HOWTO: Improve Font Rendering in LMDE

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Re: HOWTO: Improve Font Rendering in LMDE

Postby craig10x on Fri Oct 08, 2010 9:27 pm

Kazmirzak wrote:"If you look at what the script does, it sets the resolution to 96dpi and sets LCD to slight already."

funny enough, I did a clean install of LMDE and applied all updates - and the settings above were already active, and my fonts look good as they should.


i am curious...do the fonts like look as good as they would on the main edition of mint?
and did it change with the updates you did? if so, i wonder if the mint team did something to it....
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Linux Mint is funded by ads and donations.
 

Re: HOWTO: Improve Font Rendering in LMDE

Postby burtb08 on Tue Oct 12, 2010 4:12 pm

burtb08
Level 1
Level 1
 
Posts: 18
Joined: Thu Sep 09, 2010 8:25 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby leonbnu on Tue Oct 12, 2010 8:36 pm

burtb08 wrote:If you like the way Ubuntu does the font bit, have a look: http://lovingthepenguin.blogspot.com/2010/07/ubuntu-font-rendering-in-debian-squeeze.html


I actually followed this, but couldn't see any change, the font rendering was already looking good(just a little fuzzy) before i did this though.
leonbnu
Level 1
Level 1
 
Posts: 30
Joined: Thu Oct 01, 2009 6:28 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby craig10x on Tue Oct 12, 2010 8:52 pm

maybe it is like the secret ingredient in coca cola...i wonder if clem will be able to able to figure out exactly what they do to make it so beautiful...
i'm typing this from a new Kubuntu 10.10 install and everything on here looks gorgeous :)
There's something they add that gives it the magic touch... :lol:
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby runningman on Wed Oct 13, 2010 4:17 am

craigevil you are the man.Ikey`s fix was ok but the fix you supplied is amazing.I thought it was just this laptop cause windows didn`t look so good but now nice and sharp :mrgreen:
Running is more mental exercise than physical
User avatar
runningman
Level 1
Level 1
 
Posts: 10
Joined: Sat Sep 11, 2010 5:50 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby divot66 on Fri Oct 22, 2010 10:17 am

Nice job Ikey. I was beginning to think of giving up on LMDE. Worked like a charm.
divot66
Level 1
Level 1
 
Posts: 38
Joined: Sun Aug 10, 2008 12:50 am

Re: HOWTO: Improve Font Rendering in LMDE

Postby craig10x on Mon Oct 25, 2010 10:26 am

I've read on some blogs that what ubuntu has that LMDE would need is the libcairo2 patches...if that is true, i hope Clem reads this and looks into that..

Also..i was curious, in LMDE, do you have access to the new Ubuntu Fonts that became the default in Ubuntu 10.10?
Someone mentioned that you now have access to Mint 10 features, so i was wondering if ubuntu fonts was part of that...do you get that through debian
updates or through mint's own updates?
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby sgosnell on Tue Nov 02, 2010 6:19 pm

This was apparently my problem earlier, when I couldn't run the appearance changer. I ran fixfonts.sh again today, and now I can't run it again. The conky window is wonky. This is on an Asus EEE-PC 900. Removing the ~.gconf/desktop folder and restarting X fixes the problem. Something in the script is putting incorrect configuration information there.
Asus eee-pc 900 w/ 32GB SSD.
sgosnell
Level 5
Level 5
 
Posts: 686
Joined: Fri Sep 10, 2010 9:32 pm
Location: Baja Oklahoma

Re: HOWTO: Improve Font Rendering in LMDE

Postby zole052 on Thu Nov 18, 2010 8:04 am

After executing fixfonts.sh script the tab fonts on chrome browser become too small :( Every other font is ok.
Image
zole052
Level 2
Level 2
 
Posts: 59
Joined: Thu Jan 29, 2009 6:32 pm
Location: Umag, Croatia

Re: HOWTO: Improve Font Rendering in LMDE

Postby zole052 on Thu Nov 18, 2010 10:25 am

zole052 wrote:After executing fixfonts.sh script the tab fonts on chrome browser become too small :( Every other font is ok.
Image

After a shutdown everything is as it should be, problem solved :oops:
zole052
Level 2
Level 2
 
Posts: 59
Joined: Thu Jan 29, 2009 6:32 pm
Location: Umag, Croatia

Re: HOWTO: Improve Font Rendering in LMDE

Postby wilbert-vanbakel on Thu Nov 18, 2010 11:38 am

Your script is appreciated, Ikey.

I can't help but wonder (since originally Linux Mint is a derivative of Ubuntu) how likely it is that Mint would adopt the fontconfig files from Ubuntu.
I replaced the /etc/fonts and the /usr/share/fonts folders by the ones available on Ubuntu 10.10 and the result is excellent.
Does Mint have a policy in this regard?
wilbert-vanbakel
Level 1
Level 1
 
Posts: 4
Joined: Sun Mar 15, 2009 8:07 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby craig10x on Thu Nov 18, 2010 2:54 pm

If doing that gives you the ubuntu quality in the font rendering then hopefully, Clem will read this and implement it into LMDE :wink:

That's the way it should look (out of the box) one should not have to configure it on their own...mint is known for the out of box experience....
Ubuntu/Kubuntu has the best font rendering i have ever come across in linux distros...and the reason why the regular mint gnome and kde look great is because they are based on ubuntu...With direct debian, it needs to be added in...and that should be done by the mint developers rather then the users...
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby mfdemicco on Sat Nov 27, 2010 1:04 am

After spending some time using Kubuntu, the font rendering is a bit better than what I could get with LMDE. Now, I've made it just as good by installing a patched libcairo2 from http://download.tuxfamily.org/skinny/libcairo2-patched/ and followed these instructions to copy over missing font configuration files from my Kubuntu install to LMDE:

To avoid "color fringing" (AKA "rainbow blur"), you also have to enable LCD filtering. One way is to install Ubuntu's fontconfig-config package, which puts the needed settings in /etc/fonts/conf.d. Alternatively, see if you already have the following files in /etc/fonts/conf.avail:

10-antialias.conf
10-hinting.conf
10-hinting-slight.conf
11-lcd-filter-lcddefault.conf
53-monospace-lcd-filter.conf

If so, you can just create symlinks from the first directory to the other:

ln -s /etc/fonts/conf.avail/10-antialias.conf /etc/fonts/conf.d/10-antialias.conf
ln -s /etc/fonts/conf.avail/10-hinting.conf /etc/fonts/conf.d/10-hinting.conf
ln -s /etc/fonts/conf.avail/10-hinting-slight.conf /etc/fonts/conf.d/10-hinting-slight.conf
ln -s /etc/fonts/conf.avail/11-lcd-filter-lcddefault.conf /etc/fonts/conf.d/11-lcd-filter-lcddefault.conf
ln -s /etc/fonts/conf.avail/53-monospace-lcd-filter.conf /etc/fonts/conf.d/53-monospace-lcd-filter.conf

If you don't have these files, either unpack the Ubuntu .deb file and copy them over, or create a /etc/fonts/local.conf file which sets "lcdfilter" to "lcddefault". This file is XML, so I'm unable to show it here - see ArchWiki for details.

http://wiki.archlinux.org/index.php/Fon ... n#LCD_Type

For more on the importance of filtering, see Freddie Witherden's Treatise on Font Rasterisation.

https://freddie.witherden.org/pages/font-rasterisation/
mfdemicco
Level 1
Level 1
 
Posts: 36
Joined: Tue Mar 10, 2009 6:07 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby craig10x on Sat Nov 27, 2010 10:26 am

after doing that...are you finding that it now matches the rendering of kubuntu?
if it does, i hope Clem reads your post...ubuntu/kubuntu has the best rendering i have ever seen on linux and if he can get it to that quality on LMDE then it would be great...
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby mfdemicco on Sat Nov 27, 2010 11:22 am

craig10x wrote:after doing that...are you finding that it now matches the rendering of kubuntu?
if it does, i hope Clem reads your post...ubuntu/kubuntu has the best rendering i have ever seen on linux and if he can get it to that quality on LMDE then it would be great...


Yes, it looks the same to me.
mfdemicco
Level 1
Level 1
 
Posts: 36
Joined: Tue Mar 10, 2009 6:07 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby craig10x on Sat Nov 27, 2010 8:45 pm

Thanks...ok Clem...make note and check out please :D :wink:
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby craig10x on Thu Dec 02, 2010 3:42 pm

By the way...with clem's announcement of the new package of updates coming out tomorrow for those of you who are using LMDE right now, one item mentioned is improved font rendering....I would love to see some feedback here and how it looks after you install this new package....I'd especially like to know if it looks like the ubuntu/kubuntu/or the mint editions that are based on them...
Thanks :)

Oh yes...would also like to know if ubuntu fonts are included in the package since it updates you to Mint 10 (which has them available of course)...
craig10x
Level 7
Level 7
 
Posts: 1502
Joined: Fri Jul 03, 2009 12:44 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby DavidSTL on Sat Dec 25, 2010 3:52 am

Don't know if this will help with the fonts or not but seems compiz is not working by default I ran this in terminal

compiz --replace

compiz then started working and my fonts look a little better I think ?
If you what it to start when you start up you can do this.

Menu-Preferences-Startup Applications and add the command compiz --replace to there works for me.
Here or the fonts I use

FreeSans Medium 10
FreeSans Medium 10
FreeSans Medium 10
FreeSans Bold 10
Monospace 10
8)
Like I said works better for me hope it helps
David STL USA
User avatar
DavidSTL
Level 1
Level 1
 
Posts: 4
Joined: Fri Dec 24, 2010 12:03 pm

Re: HOWTO: Improve Font Rendering in LMDE

Postby torturedutopian on Wed Jan 19, 2011 1:14 pm

Hey guys !

I just switched from Kubuntu to LMDE 64. It works pretty well, I have something strange with Mozilla's apps.

In both Firefox & Thunderbird, fonts (menus & interface fonts) are too big / not the right fonts compared to what I set in the Gnome settings. Anti-aliasing seems less good than in Gnome apps.

Also, the most annoying is that Firefox litterally crawls. For instance, when zooming in Google Maps, most of the CPU is used and the animation is very jerky.

(I installed the nvidia proprietary drivers, works perfectly with compiz. The issue was the same before installing those :)

Any idea ?!
Cheers !
torturedutopian
Level 1
Level 1
 
Posts: 18
Joined: Fri Sep 10, 2010 4:45 am
Location: France

Re: HOWTO: Improve Font Rendering in LMDE

Postby rivenathos on Wed Jan 19, 2011 2:20 pm

The Ubuntu fonts are what your issue may be.

In Appearance Preferences > Fonts, change the Application font from Ubuntu 11 to Sans 10. You could change Ubuntu 11 to Ubuntu 10 if you like those fonts. Then, Firefox will have more normal-sized fonts.

That worked on my end.
Debian 7 with GNOME 64-bit
User avatar
rivenathos
Level 6
Level 6
 
Posts: 1066
Joined: Wed May 06, 2009 7:32 am
Location: USA

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Newbie Questions

Who is online

Users browsing this forum: Google Feedfetcher and 7 guests