Howto: Remove Fortune messages in the Terminal

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Re: Howto: Remove Fortune messages in the Terminal

Postby Raydog on Fri Nov 05, 2010 5:35 pm

vincent wrote:
Open a terminal and type the following:
Code: Select all
gksudo gedit /etc/bash.bashrc

in the end of the file, comment out/remove the line /usr/bin/mint-fortune, and then save the file. Open a new terminal and you should no longer see that line.


Thanks vincent, that woked for me. :D

Edit-I just read the rest of this topic and I guess I had better thank clem as well for originally posting this hint. 8)
MacBook 2.14 GHz Core 2 Duo, 3 GB memory, 250 GB 7200 rpm HD, Intel 945 Graphics.
Raydog
Level 1
Level 1
 
Posts: 37
Joined: Fri Jul 09, 2010 6:24 pm

Linux Mint is funded by ads and donations.
 

Re: Howto: Remove Fortune messages in the Terminal

Postby telic on Sat Nov 06, 2010 7:08 am

tdockery97 wrote:
telic wrote:Why on Earth is this sophomoric preference (still) a default for Mint users? Should it caution me to think twice about entrusting my enterprise environment to a collegiate OS mindset?

:roll:

You might want to open up Package Manager and install a sense of humor. :D



Would that be in the same repository as your Mushroom_Kingdom.so driver?

A plaything OS is okay at home -- but for my non-beatnik clients, Ubuntu "represents."

;)
telic
Level 3
Level 3
 
Posts: 188
Joined: Thu Mar 22, 2007 7:48 am

Re: Howto: Remove Fortune messages in the Terminal

Postby JoeInMN on Fri Nov 19, 2010 8:28 pm

Commenting out the code line is easy enough for most of us, but Profile Preferences really should have a "Show fortunes" tickbox on the General tab.
Sysinfo:
Mint 17
HP 250 G2 Notebook
Intel i3-3110M 2.40GHz/4 Gig RAM
Intel 3rd Gen Core processor Graphics Controller
Intel 7 Series/C210 Series Chipset Family High Def Audio Controller
Qualcomm Atheros QCA9565 / AR9565 Wireless Netwk Adapter (rev 01)
User avatar
JoeInMN
Level 3
Level 3
 
Posts: 106
Joined: Wed Nov 17, 2010 5:52 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby jesica on Fri Dec 03, 2010 5:51 am

thanks for the info
Image

My Linux Counter number # 566377
Mate
IT Ninja
Happy apt-get-ing!
Linux Mint Donar # 2159


Security is the separation of an asset from a threat.
User avatar
jesica
Level 9
Level 9
 
Posts: 2543
Joined: Sat Jul 18, 2009 3:54 am
Location: South Africa

Re: Howto: Remove Fortune messages in the Terminal

Postby LindseyD. on Mon Dec 13, 2010 5:17 pm

I've never touched my bashrc, but I don't have anything about fortune in it. And, needless to say, no cow and no fortunes.

And I miss them :cry:

Could someone please post the first few lines before (and maybe after?) the appropriate line so that I don't screw up putting the line in?
Mint15 KDE
LindseyD.
Level 4
Level 4
 
Posts: 260
Joined: Fri Mar 26, 2010 12:35 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby Edgpaez on Mon Dec 13, 2010 5:55 pm

JoeInMN wrote:Commenting out the code line is easy enough for most of us, but Profile Preferences really should have a "Show fortunes" tickbox on the General tab.


+1!
I love those fortune messages, but I've seen people who doesn't agree...
a click and change would be pretty good thing to add :)
Edgpaez
Level 1
Level 1
 
Posts: 17
Joined: Tue Dec 07, 2010 11:36 am

Re: Howto: Remove Fortune messages in the Terminal

Postby wayne128 on Mon Dec 13, 2010 6:01 pm

LindseyD. wrote:I've never touched my bashrc, but I don't have anything about fortune in it. And, needless to say, no cow and no fortunes.

And I miss them :cry:

Could someone please post the first few lines before (and maybe after?) the appropriate line so that I don't screw up putting the line in?


that line is the last line,, here are those lines just before

# enable bash completion in interactive shells
if [ -f /etc/bash_completion ]; then
. /etc/bash_completion
fi

# if the command-not-found package is installed, use it
if [ -x /usr/lib/command-not-found ]; then
function command_not_found_handle {
# check because c-n-f could've been removed in the meantime
if [ -x /usr/lib/command-not-found ]; then
/usr/bin/python /usr/lib/command-not-found -- $1
return $?
else
return 127
fi
}
fi

/usr/bin/mint-fortune
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: Howto: Remove Fortune messages in the Terminal

Postby LindseyD. on Mon Dec 13, 2010 6:47 pm

Thanks, wayne128. I was 99.9% sure what to do, but bashrc is NOT something I'd want to mess up. Belt & suspenders for me all the way. :)
Mint15 KDE
LindseyD.
Level 4
Level 4
 
Posts: 260
Joined: Fri Mar 26, 2010 12:35 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby grey1960envoy on Wed Jan 05, 2011 10:18 pm

In LMDE to remove the fortunes just type "gksudo gedit /etc/bash.bashrc" and remove the last "paragraph" to fi, save and close.
In a perfect world everything has it's place, Linux on my computer, windows on the wall, and M$ in the trash!
CrunchBang, LMDE, Mint 9 ,Peppermint Hackintosh and a few others :) Registered ...Machine; #432150 user ;#530829
User avatar
grey1960envoy
Level 4
Level 4
 
Posts: 477
Joined: Mon Aug 23, 2010 10:21 pm
Location: 3rd rock from the sun

Re: Howto: Remove Fortune messages in the Terminal

Postby Boringbytes on Tue Feb 01, 2011 12:55 am

Can you replace the default fortunes with a custom file?
I like most of the fortunes, but sometimes you just feel like a change.
Wishing there really was a Linux guide for the thick and stupid, so I could be reading it right now.
Boringbytes
Level 1
Level 1
 
Posts: 30
Joined: Fri Oct 15, 2010 7:16 am

Re: Howto: Remove Fortune messages in the Terminal

Postby vincent on Tue Feb 01, 2011 9:31 pm

Add any fortunes you want into /usr/share/games/fortunes/, and look at the existing fortunes in there to have an idea of how to format your own fortunes.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Howto: Remove Fortune messages in the Terminal

Postby jwalkin on Sun Mar 06, 2011 2:15 pm

There is no mint-fortune line in .bash_rc for mint 10 kde. I use the gnome version mostly and I disable it in gnome all the time. I was just trying out kde and can't find where it is hidden. Looked under /etc/profile, bash_completion, bash.rc and there is no reference to mint-fortune in any of the files. any clues here? Testing kde for our company and need to disable it.
jwalkin
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 06, 2011 2:03 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby richyrich on Sun Mar 06, 2011 2:32 pm

The easy way, open a terminal and copy/paste. or click the SELECT ALL, or type this command :
Code: Select all
touch .disable-mint-fortunes


regards, 8)
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby jwalkin on Sun Mar 06, 2011 5:25 pm

thanks richyrich. created empty file in home directory and it did not work, opened /usr/bin/mint-fortune wih nano as superuser and the last line pipes your fortune to your terminal. commented it out and restarted terminal. fortune is disabled. don't know why they took it out of bashrc in KDE.
jwalkin
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 06, 2011 2:03 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby georgezilla on Mon Apr 25, 2011 10:26 pm

Actually I'm using LM 10 and that line is nowhere in the relevant file. But there is ......

" .. # /usr/bin/mint-fortune ... "

Which appears to be the equal of what was suggested, so I commented it out. My problem was/is not on the "how" but on the here of the relevent file. Just couldn't find it anywhere.

So in LM 10, comment out that line and it goes away.

In answer to "Who hates animals"? I for one don't. I try to eat as many of them as I can every day. I just don't like them popping up and making silly remarks in my terminal.

So thank you for your help.
georgezilla
Level 1
Level 1
 
Posts: 14
Joined: Mon Apr 25, 2011 9:08 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby Forthright on Sun May 01, 2011 10:17 am

telic wrote:Why on Earth is this sophomoric preference (still) a default for Mint users? Should it caution me to think twice about entrusting my enterprise environment to a collegiate OS mindset?


A very valid point here, the very fact that putting fortunes in has spawned a thread on how to remove them is a strong indicator in itself.

Fortunes do nothing to increase the functionality of a terminal, or increase workflow, and some of us (myself included) just find them irritating.

Of course, I believe in choice. But in this case I'd strongly suggest this as being a case of opt-in rather than opt-out so as not to irritate some users :evil:
Forthright's Usability Test: "Can you do that effectively whilst holding a conversation and eating a sandwich?"
User avatar
Forthright
Level 1
Level 1
 
Posts: 15
Joined: Fri Apr 01, 2011 2:01 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby RSimpson on Sat May 21, 2011 1:59 am

I'm sure Mint used to ask whether you wanted them or not... I think the check mark was ticked by default, but it was easy to say "no". Personally, I'd love to see them on a startup or login screen, but not every time I bring up a terminal.
User avatar
RSimpson
Level 1
Level 1
 
Posts: 29
Joined: Thu Sep 13, 2007 7:24 pm

Re: Howto: Remove Fortune messages in the Terminal

Postby steogede on Sat Jul 09, 2011 8:19 am

You can also disable this for a single user using gconf:
Code: Select all
gconftool-2 --type bool /
  --set /desktop/linuxmint/terminal/show_fortunes false


Or set the default for users who don't have a setting for this yet (e.g. root, future users):
Code: Select all
sudo gconftool-2 --direct /
  --config-source xml:readwrite:/etc/gconf/gconf.xml.defaults /
  --type bool /
  --set /desktop/linuxmint/terminal/show_fortunes false


Or you can use the GUI tool gconf-editor.

NB. I have only tried this in LM 11 (that is the only LM I have ever used).

BTW, I don't mind the fortunes myself but I'm not a big fan of the Husse ones (it appears mostly to be direct quotes from his forum posts) - I'm not a big fan of these fortunes, they seem to be direct quotes from his forum posts and many of them appear pointless out of context (I suspect they are just there as a posthumous tribute?). What I don't understand is why there are 8 packages which depend on fortunes-husse - that is, so far as the package manager is concerned, I can't see any real dependency.
steogede
Level 1
Level 1
 
Posts: 1
Joined: Sat Jul 09, 2011 7:07 am

Re: Howto: Remove Fortune messages in the Terminal

Postby subeh.sharma on Tue Jul 19, 2011 3:15 am

"/usr/bin/mint-fortune" to be removed in you're on LM11.
User avatar
subeh.sharma
Level 2
Level 2
 
Posts: 52
Joined: Fri Jul 15, 2011 5:43 am

Re: Howto: Remove Fortune messages in the Terminal

Postby RubberSoul on Sat Aug 06, 2011 9:31 am

Thanks for that mate... was starting to annoy me every time I opened the terminal.
Sorted now though :D
User avatar
RubberSoul
Level 1
Level 1
 
Posts: 11
Joined: Fri Jul 29, 2011 6:33 pm
Location: Melbourne, Australia

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Tutorials / Howtos

Who is online

Users browsing this forum: Jim Hauser and 11 guests