HOW TO: Solve your LMDE audio issues

Write tutorials here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

HOW TO: Solve your LMDE audio issues

Postby blowtorch on Sun Oct 31, 2010 11:53 am

LMDE came with pulseaudio installed but not configured. The information contained here solves the configuration issues.
This solves multiple audio issues like flash player audio problems, running multiple audio programs at once and making some programs function correctly.

This was originally posted by omenest here (all credit to him) viewtopic.php?f=141&t=55381#p318668

Code: Select all
sudo gedit /etc/asound.conf


paste the following code in the file asound.conf:

Code: Select all
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}


Save the file

Reboot your PC
Last edited by blowtorch on Mon Nov 01, 2010 10:31 am, edited 2 times in total.
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Linux Mint is funded by ads and donations.
 

Re: Solve your LMDE audio issues <<< sticky me

Postby c7p on Sun Oct 31, 2010 12:16 pm

Thank you for the post :) , it solved the second problem occured after long time regarding my audio-card :D :D .
c7p
Level 1
Level 1
 
Posts: 14
Joined: Fri Oct 08, 2010 5:10 pm

Re: Solve your LMDE audio issues <<< sticky me

Postby blowtorch on Sun Oct 31, 2010 2:29 pm

c7p wrote:Thank you for the post :) , it solved the second problem occured after long time regarding my audio-card :D :D .


I am glad it helped you are one of the many people who have resolved your issue with this simple yet effective solution. The just reaffirms the need for this information to be stickied.
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Re: Solve your LMDE audio issues <<< sticky me

Postby Oscar799 on Mon Nov 01, 2010 3:35 am

Thread stickied
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8942
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Solve your LMDE audio issues <<< sticky me

Postby blowtorch on Mon Nov 01, 2010 9:48 am

oscar799 wrote:Thread stickied


Thanks :mrgreen:
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Postby julio00 on Mon Nov 01, 2010 8:57 pm

I tried this solution to my audio problems but i'm still getting problems.

I have one Creative X-fi Express Music and the sound was working normally but I notice when I use totem, vlc or mplayer the volume control it's linked to the Master of the sound card. If I move the slider on Totem or VLC I can see the master control on alsamixer going up and down. If I open sound files with VLC and Totem at the same time both programs controls the master on the Sound Card.

Any idea?

Thanks
julio00
Level 1
Level 1
 
Posts: 1
Joined: Mon Nov 01, 2010 8:42 pm

Re: HOW TO: Solve your LMDE audio issues

Postby blowtorch on Tue Nov 02, 2010 2:32 pm

julio00 wrote:I tried this solution to my audio problems but i'm still getting problems.

I have one Creative X-fi Express Music and the sound was working normally but I notice when I use totem, vlc or mplayer the volume control it's linked to the Master of the sound card. If I move the slider on Totem or VLC I can see the master control on alsamixer going up and down. If I open sound files with VLC and Totem at the same time both programs controls the master on the Sound Card.

Any idea?

Thanks


This is not a bug, the programs are adjusting the master volume like they were designed to.

Within the pulseaudio volume control you can individually adjust application volume.
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Postby asymmetros on Wed Nov 03, 2010 1:36 pm

Worked for me :D
Thank you very much both of you!
Sid Mint Xfce -32, Openbox, KDE, Enlightenment, Liquorix Kernel
HP Compaq Presario cq71, Intel Core 2 Duo T4400 @ 2.2 GHz, 3 GB DDR2 RAM, Nvidia Geforce G 103M
asymmetros
Level 4
Level 4
 
Posts: 310
Joined: Tue Jun 01, 2010 5:34 pm
Location: athens

Re: HOW TO: Solve your LMDE audio issues

Postby lakehousetech on Wed Nov 10, 2010 8:29 pm

Although I have not encountered issues relating to loss of sound, my audio only comes out of one of the speakers of my notebook. It's also very quiet, even on the maximum setting. I have adjusted the limited configuration, but that didn't help. I haven't found any other threads with the same problem. Not sure if this is directly related to pulse audio, but using ALSA in place of that did not help either. lspci output:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Micro-Star International Co., Ltd. Device 7220
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at f8ef8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [130] Root Complex Link
Kernel driver in use: HDA Intel
Wherever you go, there you are... - Buckaroo Banzai
http://www.lakehousetech.com
- Mint Debian
User avatar
lakehousetech
Level 4
Level 4
 
Posts: 454
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Re: HOW TO: Solve your LMDE audio issues

Postby kwevej on Fri Nov 12, 2010 12:59 pm

I've solved problems by purging pulseaudio ;)

some howto here: viewtopic.php?f=42&t=60485
Last edited by kwevej on Sat Nov 27, 2010 1:23 pm, edited 1 time in total.
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: HOW TO: Solve your LMDE audio issues

Postby sirpecangum on Sun Nov 14, 2010 5:29 pm

Thank you!
sirpecangum
Level 1
Level 1
 
Posts: 2
Joined: Sun Nov 14, 2010 5:25 pm

Re: HOW TO: Solve your LMDE audio issues

Postby blowtorch on Tue Nov 16, 2010 12:08 am

kwevej wrote:I've solved problems by purging pulseaudio ;)


ya ... that's not really a fix (i guess it is in a way) ... this was meant for people who want to use pulseaudio

i prefer pulseaudio because of it's preamp ability and i can easily switch between my speakers and hdmi output
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Postby lakehousetech on Fri Nov 19, 2010 1:03 am

I've found no difference after purging pulse-audio. For now I'm using external speakers and the sound is great. Will have to get some time to play with the hardware configuration so all the laptop speakers work in the future (oh and hopefully make them loud as well). :)
Wherever you go, there you are... - Buckaroo Banzai
http://www.lakehousetech.com
- Mint Debian
User avatar
lakehousetech
Level 4
Level 4
 
Posts: 454
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Re: HOW TO: Solve your LMDE audio issues

Postby EdgarManhattan on Sat Nov 20, 2010 7:28 pm

In addition to the above, I had to install the beta Adobe Flash player "square" here:
http://labs.adobe.com/downloads/flashplayer10.html

The standard Flash did not output any sound. "Square" is a great flash player, it's visuals are better than the standard release, too.
EdgarManhattan
Level 1
Level 1
 
Posts: 7
Joined: Sat Nov 20, 2010 7:22 pm

Re: HOW TO: Solve your LMDE audio issues

Postby beli0135 on Sun Nov 21, 2010 5:38 am

Here is best solution to sound problem:

$ sudo apt-get remove pulseaudio
$ sudo killall pulseaudio
$ sudo killall pulseaudio
pulseaudio: no process killed
$ (echo Package: pulseaudio; echo Pin: release a=fakerepo; echo Pin-Priority: 1999) |
sudo tee -a /etc/apt/preferences

I don't really know why developers are pushing (with foot) PulseAudio garbage. It's just GARBAGE. Doesn't work properly. Never did, probably never will.
Best regards,
Emil Beli

http://www.beli.ws/blog
User avatar
beli0135
Level 2
Level 2
 
Posts: 64
Joined: Fri Jul 24, 2009 10:41 pm
Location: Belgrade, Serbia

Re: HOW TO: Solve your LMDE audio issues

Postby kwevej on Sun Nov 21, 2010 9:37 am

lakehousetech wrote:I've found no difference after purging pulse-audio. For now I'm using external speakers and the sound is great. Will have to get some time to play with the hardware configuration so all the laptop speakers work in the future (oh and hopefully make them loud as well). :)


I've found a difference - much lower CPU usage while listening to music.

The idea behind PulseAudio is fine, sadly, the implementation is not.
User avatar
kwevej
Level 5
Level 5
 
Posts: 624
Joined: Mon Mar 22, 2010 3:35 pm
Location: Delft / Prague [@ LMDE]

Re: HOW TO: Solve your LMDE audio issues

Postby zole052 on Wed Nov 24, 2010 6:10 am

Now my sound works perfectly Image
zole052
Level 2
Level 2
 
Posts: 59
Joined: Thu Jan 29, 2009 6:32 pm
Location: Umag, Croatia

Re: HOW TO: Solve your LMDE audio issues

Postby kruijf on Thu Nov 25, 2010 5:47 am

blowtorch wrote:LMDE came with pulseaudio installed but not configured. The information contained here solves the configuration issues.
This solves multiple audio issues like flash player audio problems, running multiple audio programs at once and making some programs function correctly.

This was originally posted by omenest here (all credit to him) viewtopic.php?f=141&t=55381#p318668

Code: Select all
sudo gedit /etc/asound.conf


paste the following code in the file asound.conf:

Code: Select all
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}


Save the file

Reboot your PC


I used this solution and it works great :)
Also i posted this solution on the dutch Mint forum.
Acer Aspire 5749: Linux Mint 13 Cinnamon


dropbox

Linux steunpunt Soest

Twitter: @bdekruijf

Team Member of the Dutch support forum.
User avatar
kruijf
Level 3
Level 3
 
Posts: 117
Joined: Sat May 29, 2010 2:43 pm
Location: Soest, Netherlands

Re: HOW TO: Solve your LMDE audio issues

Postby Fornhamfred on Thu Nov 25, 2010 2:57 pm

Have been having problems with Pulse running my CPU at 100%. Making this entry seems to have resolved the problem but I am not sure why. CPU usage for pulse is not even registering at 1% now.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: HOW TO: Solve your LMDE audio issues

Postby CDS on Mon Nov 29, 2010 3:36 am

I installed LMDE in 2 computers. One is acer aspire netbook. It works the sound using tutorial by blowtorch in this forum. Another is Acer Aspire 4710 notebook. It works the sound with the built-in speaker but it doesn't work with headphone. I tried Linuxmint 10; ubuntu 10.10. All are the same result. Speaker works but headphone doesn't. I tried solution for Ubuntu 9.10 but it doesn't work on Ubuntu version 10.10. Is this problem related to hardware related issue?
Desperately needed help!
CDS
Level 1
Level 1
 
Posts: 35
Joined: Tue Mar 09, 2010 11:22 am

Linux Mint is funded by ads and donations.
 
Next

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 1 guest