Black screen in lmde on nvidia cards , how to fix.

Old threads created long before the LMDE forum restructuring

Black screen in lmde on nvidia cards , how to fix.

Postby gazza on Fri Dec 24, 2010 8:04 pm

This issue has become a real problem with the release of linuxmint-debian-201012-gnome-dvd-i386

If you have that version of lmde it is strongly suggested you don't attempt an install. A newer version has been released. We apologize for any inconvenience.

Here is the link to the newer 201101 release LMDE 201101 32-bit re-spin to read all about it, and also has the link to the iso.

Below is some tips for the adventurous to attempt an install, not recommended for linux beginners as the possibility of destroying grub is likely.


Thanks to Eric Jones, for his hard work in helping solve this issue :)
And to Justin for refining the fix as the original didn't work for me .


Place cd in computer, switch on, at the grub prompt:-

Down arrow to "Compatibility mode"
Hit Tab key to edit
the line will read something like this

/casper/vmlinuz boot=live xforcevesa initrd=/casper/initrd.lz and a heap more , NOTE the word "xforcevesa" after that insert the word "nomodeset" , without the quote. Hit enter to boot the dvd. It will be very sluggish, but you will be able to install.

then boot it , this is only a temporary fix in order to boot.


Once you have install lmde , (here my installer stalled on installing grub, so the rest is untested, except that Eric managed it)
On the first boot up, you must edit grub again, hit the letter 'e' to do it.
with the above code, at the line that ends with "ro quiet", affix " -- nouveau.setmode=0"

When you have booted the install, open a terminal and
Code: Select all
sudo apt-get remove xserver-xorg-video-nouveau


That will permanently get rid of Nouveau from lmde. Reboot if you wish to install a nvidia driver


Installing your Nvidia driver ,

For nvidia drivers visit http://www.nvidia.com/Download/index.aspx , enter your card into the search and click search.
Then download the driver.

Then open a terminal in the directory the driver is in.
Code: Select all
 sudo sh NV*.run --no-x-check


This is tricky, as a few errors popup that can throw you right off, treat it as a game, and try to get to the next level by answering the ?'s right, it's not a simple yes yes install

Then reboot and your new driver should be working
Image
Don't miss the donut by looking through the hole.
User avatar
gazza
Level 2
Level 2
 
Posts: 79
Joined: Sun Aug 30, 2009 1:32 am

Linux Mint is funded by ads and donations.
 

Re: Black screen in lmde on nvidia cards , how to fix.

Postby linXea on Fri Dec 24, 2010 8:17 pm

Looks good.. If I had a nVidia card available I would try it myself. Good initiative, keep it up buddy =) :mrgreen:
Image
Dektop: AMD Quad-Core, 4GB RAM, ATI HD3650silent, 33TB harddrive
Laptop: Lenovo Thinkpad x201, Intel core2centrino P9600, 4GB RAM, 750gb
User avatar
linXea
Level 3
Level 3
 
Posts: 182
Joined: Mon Aug 31, 2009 7:06 am
Location: Uppsala, Sweden

Re: Black screen in lmde on nvidia cards , how to fix.

Postby wilberfan on Fri Dec 24, 2010 11:32 pm

I'm trying to install from a USB thumb drive, and this workaround does NOT work for me... Haven't tried it yet with a DVD...

In addition to the screen still going black--I now get repeated system beeps until I reboot or shutdown! :shock:
wilberfan
Level 1
Level 1
 
Posts: 16
Joined: Sat Sep 18, 2010 10:21 am

Re: Black screen in lmde on nvidia cards , how to fix.

Postby justin on Sat Dec 25, 2010 1:38 am

I posted this in another thread. I was able to test this successfully on an nvidia card. Boot up using nomodeset as a boot option and in compatibility mode. Please test and get back to me. I had massive address errors in nouveau when booting up which was tainting the kernel.

Gazza I'm guessing this is the guy I asked to tell you the info if my fix worked?

Please let us know if this fixes the issue - I've been almost feverish working on it.
justin
Level 1
Level 1
 
Posts: 38
Joined: Thu Nov 12, 2009 10:13 pm

Re: Black screen in lmde on nvidia cards , how to fix.

Postby myfreedom on Sat Dec 25, 2010 12:13 pm

I have this problem. I removed nvidia card and plugged ATI Radeon x1650. The same black screen and no boot
User avatar
myfreedom
Level 1
Level 1
 
Posts: 8
Joined: Fri Sep 10, 2010 12:42 am

Re: Black screen in lmde on nvidia cards , how to fix.

Postby Buba on Sat Dec 25, 2010 1:28 pm

it doesn't work
Buba
Level 1
Level 1
 
Posts: 2
Joined: Mon Jul 05, 2010 5:29 pm

Re: Black screen in lmde on nvidia cards , how to fix.

Postby ahulsbos on Sun Dec 26, 2010 8:25 am

I ran into the same problem with my Compaq nc 8000 laptop, which sports an ATI Mobility Radeon 9600. Just adding "nomodeset" before the "--" in the boot line didn't help. However, in compatibility mode the "/var/log/Xorg.0.log" file yielded a clue:

(EE) VESA: Kernel modesetting driver in use, refusing to load

It turned out the "radeon" driver was being loaded as well as the "vesa" one (you could see it happening as the font of the terminal changed). So this enabled me to start the installation process: edit the compatibility mode boot line to add both "nomodeset" and "radeon.modeset=0".

The installer is running now. Let's see what the fun will be after the reboot.
ahulsbos
Level 1
Level 1
 
Posts: 3
Joined: Sun Dec 26, 2010 8:10 am

Linux Mint is funded by ads and donations.
 

Return to Archive

Who is online

Users browsing this forum: No registered users and 1 guest