Mint 10 Skype Sound & Video Tutorial

Write tutorials here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Mint 10 Skype Sound & Video Tutorial

Postby gazza on Thu Dec 02, 2010 7:04 pm

This is meant as a Common Issues Tutorial for How To get Skype working in LinuxMint 10.
(LMDE 64bit users Only, need to sudo apt-get install ia32-libs-gtk)

Sound.
output (speakers)

The most common reason for sound not working in Mint 10 is that Pulse chose the wrong driver. The fix is to click volume icon, choose preferences, (LMDE users, this is PulseAudio Volume Control found in the Video & Audio menu, it has a slightly different layout)

Screenshot-Sound Preferences.png
Screenshot-Sound Preferences.png (38.15 KiB) Viewed 18488 times


Up top is a slide bar, make sure this is at or near Maximum and the "Mute" is not on.

In the 'hardware' tab, down the bottom is a dropdown box, select each driver, one at a time and play sound as the "Test Button" doesn't work so ignore it, use a video or mp3 file as a test, to make sure, play the sound 'fresh' after each change of hardware driver as continuous play may only use the driver it first started playing on.

input(mic)
step 1
Following on from the above 'output' sound issue, go to the 'input' tab , make sure the input volume is at least halfway and that it is Not muted. For the 'Connector' choose which microphone you think is correct Microphone 1 or 2. Talk to the microphone, if the input level indicator shows that it's working , move to step 3

step 2
If neither work, go to the hardware tab, as in the above 'output' guide, check the driver, In theory, you should have sound output working first, so will have something like "Analog Surround 5.1 Output + Digital Stereo (IEC958) input", speakers work, but Microphone doesn't. Check the dropdown box and see if there is another "Analog Surround 5.1 Output" most likely with "+ Analog Stereo Input" , try that one, and go test the sound input again, sound output as well to be safe. If you can not get the 'input' indicator to work, then it's beyond this tutorial, but trying step 3 won't hurt, and maybe it will work with one of the drivers...

step 3
To verify and test sound input, go to mint menu -> Sound & Video -> "Sound Recorder". This application has had a few issues over time and to be on the safe side I recommend that you use "Record as: Voice, Lossless (.wav type)" to make sure it's not the app that is the problem. Make a short recording testing the mic, play back.. If sound is too soft or too loud and distorted, go back to the 'volume preferences' Input tab and change the input volume to suite , Under normal circumstances the marker 'Unamplified' is the optimum, past that your voice becomes distorted.

step 4
Open Skype, click the little blue icon bottom left corner, choose 'Options' , then choose "Sound Devices" in the Options dialog. Here , the first three settings should all be "PulseAudio server (local). If not, make them so. Try the test sound and test call. If you got your speakers and mic to work in the previous steps, then these should work.
If there is still a problem, then it's past the purview of this tutorial, suggestion is to google your sound device with the words "Skype Ubuntu Maverick" and hope to find a forum where someone has solved your specific hardware issue. To get your sound device information, open a terminal and type the following in..
Code: Select all
inxi -xA

Note! in a terminal alsamixer , is a last resort. Sometimes you need to find 'capture' , mic and mic booste, and raise their volumes and some cases un-mute them. Read it carefully it has a help option. (LMDE users Only, you must run "sudo alsactl store", to save the settings, most cases it will reboot fine, for some reason on rare machines "sudo alsactl restore" at each boot is needed to bring settings back)

Webcam

To check if your webcam works do the following.

Hit Alt and F2 , in the dialog type "gstreamer-properties". in that dialog, the second tab 'video' , test the "Default Input" , make sure the "Device" is your webcam, the "Plugin" usually defaults to "Video for Linux 2 (v4l2)" which is the most common driver base for most webcams. Usually nothing needs to be changed here and the test works fine. If fiddling doesn't produce any results, google is your friend, use the make and model of your webcam along with "Ubuntu Maverick" and hope to find a forum where someone has solved your specific hardware issue.

Screenshot-Multimedia Systems Selector.png
Screenshot-Multimedia Systems Selector.png (33.7 KiB) Viewed 18488 times


Webcam is Working, but Not in Skype.

This is a common issue with version 2.1.0.81 of Linux Skype and Mint 10 . I've had this issue myself and a search of google came up with a solution. Some simple, some very complex. I'll write as simple as possible for people who are not that familiar with Linux.

First , Make sure Skype is NOT on. turn it off!

Open a terminal, you'll find that in mint menu. Read this little help on how to copy paste.
There are Two ways to paste in Linux , the ctrl+c to copy and ctrl+v to paste (in a terminal it is shift+ctrl+v to paste) OR highlight text, hover mouse at insertion point and Click the Middle Scrollwheel button.

now copy paste ONE of the following two lines in the terminal and hit enter in the terminal to run skype. Click the bottom left blue icon in skype, choose "Options", find "Video Devices" , and click the 'test' button.

Skype Webcam Test Options image.
Screenshot-Options.png
Screenshot-Options.png (56.48 KiB) Viewed 18488 times


Does your webcam show up? No? , quit skype, try the second line, paste it in the terminal, hit enter, do above and test the webcam. Does it work? if yes, continue, if no, sorry, you'll have to google your webcam details along with the words "Ubuntu Maverick" and hope to find a forum where someone has solved your specific hardware issue.

The Two Different Lines..
32bit OS use these
Code: Select all
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype

Code: Select all
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype


64bit OS use these
Code: Select all
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype

Code: Select all
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype



If your Webcam Now works in skype with one of the above commands in a terminal, this is the simplest method I can find, unfortunately it's no a simple point and click one.

Make an executable bash file in /usr/bin called skype.sh and change the mint menu skype app to use skype.sh

How to achieve this.
In a terminal paste/type the following

Code: Select all
sudo gedit /usr/bin/skype.sh


You will be asked for your password, do not panic, it will not give feedback of dots or * as you type your password, that is normal, just enter your password and hit enter. An empty document will appear. In that document paste/type the following. Make sure you use the line that worked for you in the following script, replacing the example one. NOTE, in the script skype is on it's own line...

Code: Select all
#!/bin/bash
export LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so
skype &


Double check you have the right line that worked for you, in front of the word "export" in this document , then:-
Save and close the document.

Open a terminal paste/type the following. This will make the file executable

Code: Select all
sudo chmod 755 /usr/bin/skype.sh


If this was done right, typing skype.sh in a terminal, will have skype open, double check the cam still works. If it doesn't , go back and check you put the right line in front of the word 'export' in the skype.sh script you just made, and that you made the script executable.

Now Fixing the skype launcher in mint menu.

Right click mint menu, "Edit Menu" , find Skype click on it then click the "Properties" on the right hand side of that dialog (LMDE users double click it). In the command where it says 'skype' , replace that with skype.sh

Now skype will call skype.sh and use that script everytime it launches. Hope all went well, happy skyping :)

This has been edited 2011-01-02 , and a thanks to miisterwright for having an issue with it :)
Last edited by xenopeek on Wed Jan 09, 2013 12:57 pm, edited 1 time in total.
Reason: Unstickied
Image
Don't miss the donut by looking through the hole.
User avatar
gazza
Level 2
Level 2
 
Posts: 79
Joined: Sun Aug 30, 2009 1:32 am

Linux Mint is funded by ads and donations.
 

Re: Mint 10 Skype Sound & Video Tutorial

Postby Oscar799 on Sat Dec 04, 2010 4:28 am

Made sticky
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8942
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Mint 10 Skype Sound & Video Tutorial

Postby linXea on Sat Dec 04, 2010 5:21 am

Very nice tutorial. I am sure it will come in handy quite often :)

cheers o/
Image
Dektop: AMD Quad-Core, 4GB RAM, ATI HD3650silent, 33TB harddrive
Laptop: Lenovo Thinkpad x201, Intel core2centrino P9600, 4GB RAM, 750gb
User avatar
linXea
Level 3
Level 3
 
Posts: 182
Joined: Mon Aug 31, 2009 7:06 am
Location: Uppsala, Sweden

Re: Mint 10 Skype Sound & Video Tutorial

Postby miisterwright on Wed Dec 29, 2010 4:54 am

I'm able to get Skype working perfectly by running the following in a terminal:
Code: Select all
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype


But neither entering that code in the properties of Skype in the "Applications" menu or entering it with ALT+F2 works properly. Skype will run, but when I test the video I get an error about V4L2 and not being a JPEG. Seems the preload command is being ignored.

I also created an executable "skype.sh" file and the results are the same as above. I've tried selecting "Run in Terminal" as well.

So my question is why would the command in the menu properties or Alt+F2 give a different result than a command given in a terminal?
miisterwright
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 29, 2010 4:35 am

Re: Mint 10 Skype Sound & Video Tutorial

Postby Jinryu on Thu Dec 30, 2010 7:23 am

Gazza, I've tried to get my Quickcam STX working for literally over a year with various other methods. I'm running Linux Mint 9 (standard 32-bit edition) and your method works PERFECTLY for me. Thanks so much!
Jinryu
Level 1
Level 1
 
Posts: 8
Joined: Wed Mar 31, 2010 5:46 pm

Re: Mint 10 Skype Sound & Video Tutorial

Postby gazza on Fri Dec 31, 2010 10:36 pm

miisterwright wrote:I'm able to get Skype working perfectly by running the following in a terminal:
Code: Select all
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype


But neither entering that code in the properties of Skype in the "Applications" menu or entering it with ALT+F2 works properly. Skype will run, but when I test the video I get an error about V4L2 and not being a JPEG. Seems the preload command is being ignored.

I also created an executable "skype.sh" file and the results are the same as above. I've tried selecting "Run in Terminal" as well.

So my question is why would the command in the menu properties or Alt+F2 give a different result than a command given in a terminal?


are you sure you have skype.sh written correctly , in your case

Code: Select all
#!/bin/bash
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype



Did you chmod the file as explained? to test run skype.sh in a terminal, it should launch skype. then edit the skype command in mint menu to be skype.sh
Image
Don't miss the donut by looking through the hole.
User avatar
gazza
Level 2
Level 2
 
Posts: 79
Joined: Sun Aug 30, 2009 1:32 am

Re: Mint 10 Skype Sound & Video Tutorial

Postby miisterwright on Sat Jan 01, 2011 12:03 am

gazza wrote:are you sure you have skype.sh written correctly , in your case

Code: Select all
#!/bin/bash
LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype


Yes. 'skype.sh' works when I enter it into the terminal, but not when I use it for the command in the menu.

Something in my configuration has changed since I started with this problem, because I discovered that I know longer need to use the preload command; the normal 'skype' command works just fine now... when it's entered into a terminal.

I just can't figure out why a command in the menu wouldn't produce the same result as the same command entered into a terminal.
miisterwright
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 29, 2010 4:35 am

Re: Mint 10 Skype Sound & Video Tutorial

Postby gazza on Sun Jan 02, 2011 4:17 am

Sorry miisterwright but I found out you did the right thing, wasn't your fault.

I just installed lmde64 and it took a bit of tweeking to get things right, but found my above solution isn't the be all and end all. The skype.sh didn't work for me either, in a terminal skype.sh did, but replace the command skype with skype.sh in the mint menu and it still won't work. It took a bit of hit and miss, but found the solution:-

Code: Select all
#!/bin/bash
export LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so
skype &


Even though you got it going, this will help others I hope, it's very annoying when people tell you that it will work, and you find out it doesn't
Image
Don't miss the donut by looking through the hole.
User avatar
gazza
Level 2
Level 2
 
Posts: 79
Joined: Sun Aug 30, 2009 1:32 am

Re: Mint 10 Skype Sound & Video Tutorial

Postby Drizz on Sun Jan 30, 2011 6:37 pm

great tutorial and video works fine now, however the mic doesn't.
if i make a call i can see and hear others and they can see me but they cannot hear me.

i'm not sure what the webcam is, only it;s a logitech
Drizz
Level 1
Level 1
 
Posts: 45
Joined: Fri May 22, 2009 2:03 pm

Re: Mint 10 Skype Sound & Video Tutorial

Postby Drizz on Sun Jan 30, 2011 6:47 pm

Thing i found what the issue was, did have the webcam selected in the input properties.

http://community.linuxmint.com/tutorial/view/219
Drizz
Level 1
Level 1
 
Posts: 45
Joined: Fri May 22, 2009 2:03 pm

Re: Mint 10 Skype Sound & Video Tutorial

Postby youngdaddytc on Mon Apr 11, 2011 11:18 pm

is there a way to separate the speaker that rings from the speaker you hear when you talk to someone? i have a usb phone, but in the skype options all i get is pulseaudio server for everything, with no other choice. if i go to my linux mint sound preferences, in the hardware tab i can see both the internal audio (desktop speakers) and my usb headset. it seems though, that skype doesn't want to see them and therefore....

if i use the usb headset for everything, calls work... but i never hear the phone when it rings. likewise, if i set the linux default audio settings to internal (desktop speakers) then i do hear the ringing, but my phone call becomes a 'speaker phone'....whereas i'd like to have the phone call conversation come through the usb headset.

anyone know of a simple fix for this? im stumped.
youngdaddytc
Level 2
Level 2
 
Posts: 64
Joined: Mon Mar 08, 2010 9:52 pm
Location: Rockford, Illinois / Cape Town, South Africa

Re: Mint 10 Skype Sound & Video Tutorial

Postby youngdaddytc on Tue Apr 12, 2011 12:35 am

youngdaddytc wrote:is there a way to separate the speaker that rings from the speaker you hear when you talk to someone? i have a usb phone, but in the skype options all i get is pulseaudio server for everything, with no other choice. if i go to my linux mint sound preferences, in the hardware tab i can see both the internal audio (desktop speakers) and my usb headset. it seems though, that skype doesn't want to see them and therefore....

if i use the usb headset for everything, calls work... but i never hear the phone when it rings. likewise, if i set the linux default audio settings to internal (desktop speakers) then i do hear the ringing, but my phone call becomes a 'speaker phone'....whereas i'd like to have the phone call conversation come through the usb headset.

anyone know of a simple fix for this? im stumped.


reply to self...

found my own fix. went to pulseaudio preferences, and there now were a bunch of checkboxes, some for this and some for that. i just checked 'add virtual output device for simultaneous output on all local sound cards.'

now audio plays through all sources, but if i want a private call i can just turn down the speaker volume on the desktop. problem solved, sort of. :-)
youngdaddytc
Level 2
Level 2
 
Posts: 64
Joined: Mon Mar 08, 2010 9:52 pm
Location: Rockford, Illinois / Cape Town, South Africa

Mint 11.0-64 & Skype using an Envison USB 2.0 web cam

Postby marvinudy on Tue May 31, 2011 9:39 pm

Gazza,

Thanks for the great 'how-to'. I followed the procedure and the web cam is up and running in Skype. Tomorrow I will help my friend and hopefully 'fix' his Skype web cam video. It appeared necessary to reboot to reinitialize the camera.

I also applied the 'skype.sh' command in the V4L2UCP 'preview-configpreview' for a working web cam in Skype.

Best regards,

marvinudy
marvinudy
Level 1
Level 1
 
Posts: 19
Joined: Mon Aug 27, 2007 9:24 pm

Re: Mint 10 Skype Sound & Video Tutorial

Postby Beansof57 on Mon Aug 01, 2011 1:43 pm

I'm a genuine newbie and am not what could be described as a computer buff. I'm on Katya and was having webcam problems in that it just wasn't working.
I began following the instructions, or so I thought, 3 or 4 times all with no results. Then I really DID follow the instructions, spaces, things on different lines, making sure that no unwanted spaces were creeping into the copy/paste process, etc. Worked a bleeding treat smooth as a baby's bottom. Thanks, thanks thanks. To use the webcam I was having to go to my laptop and revert to XP.
BTW, I was having trouble with Pulseaudio until I replaced it with Alsa and, yet again, following instructions to the letter won the fair lady. Well at least I was able to speak to her and, now, I can even see her. That may not be at all advisable in some cases, of course! :lol:
Beansof57
Level 1
Level 1
 
Posts: 7
Joined: Thu Mar 03, 2011 12:00 pm
Location: Barcelona - Catalunya

Re: Mint 10 Skype Sound & Video Tutorial

Postby jinzun on Sun Aug 14, 2011 8:41 pm

Excellent tutorial. Thanks for taking the time.

The command worked for me on my 64bit, homemade, overheating, ancient box.

After years of using RH then Fedora exclusively, I just recently made the switch to Mint (after the FC15, Gnome3 train wreck) and love it. Great OS, community, and support.

Thanks again.
jinzun
Level 1
Level 1
 
Posts: 1
Joined: Sun Aug 14, 2011 8:35 pm

Re: Mint 10 Skype Sound & Video Tutorial

Postby csn_0 on Thu Dec 29, 2011 7:25 pm

i am new to linux. i have just installed mint12 32bit os and like many users, have no-display problem with my logitech webcam while using skype.

following this tutorial, i tried to trigger the webcam with

LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype or
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

without success as these files only reside in /usr/lib/i386-linux-gnu/libv4l/

when i LD_PRELOAD either of the amended address links in mint Terminal, the webcam works, but it doesn't when i created the skype.sh at /usr/bin/. i have accordingly edited the properties path in menu for skype.

funny thing is mint wouldn't allow me to save the skype.sh file to /usr/lib/i386-linux-gnu/libv4l/ dicretory to test whether skype works from there.

i would appreciate it if a guru can come to point me to the right direction. tks.
csn_0
Level 1
Level 1
 
Posts: 1
Joined: Thu Dec 29, 2011 6:58 pm

Re: Mint 10 Skype Sound & Video Tutorial

Postby Anfield800 on Mon Mar 26, 2012 5:18 pm

Hi, new to Linux and the forum. Just wanted to say thanks for this tutorial, I've fixed my Skype problem AND I kind if understood what I was doing to fix it.

Thanks again.

Lee
Anfield800
Level 1
Level 1
 
Posts: 11
Joined: Sat Mar 24, 2012 2:56 pm

Linux Mint is funded by ads and donations.
 

Return to Tutorials

Who is online

Users browsing this forum: No registered users and 20 guests