Package management broken, no LinuxMint module, bad Opera

Questions about applications and software
Forum rules
Before you post please read this

Package management broken, no LinuxMint module, bad Opera

Postby JoeInMN on Wed Jan 26, 2011 11:10 am

My apologies if there is an existing thread for this somewhere; I couldn't come up with a search entry that didn't generate thousands of results that I'm not able to read through. If there is a solution already posted, point me at it and I will link it here as well.

I recently somehow managed to break package management on my Julia system. It's hard to remember the exact steps that led to this, but as it stands, I have Opera marked for removal and apparently frozen in that state, as Synaptic shows its package with a red X and a red selection bar across all columns; I am not able to unmark, reinstall or remove it. I was managing Opera with the http://deb.opera.com/opera/ repository; it doesn't seem to matter whether or not I have it enabled in Sources. Synaptic puts out an error box saying "E: opera: subprocess installed post-removal script returned error exit status 1" whenever I try to install anything. Here is what happens when I try to install via the Terminal; I don't have the tech knowledge to interpret all of this:

===============================================
jpl@jpl-B701 ~ $ sudo apt-get install soundconverter
[sudo] password for jpl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
opera
The following NEW packages will be installed:
soundconverter
0 upgraded, 1 newly installed, 1 to remove and 30 not upgraded.
1 not fully installed or removed.
Need to get 0B/110kB of archives.
After this operation, 30.1MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 289292 files and directories currently installed.)
Removing opera ...
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/chrome" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: error processing opera (--remove):
subprocess installed post-removal script returned error exit status 1
Processing triggers for menu ...
Errors were encountered while processing:
opera
E: Sub-process /usr/bin/dpkg returned an error code (1)

======================================================

Here is an attempt to start Software Center:

=====================================================
jpl@jpl-B701 ~ $ gksudo software-center
from softwarecenter.app import SoftwareCenterApp
File "/usr/share/software-center/softwarecenter/app.py", line 37, in <module>
from softwarecenter.db.application import Application, DebFileApplication
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint

======================================================

Whatever is causing the Opera problem and the missing LinuxMint module, it seems to be preventing me from installing or removing packages at all, and I need to fix it as soon as possible.

Thanks!
Sysinfo:
Mint 17
HP 250 G2 Notebook
Intel i3-3110M 2.40GHz/4 Gig RAM
Intel 3rd Gen Core processor Graphics Controller
Intel 7 Series/C210 Series Chipset Family High Def Audio Controller
Qualcomm Atheros QCA9565 / AR9565 Wireless Netwk Adapter (rev 01)
User avatar
JoeInMN
Level 3
Level 3
 
Posts: 106
Joined: Wed Nov 17, 2010 5:52 pm

Linux Mint is funded by ads and donations.
 

Re: Package management broken, no LinuxMint module, bad Oper

Postby viking777 on Wed Jan 26, 2011 11:55 am

Have a read through this post here and adapt it to your situation, that might fix it.

http://forums.linuxmint.com/viewtopic.php?f=47&t=60074&p=345478&hilit=aptitude#p345478
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Package management broken, no LinuxMint module, bad Oper

Postby JoeInMN on Wed Jan 26, 2011 4:27 pm

Thanks for the link. I tried substituting Opera for Firefox in the process, but I'm not sure that it did anything for my particular problem. Synaptic still shows Opera with a big red stripe, and asks me to confirm that I want to discard marked changes when I quit. How much of the following Terminal conversation is useful, I don't know, so I'll just go ahead and post the whole thing:

===================================================
jpl@jpl-B701 ~ $ sudo aptitude update
[sudo] password for jpl:
Ign file: binary/ Release.gpg
Ign file:/usr/share/local-repository/ binary/ Translation-en
Ign file:/usr/share/local-repository/ binary/ Translation-en_US
Ign file: binary/ Release
Ign file: binary/ Packages
Ign file: binary/ Packages
Get:1 http://dl.google.com stable Release.gpg [197B]
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en_US
Get:2 http://dl.google.com stable Release [1,347B]
Get:3 http://dl.google.com stable/main i386 Packages [1,083B]
Hit http://deb.opera.com stable Release.gpg
Ign http://deb.opera.com/opera/ stable/non-free Translation-en
Hit http://archive.ubuntu.com maverick Release.gpg
Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en_US
Ign http://deb.opera.com/opera/ stable/non-free Translation-en_US
Hit http://deb.opera.com stable Release.gpg
Ign http://deb.opera.com/opera-beta/ stable/non-free Translation-en
Ign http://deb.opera.com/opera-beta/ stable/non-free Translation-en_US
Hit http://deb.opera.com stable Release
Ign http://archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_US
Hit http://archive.ubuntu.com maverick-updates Release.gpg
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Hit http://deb.opera.com stable Release
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en_US
Hit http://archive.ubuntu.com maverick Release
Ign http://deb.opera.com stable/non-free i386 Packages
Hit http://archive.ubuntu.com maverick-updates Release
Hit http://archive.ubuntu.com maverick/main i386 Packages
Ign http://deb.opera.com stable/non-free i386 Packages
Hit http://archive.ubuntu.com maverick/restricted i386 Packages
Hit http://archive.ubuntu.com maverick/universe i386 Packages
Hit http://archive.ubuntu.com maverick/multiverse i386 Packages
Ign http://deb.opera.com stable/non-free i386 Packages
Hit http://archive.ubuntu.com maverick-updates/main i386 Packages
Hit http://archive.ubuntu.com maverick-updates/restricted i386 Packages
Hit http://archive.ubuntu.com maverick-updates/universe i386 Packages
Hit http://archive.ubuntu.com maverick-updates/multiverse i386 Packages
Ign http://deb.opera.com stable/non-free i386 Packages
Hit http://deb.opera.com stable/non-free i386 Packages
Hit http://deb.opera.com stable/non-free i386 Packages
Hit http://linux.dropbox.com lucid Release.gpg
Ign http://linux.dropbox.com/ubuntu/ lucid/main Translation-en
Ign http://linux.dropbox.com/ubuntu/ lucid/main Translation-en_US
Hit http://linux.dropbox.com lucid Release
Hit http://linux.dropbox.com lucid/main i386 Packages
Hit http://security.ubuntu.com maverick-security Release.gpg
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en_US
Hit http://archive.canonical.com maverick Release.gpg
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en
Hit http://packages.medibuntu.org maverick Release.gpg
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/am-monkeyd/nau ... pa/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/am-monkeyd/nau ... pa/ubuntu/ maverick/main Translation-en_US
Get:4 http://packages.linuxmint.com julia Release.gpg [198B]
Ign http://packages.linuxmint.com/ julia/import Translation-en
Ign http://packages.linuxmint.com/ julia/import Translation-en_US
Ign http://packages.linuxmint.com/ julia/upstream Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en_US
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en_US
Hit http://archive.canonical.com maverick Release
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/jonoomph/openshot-edge/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/jonoomph/openshot-edge/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/lallenlowe/dexter-ppa/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/lallenlowe/dexter-ppa/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release.gpg
Hit http://security.ubuntu.com maverick-security Release
Ign http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ maverick/main Translation-en_US
Get:5 http://ppa.launchpad.net maverick Release.gpg [316B]
Ign http://packages.linuxmint.com/ julia/upstream Translation-en_US
Get:6 http://packages.linuxmint.com julia Release [7,253B]
Hit http://archive.canonical.com maverick/partner i386 Packages
Ign http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/pmjdebruijn/da ... se/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/pmjdebruijn/da ... se/ubuntu/ maverick/main Translation-en_US
Hit http://security.ubuntu.com maverick-security/main i386 Packages
Ign http://packages.medibuntu.org/ maverick/free Translation-en
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/rjeschmi/rjeschmi-ppa/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/rjeschmi/rjeschmi-ppa/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/stk/dev/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/stk/dev/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release.gpg
Hit http://security.ubuntu.com maverick-security/restricted i386 Packages
Hit http://security.ubuntu.com maverick-security/universe i386 Packages
Hit http://security.ubuntu.com maverick-security/multiverse i386 Packages
Ign http://packages.linuxmint.com julia/import i386 Packages
Ign http://packages.medibuntu.org/ maverick/free Translation-en_US
Ign http://packages.linuxmint.com julia/upstream i386 Packages
Ign http://ppa.launchpad.net/tiheum/equinox/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/tiheum/equinox/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/ubuntu-mozilla ... pa/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/ubuntu-mozilla ... pa/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release.gpg
Ign http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ maverick/main Translation-en_US
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick Release
Ign http://packages.linuxmint.com julia/import i386 Packages
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick Release
Ign http://packages.medibuntu.org/ maverick/non-free Translation-en
Ign http://packages.linuxmint.com julia/upstream i386 Packages
Get:7 http://ppa.launchpad.net maverick Release [9,745B]
Hit http://packages.linuxmint.com julia/import i386 Packages
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick Release
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Ign http://packages.medibuntu.org/ maverick/non-free Translation-en_US
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://packages.linuxmint.com julia/upstream i386 Packages
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Get:8 http://ppa.launchpad.net maverick/main Sources [10.9kB]
Hit http://packages.medibuntu.org maverick Release
Get:9 http://ppa.launchpad.net maverick/main i386 Packages [20.1kB]
Hit http://packages.medibuntu.org maverick/free i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://packages.medibuntu.org maverick/non-free i386 Packages
Hit http://ppa.launchpad.net maverick/main Sources
Hit http://ppa.launchpad.net maverick/main i386 Packages
Hit http://archive.getdeb.net maverick-getdeb Release.gpg
Ign http://archive.getdeb.net/ubuntu/ maverick-getdeb/games Translation-en
Ign http://archive.getdeb.net/ubuntu/ maverick-getdeb/games Translation-en_US
Hit http://archive.getdeb.net maverick-getdeb Release
Hit http://archive.getdeb.net maverick-getdeb/games Sources
Hit http://archive.getdeb.net maverick-getdeb/games i386 Packages
Fetched 51.1kB in 11s (4,278B/s)

jpl@jpl-B701 ~ $ sudo aptitude keep-all
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
Need to get 0B/9,949kB of archives. After unpacking 0B will be used.
Preconfiguring packages ...
Selecting previously deselected package opera.
(Reading database ... 289293 files and directories currently installed.)
Preparing to replace opera 11.00.1176 (using .../opera_11.00.1176_i386.deb) ...
Unpacking replacement opera ...
Processing triggers for mintsystem ...
Processing triggers for menu ...
Processing triggers for shared-mime-info ...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for software-center ...
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
Processing triggers for python-support ...
Processing triggers for python-central ...
Setting up opera (11.00.1176) ...
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/chrome" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: error processing opera (--configure):
subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Processing triggers for menu ...
Errors were encountered while processing:
opera
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up opera (11.00.1176) ...
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/chrome" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: error processing opera (--configure):
subprocess installed post-installation script returned error exit status 1
Processing triggers for menu ...
Errors were encountered while processing:
opera

jpl@jpl-B701 ~ $ sudo aptitude purge opera
The following packages will be REMOVED:
opera{p}
0 packages upgraded, 0 newly installed, 1 to remove and 30 not upgraded.
Need to get 0B of archives. After unpacking 31.0MB will be freed.
Do you want to continue? [Y/n/?] y
(Reading database ... 289663 files and directories currently installed.)
Removing opera ...
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/chrome" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: error processing opera (--purge):
subprocess installed post-removal script returned error exit status 1
No apport report written because MaxReports is reached already
Processing triggers for software-center ...
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for shared-mime-info ...
Processing triggers for menu ...
Processing triggers for mintsystem ...
Processing triggers for python-central ...
Processing triggers for python-support ...
Errors were encountered while processing:
opera
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

jpl@jpl-B701 ~ $

===================================================
Sysinfo:
Mint 17
HP 250 G2 Notebook
Intel i3-3110M 2.40GHz/4 Gig RAM
Intel 3rd Gen Core processor Graphics Controller
Intel 7 Series/C210 Series Chipset Family High Def Audio Controller
Qualcomm Atheros QCA9565 / AR9565 Wireless Netwk Adapter (rev 01)
User avatar
JoeInMN
Level 3
Level 3
 
Posts: 106
Joined: Wed Nov 17, 2010 5:52 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby jamesdmeacham3 on Sat Jan 29, 2011 5:28 pm

I'm having precisely the same issue and the aptitude fix isn't working for me either. I'm currently unable to upgrade any of the 3 mint machines I'm running nor am I able to delete Opera. Hoping this might get someone's attention...

Cheers,

James
jamesdmeacham3
Level 1
Level 1
 
Posts: 4
Joined: Sat Jan 29, 2011 5:25 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby willie42 on Sat Jan 29, 2011 7:32 pm

hello james

Try this

Code: Select all
sudo apt-get update && sudo apt-get upgrade


let me know if this works if not post the results here
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.
User avatar
willie42
Level 7
Level 7
 
Posts: 1977
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Re: Package management broken, no LinuxMint module, bad Oper

Postby jamesdmeacham3 on Sat Jan 29, 2011 8:06 pm

Thanks for having a look at this. Unfortunately, it didn't work and this is what I got:


Do you want to continue [Y/n]? Y
Preconfiguring packages ...
Selecting previously deselected package opera.
(Reading database ... 331276 files and directories currently installed.)
Preparing to replace opera 11.01.1190 (using .../opera_11.01.1190_amd64.deb) ...
Unpacking replacement opera ...
(normal stuff in here....)

Processing triggers for mintsystem ...
Processing triggers for software-center ...
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
Processing triggers for python-support ...
Processing triggers for python-central ...
Setting up opera (11.01.1190) ...
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: error processing opera (--configure):
subprocess installed post-installation script returned error exit status 1
Processing triggers for menu ...
Errors were encountered while processing:
opera
E: Sub-process /usr/bin/dpkg returned an error code (1)
jmXXXXXX@XXXXXXX:~$


Any suggestions?

Cheers,

James
jamesdmeacham3
Level 1
Level 1
 
Posts: 4
Joined: Sat Jan 29, 2011 5:25 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby willie42 on Sat Jan 29, 2011 8:13 pm

do this

Code: Select all
gksudo gedit /etc/apt/sources.list



copy and past here
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.
User avatar
willie42
Level 7
Level 7
 
Posts: 1977
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Re: Package management broken, no LinuxMint module, bad Oper

Postby jamesdmeacham3 on Sat Jan 29, 2011 8:16 pm

deb http://packages.linuxmint.com/ julia main upstream import romeo
deb http://archive.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ maverick partner
deb http://packages.medibuntu.org/ maverick free non-free
deb http://www.mendeley.com/repositories/xUbuntu_10.10 /
deb http://archive.getdeb.net/ubuntu maverick-getdeb apps
deb http://archive.getdeb.net/ubuntu maverick-getdeb games
jamesdmeacham3
Level 1
Level 1
 
Posts: 4
Joined: Sat Jan 29, 2011 5:25 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby willie42 on Sat Jan 29, 2011 8:45 pm

Found this Thread for you.

hope this helps if not come back and I will continue to look

http://allforlinux.com/2010/07/solving- ... ror-code1/
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.
User avatar
willie42
Level 7
Level 7
 
Posts: 1977
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Re: Package management broken, no LinuxMint module, bad Oper

Postby jamesdmeacham3 on Sat Jan 29, 2011 8:57 pm

I followed the directions in the post and it didn't work. However, when I followed the directions in the post and then did:

$sudo apt-get remove opera

it worked.

Thanks for your help, mate.

Cheers,

James
jamesdmeacham3
Level 1
Level 1
 
Posts: 4
Joined: Sat Jan 29, 2011 5:25 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby willie42 on Sat Jan 29, 2011 8:58 pm

Glad it helped...Please edit the Subject line and put Solved so others can be helped :D
Comptia A+ Certified Technician
Comptia Network + Certified Technician
You can not have Success without Failures.
User avatar
willie42
Level 7
Level 7
 
Posts: 1977
Joined: Tue Jun 22, 2010 7:52 pm
Location: Oak Ridge, TN USA

Re: Package management broken, no LinuxMint module, bad Oper

Postby JoeInMN on Thu Feb 03, 2011 2:05 am

I'm the OP, heh, and not solved yet...

===================================================
jpl@jpl-B701 ~ $ sudo apt-get remove opera
[sudo] password for jpl:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
libreoffice-filter-binfilter
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
opera
0 upgraded, 0 newly installed, 1 to remove and 31 not upgraded.
1 not fully installed or removed.
After this operation, 30.8MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 328091 files and directories currently installed.)
Removing opera ...
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/http" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/https" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/ftp" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/firefox-4.0.desktop": usage of MIME type "x-scheme-handler/chrome" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/kde4/kmailservice.desktop": usage of MIME type "x-scheme-handler/mailto" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/kde4/ktelnetservice.desktop": usage of MIME type "x-scheme-handler/telnet" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/kde4/ktelnetservice.desktop": usage of MIME type "x-scheme-handler/rlogin" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
Warning in file "/usr/share/applications/kde4/ktelnetservice.desktop": usage of MIME type "x-scheme-handler/ssh" is discouraged (the use of "x-scheme-handler" as media type is strongly discouraged in favor of a subtype of the "application" media type)
No protocol specified
/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
dpkg: error processing opera (--remove):
subprocess installed post-removal script returned error exit status 1
Processing triggers for software-center ...
No protocol specified
/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
File "/usr/sbin/update-software-center", line 34, in <module>
from softwarecenter.db.update import rebuild_database
File "/usr/share/software-center/softwarecenter/db/update.py", line 41, in <module>
from softwarecenter.db.database import parse_axi_values_file
File "/usr/share/software-center/softwarecenter/db/database.py", line 26, in <module>
from softwarecenter.db.application import Application
File "/usr/share/software-center/softwarecenter/db/application.py", line 31, in <module>
from softwarecenter.distro import get_distro
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 127, in <module>
distro_instance=_get_distro()
File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 116, in _get_distro
module = __import__(distro_id, globals(), locals(), [], -1)
ImportError: No module named LinuxMint
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'interface/x-winamp-skin'

Processing triggers for menu ...
Processing triggers for mintsystem ...
Processing triggers for python-central ...
Processing triggers for python-support ...
Errors were encountered while processing:
opera
E: Sub-process /usr/bin/dpkg returned an error code (1)
jpl@jpl-B701 ~ $

================================================

Synaptic still shows Opera installed, but with a red x on its selection box and a red bar across its fields.

The "No module named LinuxMint" line is still there; is that as worrisome as it sounds to me?

Sorry about all of the long terminal pastes, and thanks to everyone for digging through it all.
Sysinfo:
Mint 17
HP 250 G2 Notebook
Intel i3-3110M 2.40GHz/4 Gig RAM
Intel 3rd Gen Core processor Graphics Controller
Intel 7 Series/C210 Series Chipset Family High Def Audio Controller
Qualcomm Atheros QCA9565 / AR9565 Wireless Netwk Adapter (rev 01)
User avatar
JoeInMN
Level 3
Level 3
 
Posts: 106
Joined: Wed Nov 17, 2010 5:52 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby viking777 on Thu Feb 03, 2011 5:40 am

First suggestion

Code: Select all
sudo apt-get -f install


Next suggestion could you retry the advice I gave in the second post on this thread and then post the output of

Code: Select all
sudo aptitude purge opera


Which is the last step of that sequence.

Last suggestion, if the first two don't work this would be a little bit tedious but you could try it if you want.

Open a terminal and run

Code: Select all
locate opera


Then delete all the folders and files that Opera has installed - there are quite a lot of them, but once you have finished opera should be gone, then try suggestion 1 again.

As for the 'no linux mint module' warning, this seems to have something to do with software centre, so for the time being do not use the software centre, use the package manager or the apt-get command instead, when you have fixed the problems with those you may then be able to fix the problem with software centre, but for the moment just forget about trying to use it.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Package management broken, no LinuxMint module, bad Oper

Postby JoeInMN on Sun Feb 06, 2011 9:19 pm

I did everything up until your last suggestion, and Synaptic still shows Opera marked as before - green box with red x, and red bar across. The terminal conversation for all of that is pretty long; if you think it will be useful then I can paste the whole thing here. "Locate opera" then spews out a phone book's worth of lines, and at this point I become a little nervous, out of fear that I will break something vital by deleting things manually without being absolutely sure of what I'm doing. So I stopped there.

When Julia KDE is released, I plan to do a clean install into another partition, and after I get that set up and everything transferred over, I might go ahead with this and see what happens. I guess I can hold out until then.

Thanks for your help!
Sysinfo:
Mint 17
HP 250 G2 Notebook
Intel i3-3110M 2.40GHz/4 Gig RAM
Intel 3rd Gen Core processor Graphics Controller
Intel 7 Series/C210 Series Chipset Family High Def Audio Controller
Qualcomm Atheros QCA9565 / AR9565 Wireless Netwk Adapter (rev 01)
User avatar
JoeInMN
Level 3
Level 3
 
Posts: 106
Joined: Wed Nov 17, 2010 5:52 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby wakeupgod on Sun Feb 24, 2013 5:06 pm

Here's what I did to fix this issue (While logged in as root, I know it's bad practice but I'm a RHEL sysadmin and I get tired of typing sudo when fixing a problem on my home desktop). Sorry for posting to a dead thread but I was searching for a solution today and while this thread didn't hold the solution it triggered my brain to realize what the solution was.

Code: Select all
machine-name ~ # apt-get remove software-center
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  oneconf software-center-aptdaemon-plugins ubuntu-sso-client
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  software-center
0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
1 not fully installed or removed.
After this operation, 4,522 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 169611 files and directories currently installed.)
Removing software-center ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Setting up opera (12.14.1738-1linuxmint) ...
machine-name ~ # apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  oneconf software-center-aptdaemon-plugins ubuntu-sso-client
0 upgraded, 0 newly installed, 3 to remove and 2 not upgraded.
After this operation, 407 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 169160 files and directories currently installed.)
Removing oneconf ...
Removing software-center-aptdaemon-plugins ...
Removing ubuntu-sso-client ...
machine-name ~ # apt-get remove opera
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  opera
0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
After this operation, 45.5 MB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 169060 files and directories currently installed.)
Removing opera ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Processing triggers for shared-mime-info ...
machine-name ~ #


See, no problems!
wakeupgod
Level 1
Level 1
 
Posts: 2
Joined: Sun Feb 24, 2013 4:58 pm

Re: Package management broken, no LinuxMint module, bad Oper

Postby JoeInMN on Thu Mar 14, 2013 9:23 pm

wakeupgod wrote:Here's what I did to fix this issue (While logged in as root, I know it's bad practice but I'm a RHEL sysadmin and I get tired of typing sudo when fixing a problem on my home desktop). Sorry for posting to a dead thread but I was searching for a solution today and while this thread didn't hold the solution it triggered my brain to realize what the solution was.

Code: Select all
Stuff


See, no problems!


Issue is long dead for me of course, so I can't try your solution, but thanks for posting it for anyone else who might still need it.
Sysinfo:
Mint 17
HP 250 G2 Notebook
Intel i3-3110M 2.40GHz/4 Gig RAM
Intel 3rd Gen Core processor Graphics Controller
Intel 7 Series/C210 Series Chipset Family High Def Audio Controller
Qualcomm Atheros QCA9565 / AR9565 Wireless Netwk Adapter (rev 01)
User avatar
JoeInMN
Level 3
Level 3
 
Posts: 106
Joined: Wed Nov 17, 2010 5:52 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Bing [Bot] and 28 guests