HOW TO: Install Broadcom-sta (wl) driver in LMDE

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby billh on Tue Feb 22, 2011 10:58 pm

I tried http://wireless.kernel.org/en/users/Documentation/FAQ#Q:_Is_my_XXX_model_device_supported.3F and found instructions to Google "14e4:4727" site:cateee.net/lkddb/ . That turned up nothing, so it sounds as if brcm80211 is not the way to go, right?

The earlier process did not install b43-fwcutter on my system. Is that an issue?
billh
Level 1
Level 1
 
Posts: 8
Joined: Tue Feb 22, 2011 6:48 pm

Linux Mint is funded by ads and donations.
 

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby dawgdoc on Tue Feb 22, 2011 11:14 pm

billh wrote:That turned up nothing, so it sounds as if brcm80211 is not the way to go, right?

The earlier process did not install b43-fwcutter on my system. Is that an issue?

I have been using LMDE since about a month after it was released, that was when I installed broadcom-sta for my bcm4311. I have not ever installed b43-fwcutter. So, I would think that its absence is not an issue.

Give the brcm80211 a try. Otherwise I think you will have to download the newer version of broadcom-sta from their site and compile from source. Directions can be found in the readme file on the Broadcom site.

The one set of posts I have seen by someone else with the bcm4313 b/g/n ended up getting it working with the brcm80211. I think his posts are at the bottom of the first page of this thread.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 13 Gnome x32 PAE, LMDE
READING: The Autobiography of Benvenuto Cellini
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2690
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby billh on Tue Feb 22, 2011 11:58 pm

Thanks. I just tried that, to no avail.

I did try

Code: Select all
# modprobe -r brcm80211 ; modprobe brcm80211
# iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

eth2      IEEE 802.11  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:8 Mb/s   Tx-Power:24 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Managementmode:All packets received
          Link Quality=5/5  Signal level=0 dBm  Noise level=-91 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

# ifdown eth2
ifdown: interface eth2 not configured
# ifup eth2
Ignoring unknown interface eth2=eth2.
 


I also noticed that the connection was set up in ad-hoc mode; I changed that to Infrastructure, after which it waited for quite a while before failing to connect.

Is it important that Menu > Administration > Network brings up a Network Settings dialog with 3 tabs (General, DNS, and Hosts)? I though there was a fourth tab at the front that let you set up Wired, Wireless, etc.
billh
Level 1
Level 1
 
Posts: 8
Joined: Tue Feb 22, 2011 6:48 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby billh on Wed Feb 23, 2011 7:50 pm

FWIW, installing the drive from Broadcom (Method 3) worked nicely. I'm posting here with no Ethernet cable connected. Thanks for the tutorial and help.
billh
Level 1
Level 1
 
Posts: 8
Joined: Tue Feb 22, 2011 6:48 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby dawgdoc on Wed Feb 23, 2011 8:51 pm

I am glad you were able to get it working.

Yes, installing using the instructions on the Broadcom site will allow you to get a newer version of the driver, currently it is the 5.100.82.38. Apparently this is necessary for the newer version of the bcm4313 chipset that incorporates 802.11n.

I will edit the original tutorial to reflect the need for the newer driver version.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 13 Gnome x32 PAE, LMDE
READING: The Autobiography of Benvenuto Cellini
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2690
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby billh on Thu Feb 24, 2011 3:51 pm

When you edit the tutorial, can you point to how to have the module loaded at boot time? I shut down (inadvertently; i tried to hibernate, but it appears it rebooted instead--maybe i have another problem), and now I had to reinstall the kernel module.

After reading a bit, it's not clear if the Broadcom README.txt instructions would apply to LMDE or not (load the driver, run `depmod -a`, and run `echo modprobe wl >> /etc/rc.local`, as that's followed immediately with a note about Fedora and SUSE. It's also not clear if a new initramfs might be required, but I found a Debian kernel handbook page (http://kernel-handbook.alioth.debian.or ... ramfs.html) that mentioned # dpkg-reconfigure linux-image-2.6.18-3-686, which I hadn't seen elsewhere.
billh
Level 1
Level 1
 
Posts: 8
Joined: Tue Feb 22, 2011 6:48 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby dawgdoc on Thu Feb 24, 2011 7:47 pm

Since a previous post of yours indicates that wl was an active module, it would be best to use the part of the readme.txt about upgrading.
Upgrading from a previous version:
---------------------------------

If you were already running a previous version of wl, you'll want to provide
a clean transition from the older driver. (The path to previous driver is
usually /lib/modules/<kernel-version>/kernel/net/wireless)

# rmmod wl
# mv <path-to-prev-driver>/wl.ko <path-to-prev-driver>/wl.ko.orig
# cp wl.ko <path-to-prev-driver>/wl.ko
# depmod
# modprobe wl

The new wl driver should now be operational and your all done.

The readme instructions do not say, but you probably knew to do the above as root.

I noted in my install that the path I highlighted above in red is not correct. In my install the path is /lib/modules/2.6.32-5-686/kernel/drivers/net/wireless Unless you used a comparable path, I think this may be what needs changing.

Also, depmod is equivalent to depmod -a -a is a default option if no module name is provided.
You probably do not need echo modprobe wl >> /etc/rc.local, I have that file but there is nothing in it except commented out lines and exit 0
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 13 Gnome x32 PAE, LMDE
READING: The Autobiography of Benvenuto Cellini
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2690
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby mike4ca on Tue Mar 08, 2011 12:09 am

I have a Dell inspiron 1520 laptop (BCM4312 wireless). With Mint main edition, I was able to use my b44 wired lan connection and install the b43 wireless. Both work. I have installed LMDE on a second partition. I tried for hours to get my wireless to work through this posting. Like others, I would lose the wired connection but I could never get the wireless to work. I reinstalled LMDE, then went to the software manager and typed in b43. I installed the firmware-b43-installer. Rebooted the computer. Now I am connected through the wireless and still have wired available if I want!

The firmware-b43-installer was very easy.
mike4ca
Level 1
Level 1
 
Posts: 9
Joined: Mon Dec 06, 2010 10:49 pm
Location: Iowa, USA

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby addegsson on Tue Mar 08, 2011 3:32 am

Method 1 works great, thanks!
addegsson
Level 1
Level 1
 
Posts: 21
Joined: Wed Feb 23, 2011 2:20 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby christoff522 on Sat Apr 30, 2011 10:03 pm

I found this on debian forums, hope it helps :)

firstly download all this
sudo apt-get install module-assistant broadcom-sta-common broadcom-sta-source wireless-tools wpasupplicant


then
sudo module-assistant prepare broadcom-sta
sudo module-assistant auto-install broadcom-sta

and reboot! you must REBOOT!!

every time your update kernel headers you MAY have to do this again. I know I did. Last time I got wireless working I had a 5 meg connection :/ (my broadband is 50 meg!!)
Now I am at full speed, without ANY connection losses whatsoever

good luck, this had been bothering me for ages. I reinstalled LMDE today after finding this post

source: debian forums post http://forums.debian.net/viewtopic.php?f=7&t=57858
christoff522
Level 1
Level 1
 
Posts: 31
Joined: Fri Mar 12, 2010 11:28 am

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby carlp101 on Wed May 18, 2011 4:35 pm

Thanks all that contributed to this thread. I just rebuilt my Dell Studio 15 (1558) with LMDE and was having trouble with the wireless drivers. After downloading the latest x64 drivers from the Broadcom site I successfully used the following steps supplied by billh to solve it:

1 apt-get update
2 apt-get install module-assistant wireless-tools
3 m-a a-i broadcom-sta
4 echo blacklist brcm80211 >> /etc/modprobe.d/broadcom-sta-common.conf
5 update-initramfs -u -k $(uname -r)
6 modprobe -r b44 b43 b43legacy ssb brcm80211
7 modprobe wl
8 iwconfig

That's it. No other steps required.
carlp101
Level 1
Level 1
 
Posts: 6
Joined: Sat May 08, 2010 5:40 am

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby MrBelt on Tue May 24, 2011 7:34 pm

I have no wireless extensions since I updated my kernel headers to 2.6.38-2 a few days ago. I am using a BCM4311.

Code: Select all
lo        no wireless extensions.

eth1      no wireless extensions.

irda0     no wireless extensions.

vboxnet0  no wireless extensions.


I have tried the above methods, but to no avail. Any ideas on what I could do? Thanks.
MrBelt
Level 1
Level 1
 
Posts: 2
Joined: Tue May 24, 2011 1:18 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby dawgdoc on Wed May 25, 2011 10:15 pm

@MrBelt,

I am also having problems with the new kernel and my broadcom 4311. I have not been too pressed about finding a solution because I never upgraded the broadcom-sta version for the old kernel. I have just been using the old kernel.

I had thought to rebuild from the 5.60.48.36 version of broadcom-sta-source and broadcom-sta-common. However, I did not have the option. I had run apt-get autoclean, which removed the older versions since I had downloaded the 5.100.xx.xx version before installing the new kernel. In the next day or so, when I have access to wired broadband, I will try again, using these instructions, or a variation thereof:
#2 Manually acquire the squeeze/broadcom-sta-source package from http://packages.debian.org/squeeze/all/ ... e/download. For example:

$ wget http://ftp.us.debian.org/debian/pool/no ... -2_all.deb

#3 Manually acquire the squeeze/broadcom-sta-common package from http://packages.debian.org/squeeze/all/ ... n/download. For example:

$ wget http://ftp.us.debian.org/debian/pool/no ... -2_all.deb

#4 Install the squeeze/broadcom-sta-common and squeeze/broadcom-sta-source packages via dpkg:

$ su
# dpkg -i broadcom-sta-*deb

these instructions are from the page upon which this How-To was based. When installing this older version with the new kernel, I will have to figure out how to keep the system from searching for the newer versions. If it does not work straight away, I will delete the new kernel, re-install it and then install the older drivers.

I will let you know how it goes.
Image

SYSTEM: Compaq Presario CQ62 Dual-Boot: Mint 13 Gnome x32 PAE, LMDE
READING: The Autobiography of Benvenuto Cellini
User avatar
dawgdoc
Level 9
Level 9
 
Posts: 2690
Joined: Mon Oct 05, 2009 12:53 am
Location: Kentucky, USA the land of Mint Juleps

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby TBABill on Thu May 26, 2011 1:23 pm

I do not know this for certain, but I have seen many posts on Ubuntu's forums regarding people with the BCM4311 on the 2.6.38 kernel. Most of them mentioned having to use the b43 driver instead of the STA (wl) driver. That seems odd to me, but perhaps worth giving a shot? That doesn't answer why the STA driver isn't working properly with the 4311 (works fine on my 4312) but it may offer a temporary solution until the fix is discovered.

Just wanted to throw that out in case it can help. My apologies if it does not as I don't have one to test that theory on.
TBABill
Level 6
Level 6
 
Posts: 1368
Joined: Wed Dec 30, 2009 1:02 pm
Location: Leonardtown, MD

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby zenit111 on Sat May 28, 2011 5:09 am

MrBelt wrote:I have no wireless extensions since I updated my kernel headers to 2.6.38-2 a few days ago. I am using a BCM4311.

Code: Select all
lo        no wireless extensions.

eth1      no wireless extensions.

irda0     no wireless extensions.

vboxnet0  no wireless extensions.


I have tried the above methods, but to no avail. Any ideas on what I could do? Thanks.


Have you tried Administration > Windows Wireless Drivers ? (graphic version of ndiswrapper)

If you haven't, undo everything, uninstall linux and STA drivers.. then download that Broadcom card's WINDOWS (XP/7) drivers.
Then get ndisgtk in software manager and point it to the drivers folder you just downloaded. There should be an .inf file, hopefully its not an .exe in which case use wine or virtual box to extract it first. Even when STA drivers worked for my Broadcom card, using ndisgtk vastly improved the signal strength.

FYI Broadcom has horrible support and I had to struggle for a few hours to fix my friends computer. I recommend buying another card if you can.
zenit111
Level 1
Level 1
 
Posts: 2
Joined: Thu Aug 05, 2010 4:39 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby Hawkwind on Sat May 28, 2011 5:21 am

MrBelt wrote:I have no wireless extensions since I updated my kernel headers to 2.6.38-2 a few days ago. I am using a BCM4311.

Code: Select all
lo        no wireless extensions.

eth1      no wireless extensions.

irda0     no wireless extensions.

vboxnet0  no wireless extensions.


I have tried the above methods, but to no avail. Any ideas on what I could do? Thanks.


I followed the method 1 here after upgrading my kernel from here http://community.linuxmint.com/tutorial/view/218
I am no expert though so it may be worth someone confiming this is ok before going ahead.
Hawkwind
Level 1
Level 1
 
Posts: 13
Joined: Fri Mar 04, 2011 7:08 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby Oscar799 on Sat May 28, 2011 5:36 am

You should be fine following the instructions in the tutorial http://community.linuxmint.com/tutorial/view/218
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8801
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby MrBelt on Sat May 28, 2011 7:56 pm

Thank you all! I just installed the b43 driver and it works like a charm. I'm pleased to see it's not as deaf as it was when I last used it.
By the way, I did try following that tutorial, but it did nothing for me (Broadcom cards are always mysterious this way). And I will try someday using ndiswrapper if I feel like tinkering.
MrBelt
Level 1
Level 1
 
Posts: 2
Joined: Tue May 24, 2011 1:18 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby niebling on Fri Jul 01, 2011 1:40 pm

I used method 3 after uninstalling the existing driver for the broadcom card installed by default (my Broadcom 4312 wireless card is low power and requires firmware-b43-lpphy-installer_4.174.64.19-4_all.deb instead of the default firmware-b43-installer... I marked that file for removal and applied the change using Synaptic Package Manager.

This works for Ubuntu, Linux Mint XFCE and LMDE ...

To install the premade driver from Broadcom follow the instructions given by Broadcom for installation of the Broadcom-STA driver:

On a computer with Internet access, download the required firmware files from
http://downloads.openwrt.org/sources/wl ... 130.20.0.o
http://mirror2.openwrt.org/sources/broa ... .5.tar.bz2

Copy the downloaded files to your home folder and execute the following commands
consecutively in a terminal to extract and install the firmware:

open terminal
su (makes you a super user)

(note that the prompt is now a # hashmark)

Type the following commands (after the # prompt)
tar xfvj broadcom-wl-4.150.10.5.tar.bz2
sudo b43-fwcutter -w /lib/firmware wl_apsta-3.130.20.0.o
sudo b43-fwcutter --unsupported -w /lib/firmware broadcom-wl-4.150.10.5/driver/wl_apsta_mimo.o

I did not need to reboot. My device was recognized right away and I could connect without any activation...
I connected right away no troubles.
niebling

Addendum:
Building the driver using hybrid-portsrc_x86_64-v5_100_82_38.tar us also fairly easy and probably better.
This should work for many several versions lf Linux...

Just follow these instructions:
BUILD INSTRUCTIONS
------------------
1. Setup the directory by untarring the proper tarball:

For 32 bit: hybrid-portsrc_x86-32_v5.100.82.38.tar.gz
For 64 bit: hybrid-portsrc_x86-64_v5.100.82.38.tar.gz

Example:
# mkdir hybrid_wl
# cd hybrid_wl
# tar xzf <path>/hybrid-portsrc_x86-32_v5.100.82.38.tar.gz

2. Build the driver as a Linux loadable kernel module (LKM):

# make clean (optional)
# make

When the build completes, it will produce a wl.ko file in the top level
directory.

If your driver does not build, check to make sure you have installed the
kernel package described in the requirements above.

INSTALL INSTRUCTIONS
--------------------

Upgrading from a previous version:
---------------------------------

If you were already running a previous version of wl, you'll want to provide
a clean transition from the older driver. (The path to previous driver is
usually /lib/modules/<kernel-version>/kernel/net/wireless)

# rmmod wl
# mv <path-to-prev-driver>/wl.ko <path-to-prev-driver>/wl.ko.orig (Be careful to do this BEFORE you copy wl.ko to the wireless directory!!! )
# cp wl.ko <path-to-prev-driver>/wl.ko
# depmod
# modprobe wl

The new wl driver should now be operational and your all done. (follow the steps below to "install' the driver)

Fresh installation:
------------------
1: Remove any other drivers for the Broadcom wireless device.

There are several open source drivers that are used to drive Broadcom 802.11
chips such as b43 and ssb. They will conflict with this driver and need
to be uninstalled before this driver can be installed. Any previous
revisions of the wl driver also need to be removed.

Note: On some systems such as Ubuntu 9.10, the ssb module may load during
boot even though it is blacklisted (see note under Common Issues on how to
resolve this). Nevertheless, ssb still must be removed
(by hand or script) before wl is loaded. The wl driver will not function
properly if ssb the module is loaded.

# lsmod | grep "b43\|ssb\|wl"

If any of these are installed, remove them:
# rmmod b43
# rmmod ssb
# rmmod wl

To blacklist these drivers and prevent them from loading in the future:
# echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf

2: Insmod the driver.

Otherwise, if you have not previously installed a wl driver, you'll need
to add a security module before using the wl module. Most newer systems
use lib80211 while others use ieee80211_crypt_tkip. See which one works for
your system.

# modprobe lib80211 (this one worked for me)
or
# modprobe ieee80211_crypt_tkip

Then:
# insmod wl.ko

wl.ko is now operational. It may take several seconds for the Network
Manager to notice a new network driver has been installed and show the
surrounding wireless networks.

Common issues:
----------------

* After the insmod you may see this message:
"WARNING: modpost: missing MODULE_LICENSE()"
It is expected, not harmful and can be ignored.

* You might see this message:
"insmod: error inserting 'wl.ko': -1 Unknown symbol in module"
Usually this means that the wlan security module (as mentioned above) is
not loaded. Try this:
# modprobe lib80211
or
# modprobe ieee80211_crypt_tkip
and then re-try to insmod the wl driver.
# insmod wl.ko

* If the wl driver loads but doesn't seem to do anything:
the ssb module may be the cause. Sometimes blacklisting ssb may not
be enough to prevent it from loading and it loads anyway. (This is mostly
seen on Ubuntu/Debian systems).

Check to see if ssb, wl or b43 is loaded:
# lsmod | grep "b43\|ssb\|wl"

If any of these are installed, remove them:
# rmmod b43
# rmmod ssb
# rmmod wl

Back up the current boot ramfs and generate a new one.
# cp /boot/initrd.img-`uname -r` somewheresafe
# update-initramfs -u
# reboot

------------------------------------
UPDATE FOR KERNEL 3.0.0.1-amd64

Had to use patch for kernel versions later than 2.6.x.x ...

download the patch here: http://www.mindwerks.net/wp-content/uploads/2011/03/broadcom-sta_4_kernel-2.6.38.patch

This patch supercedes the previous patch that is commonly referred to in other posts. That one no longer worked for me with
kernel 3.0.0.1-amd64



This works great with linux mint XFCE kernel 3.0.0.1-amd64... need to copy commands exactly:

make directory to comple driver ie. hybrid_wl
switch to directory: cd hybrid_wl
tar xfz hybrid-portsrc_x86_64-v5_100_82_38 (or whatever...)
patch -p1 < broadcom-sta_4_kernel-2.6.38.patch (or whatever you name the file...)
make clean
make
copy the wl.ko file to /lib/modules/3.0.0-1-amd64/kernel/net/wireless directory and then execute these commands (some may not be necessary):
depmod -a
rmmod wl
rmmod lib80211
rmmod ssb
rmmod b43

insmod lib80211
insmod wl
update-initramfs -u (to update kernel image to load wl.ko driver at boot time)

THanks!!! My other patch didn't work any longer... KEN
Last edited by niebling on Thu Oct 13, 2011 12:38 pm, edited 1 time in total.
niebling
Level 1
Level 1
 
Posts: 5
Joined: Fri Jul 01, 2011 1:19 pm

Re: HOW TO: Install Broadcom-sta (wl) driver in LMDE

Postby leonidas79 on Wed Jul 13, 2011 1:00 pm

Thank you dawgdoc ;) For me method 1 is working (HP ProBook 4525s).
leonidas79
Level 1
Level 1
 
Posts: 4
Joined: Wed Jul 13, 2011 12:44 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 3 guests