Folders are opened in Firefox

Forum rules
Before you post please read how to get help

Folders are opened in Firefox

Postby Prooz on Sun Mar 20, 2011 9:55 am

Let's say that downloaded a file in chrome (or any browser). The i click "Show in folder" and it opens in firefox! Same thing when I try to open folders with Gnome-Do (a search based launcher) and with Cairo Dock. Pretty much when I open folders thought applications. Where can I change back so that they are opened in the File Manager?
Insert funny text here...
User avatar
Prooz
Level 3
Level 3
 
Posts: 108
Joined: Wed Dec 29, 2010 1:14 pm

Linux Mint is funded by ads and donations.
 

Re: Folders are opened in Firefox

Postby viking777 on Sun Mar 20, 2011 10:41 am

Chrome opens everything in a browser as far as I can see (although on my system it opens in Chrome itself not FF) and I don't know of any way around it. As for the other problems have a look at this and see if it helps:

http://www.linuxinsight.com/living-on-the-bleeding-edge-debian-wheezy-sid.html#comment-2025

It is not answering exactly your problem, but you might be able to adapt it a bit.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Folders are opened in Firefox

Postby brubrant on Sun Mar 20, 2011 12:37 pm

Same problem here... I'm using mint 10 with LXDE.

I'm sure the problem is not with Chromium, as the same happens when I try to open Dropbox folder trough the systray icon.
brubrant
Level 1
Level 1
 
Posts: 3
Joined: Sun Mar 20, 2011 12:31 pm

Re: Folders are opened in Firefox

Postby Prooz on Sun Mar 20, 2011 1:04 pm

brubrant wrote:Same problem here... I'm using mint 10 with LXDE.

I'm sure the problem is not with Chromium, as the same happens when I try to open Dropbox folder trough the systray icon.


Same here. The problem is surely not in the browser...
Insert funny text here...
User avatar
Prooz
Level 3
Level 3
 
Posts: 108
Joined: Wed Dec 29, 2010 1:14 pm

Re: Folders are opened in Firefox

Postby viking777 on Sun Mar 20, 2011 2:28 pm

I will try and make it easier.

Open ~/.local/share/applications/mimeapps.list.

Either create a line (or edit one if it already exists) like this:

Code: Select all
inode/directory=nautilus-folder-handler.desktop


If you already have the line but it is preceeded by other entries them move the nautilus entry to the front.

If that doesn't work do the same in

~/.local/share/applications/defaults.list

EDIT. Wait a minute!! You are both using LXDE and yet this thread is in the Gnome forum :? I give up. If you are both using LXDE then it is an LXDE problem - post it in the right place :!:
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Folders are opened in Firefox

Postby brubrant on Sun Mar 20, 2011 4:52 pm

viking777 wrote: Wait a minute!! You are both using LXDE and yet this thread is in the Gnome forum :? I give up. If you are both using LXDE then it is an LXDE problem - post it in the right place :!:


I didn't noticed that. To be honest, I found the thread using Google.

Thank you for trying help, anyway. I'm going to re-post de question at LXDE forum.
brubrant
Level 1
Level 1
 
Posts: 3
Joined: Sun Mar 20, 2011 12:31 pm

Re: Folders are opened in Firefox

Postby freshlyminted on Tue Mar 22, 2011 7:31 am

Hey Viking777. I tried the two two tips you suggested in your second post. But neither of them got Gnome-Do working right for me. Any other ideas. I am running debian, gnome, and openbox and gnome-do always opens my folders in epiphany (i dont even use epiphany), it did the same thing in ubuntu with openbox, but with chrome. So annoying.

Thanks.
freshlyminted
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 22, 2011 7:24 am

Re: Folders are opened in Firefox

Postby freshlyminted on Tue Mar 22, 2011 7:35 am

Gnome-Do works correctly in both gnome and gnome/openbox.

But i prefer openbox neat, it still counts though as im using the gnome-panel in openbox. Dont get mad at me.
freshlyminted
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 22, 2011 7:24 am

Re: Folders are opened in Firefox

Postby viking777 on Tue Mar 22, 2011 8:11 am

The fix won't work unless Nautilus is your file manager, which it isn't if you are using LXDE. Even then I don't know if it will work for gnome-do. I don't use gnome-do any more, but when I did I remember it had the same sort of problems.
Chrome seems to be a different problem altogether. On Mint 10 if I go to the downloads folder in Chrome and select 'open in folder' it opens nautilus as it should. On LMDE it just opens a new browser tab, never figured out why. The fix that I gave you certainly doesn't influence Chrome in any way, it just does its own thing.
Last edited by viking777 on Tue Mar 22, 2011 8:24 am, edited 1 time in total.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Folders are opened in Firefox

Postby freshlyminted on Tue Mar 22, 2011 8:23 am

Hi viking. Not sure if you were talking to me. If so, just to let you know, i am using nautilus. It is set to handle desktop and autostart in openbox and i love Gnome-Do, cant abide by Synapse, its too fussy, have been using Kupfer whilst Do plays up, but would love to get Do working again.
Have been reading about, what little there is, on the the topic and heard others mention checking $ xdg-open '/home/ ... I tried this with one of my folders and it opened it in epiphany, though from what i understand xdg is designed to open stuff in browser, so, perhaps a false-start.

Cheers.
freshlyminted
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 22, 2011 7:24 am

Re: Folders are opened in Firefox

Postby freshlyminted on Tue Mar 22, 2011 10:23 pm

Sorted Gnome-Do and Openbox/Nautilus issue.

Installed "libfile-mimeinfo-perl".

Cheers.
freshlyminted
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 22, 2011 7:24 am

Re: Folders are opened in Firefox

Postby Prooz on Wed Mar 23, 2011 4:20 pm

@ Viking 777

Sorry for not being active here but...
I use Linux Mint 10 Gnome (64). I'm not sure what else to say to define the version.
Use nautilus...
Checked both files you mentioned but the exact line was already there.
Any more ideas? This is REALLY (I mean really, really) annoying and it used to work and then... it didn't.
Insert funny text here...
User avatar
Prooz
Level 3
Level 3
 
Posts: 108
Joined: Wed Dec 29, 2010 1:14 pm

Re: Folders are opened in Firefox

Postby viking777 on Fri Mar 25, 2011 4:51 am

Any more ideas?


Not from me - sorry.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Folders are opened in Firefox

Postby freshlyminted on Fri Mar 25, 2011 5:22 am

To Prooz. Your issue sounds like a similar issue to the one i was experiencing, albeit in a different context. Out of interest what happens when you enter:

#xdg-open '/home/you_user_name/Downloads' (for example) ? Dragging and dropping the folder icon into the terminal, after entering the command, saves you typing out the destination, you may know.

Initially when i ran a command like this it would open the destination folder in browser, not nautilus. Discovering this allowed me to focus my web searching and eventually led to my solution, installing "ibfile-mimeinfo-perl". That particular solution might not work for you, but realising "xdg-open" is miss-firing could be a step in the right direction. Editing ~/.local/share/applications/defaults.list wasnt working for me either, which is unfortunate as Gnome-Do also refuses to open up notes in Leafpad, worked fine in Gedit, tried to alter "defaults.list" to force it to call Leafpad, which it now does, but a blank page. Lame. Obviously im almost there, but... After all that im using Kupfer now. On the bright side its faster.

Good luck with your problem.
freshlyminted
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 22, 2011 7:24 am

Re: Folders are opened in Firefox

Postby viking777 on Fri Mar 25, 2011 6:38 am

Hey, wait a minute freshlyminted's excellent post allowed me to look in what might be the right direction and this is what I have come up with, it works for me anyway (and I have learned something as well :D )

Open a terminal and run

Code: Select all
mimeopen -d /home/yourusername/Documents


(or any folder it doesn't matter).

This will give you a result like this
Code: Select all
mimeopen -d /home/graham/Documents/

Please choose a default application for files of type inode/directory

        1) Open Folder  (nautilus-folder-handler)
        2) File Manager  (pcmanfm)
        3) Other...

use application #




Of course those are my results, your may be different.

If you want to open folders with nautilus just type 1, for pcmanfm 2 (a very strange option since I don't even have pcmanfm installed - but hey :shock: ) or type 3 for another application.

In my case since I want to open files in dolphin I typed 3 and I got the prompt:

Code: Select all
use command:


I change it to this:

Code: Select all
use command:dolphin


And the job is done - even in Chrome :D :D

Of course you would probably have to run the command again with root privs if you want to influence root behaviour - I haven' tried that though.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Folders are opened in Firefox

Postby freshlyminted on Fri Mar 25, 2011 7:21 am

Wow, sweet. Not sure how you got from A to B. But, thats a great command. Caused me to dust off Gnome-Do and see if i could effect it behaviour, as regards Leafpad. So, i ran a text file through it and selected "1)" (Leafpad).

Gnome-Do now opens the actual file in Leafpad, and not a blank Leafpad page, when its name is entered. However, it only works for files that have one word in the title, more than that and i get a blank page.

Oh well, iv come to appreciate Kupfer, as a launcher, for its speed, if not its looks.

Gnome-Do was so snappy in Ubuntu, but in Openbox running on Debian, one time out of five when it is called there is a lag, during which there is only a white block on the middle of the screen, before it fully renders. Only a second mind you, but the point of a launcher is to be snappy.

Still, weird though right? Only one word title, files open no problem. Something remediable in ~/.local/share/applications/defaults.list me thinks, as before editing that file, replacing Gedit entries with Leafpad, Do wouldnt call Leafpad at all. I just have no idea what to enter there to fix it.

Ah, Openbox, you are the most streamlined, snappiest Windows Manager/Desktop Environment, but your quirks, your damn quirks. Locales anyone?
freshlyminted
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 22, 2011 7:24 am

Re: Folders are opened in Firefox

Postby Prooz on Fri Mar 25, 2011 8:26 am

@ Viking 777

That IS a gr8 command :)
However it didn't work :(
I got the option of opening with nautilus or other. I chose nautilus and it opened the folder. But now when I try to open a folder throught Gnome-Do, Cairo-Dock, or whatever it doesn't open at all :(
Insert funny text here...
User avatar
Prooz
Level 3
Level 3
 
Posts: 108
Joined: Wed Dec 29, 2010 1:14 pm

Re: Folders are opened in Firefox

Postby viking777 on Fri Mar 25, 2011 8:40 am

Prooz, Your opening post said:

Let's say that downloaded a file in chrome (or any browser). The i click "Show in folder" and it opens in firefox!


That part of the problem is fixed (least it is for me). I cannot possibly help you with gnome-do or cairo-dock since I don't even have those programs installed. I am sure that gnome-do must have a user forum somewhere have you tried asking there?

EDIT. I can help you with one thing though. I remember quite clearly there were two reasons I uninstalled gnome-do. The first was because I hardly ever used it and the second was that when I did, it either failed to open documents at all or it opened them in the wrong program. That must have been at least a year ago, so obviously nothing has changed much since then. Why don't you try this 'Kupfer' that freshlyminted is talking about that seems to work for him.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Folders are opened in Firefox

Postby Prooz on Fri Mar 25, 2011 8:52 am

@ Viking 777

No, i still have the problem but now, instead of being opened in Firefox it doesn't open
Insert funny text here...
User avatar
Prooz
Level 3
Level 3
 
Posts: 108
Joined: Wed Dec 29, 2010 1:14 pm

Re: Folders are opened in Firefox

Postby viking777 on Fri Mar 25, 2011 8:58 am

Well I can't explain that, I can only repeat that it works for me now when it didn't before.

When you got to the point in the command that said:

Code: Select all
Please choose a default application for files of type inode/directory

        1) Open Folder  (nautilus-folder-handler)
        2) File Manager  (pcmanfm)
        3) Other...


Were there any other choices?

If so, try one of them instead.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Linux Mint is funded by ads and donations.
 
Next

Return to MATE

Who is online

Users browsing this forum: HighFive and 2 guests