HOW TO: Solve your LMDE audio issues

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

Re: HOW TO: Solve your LMDE audio issues

Postby lizzibet on Sun Dec 26, 2010 6:10 am

i just install gnome alsa mixer and turn up the volume on pcm and everything is fine after that.... pretty easy, no config files to adjust...
lizzibet
Level 2
Level 2
 
Posts: 87
Joined: Mon Mar 08, 2010 7:50 am

Linux Mint is funded by ads and donations.
 

Re: HOW TO: Solve your LMDE audio issues

Postby drzoo2 on Mon Dec 27, 2010 8:02 pm

I'm having problems with my sound card being detected. It seems it only detects the 2-channel audio and does not see the other output options to select 5.1 in the sound preferences.
Under hardware tab I only have option for "Analog Stero Duplex"

I noticed booting a Mint 10 Live DVD I have the other options.
Thanks
z

lspci
Code: Select all
scott@linux-main:~/Desktop$ lspci | grep -i audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)


Output from aplay -l
Code: Select all
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: HDA Generic [HDA Generic]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Output from aplay -L
Code: Select all
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=SB
    HDA ATI SB, HDA Generic
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, HDA Generic
    Front speakers
surround40:CARD=SB,DEV=0
    HDA ATI SB, HDA Generic
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
    HDA ATI SB, HDA Generic
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
    HDA ATI SB, HDA Generic
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
    HDA ATI SB, HDA Generic
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
    HDA ATI SB, HDA Generic
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: HOW TO: Solve your LMDE audio issues

Postby drzoo2 on Mon Dec 27, 2010 10:48 pm

Well, I managed to fix my issue. I read that my card wasn't supported in the 2.6.32 kernel. I updated to the Liquorix 2.6.36 Kernel and the 5.1 options were present. Ya!

z
drzoo2
Level 1
Level 1
 
Posts: 19
Joined: Fri Dec 24, 2010 11:13 am

Re: HOW TO: Solve your LMDE audio issues

Postby rijnsma on Sat Jan 01, 2011 3:57 pm

Great. Works fine (on more distro's).
Qiana.... mind your backup..
User avatar
rijnsma
Level 4
Level 4
 
Posts: 282
Joined: Wed May 06, 2009 7:28 am
Location: NL

Re: HOW TO: Solve your LMDE audio issues

Postby paro1991 on Sun Jan 30, 2011 5:36 pm

I was having sound issues with LMDE such that either only the flash player was getting sound and no other app at all or there was no sound to only the flash player.

I have ALSA and Pulseaudio installed and yes the fix you've provided has been adopted into the current asound.conf file like someone mentioned before.

My solution was installing libasound2-plugins and rebooting. Now sound works perfectly everywhere with or without flash player.
paro1991
Level 1
Level 1
 
Posts: 13
Joined: Fri Sep 17, 2010 10:41 am

Re: HOW TO: Solve your LMDE audio issues

Postby phubai on Thu Feb 03, 2011 12:50 pm

lizzibet wrote:i just install gnome alsa mixer and turn up the volume on pcm and everything is fine after that.... pretty easy, no config files to adjust...


As easy as this sounds, I almost passed it by...but I'm glad I didn't! I can now watch hulu.com without the aggravating echo in the sound that made it impossible!

Thanks for posting!

--phubai
phubai
Level 1
Level 1
 
Posts: 10
Joined: Sun Feb 04, 2007 5:28 pm
Location: Fleming Is., FL

Re: HOW TO: Solve your LMDE audio issues

Postby Yeticannotski on Sun Mar 20, 2011 5:33 pm

beli0135 wrote:Here is best solution to sound problem:

$ sudo apt-get remove pulseaudio
$ sudo killall pulseaudio
$ sudo killall pulseaudio
pulseaudio: no process killed
$ (echo Package: pulseaudio; echo Pin: release a=fakerepo; echo Pin-Priority: 1999) |
sudo tee -a /etc/apt/preferences

I don't really know why developers are pushing (with foot) PulseAudio garbage. It's just GARBAGE. Doesn't work properly. Never did, probably never will.


Thanks a lot for reminding me of this old "fix" and giving me back the usability of my computer.

I have great respect for anyone trying to build great free libre software, and pulseaudio is no exception. However, I do believe that its widespread use and distribution was made to soon. It should have matured more among a restrict and specialized user base; guys that may have some immediate practical applications for all its potential. For the moment, that is not me. I just want to call my Mom through Skype without going to layers and layers of complexity. Few Gnu-Linux issues have claimed so many hours of frustration as pulseaudio.
Yeticannotski
Level 1
Level 1
 
Posts: 15
Joined: Mon Mar 14, 2011 5:34 pm

Re: HOW TO: Solve your LMDE audio issues

Postby Bonsaii on Tue Mar 29, 2011 8:31 am

Hi,

Thanks for LMDE and all the help. Unfortunately, I need some.

After updating, my sound setting are lost.
Output works fine, input produces just noise
on sound recorder as well as Skype.

It is a HP Compaq nx7300. No internal mic, I am using a headset.
The sound card is the well known disaster, Intel HDA,
the AD1981 settings worked in the past.

If anyone can help, it is highly appreciated.
Thanks a lot,
B
Bonsaii
Level 2
Level 2
 
Posts: 89
Joined: Sat Oct 09, 2010 8:49 am

Re: HOW TO: Solve your LMDE audio issues

Postby blowtorch on Thu Apr 07, 2011 1:26 pm

Bonsaii wrote:Hi,

Thanks for LMDE and all the help. Unfortunately, I need some.

After updating, my sound setting are lost.
Output works fine, input produces just noise
on sound recorder as well as Skype.

It is a HP Compaq nx7300. No internal mic, I am using a headset.
The sound card is the well known disaster, Intel HDA,
the AD1981 settings worked in the past.

If anyone can help, it is highly appreciated.
Thanks a lot,
B



run this command as root
Code: Select all
alsactl init
User avatar
blowtorch
Level 3
Level 3
 
Posts: 101
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOW TO: Solve your LMDE audio issues

Postby Bonsaii on Thu Apr 07, 2011 2:17 pm

Sorry, I should have updated that.

It came down to being a hardware problem.

Since that was fixed, LMDE is running as smoothly as ever.

Thanks a lot.

LMDE rocks!
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 89
Joined: Sat Oct 09, 2010 8:49 am

Re: HOW TO: Solve your LMDE audio issues

Postby Jaime Frontero on Tue Apr 12, 2011 1:34 pm

looks like the latest kernel update has sound issues.

i booted into the new kernel, and my microphone was dead. i tried pretty much everything, admittedly without a rigorous approach to troubleshooting (bless you, clonezilla). finally, i purged pulseaudio to see what i could do and the alsa volume control showed both mic boosts as muted. i couldn't unmute them. i'd click 'unmute', close the volume control app, but when i reopened it to check they were muted again.

so now i'm booting back into the 2.6.32-5 kernel with pulseaudio, and the sound (mic) works again - in fact, in skype, so far i don't have to jump through the usual hoops: start skype, make a test call, close skype, and then change my hardware settings prefs to a different setting (like from Analog Duplex to 5.1 w/Analog Input. it doesn't really matter as long as you change it) - the usual workaround.

i love linux - i truly do. and Mint LMDE is exceptional. but:

* sigh * linux and sound...
Jaime Frontero
Level 1
Level 1
 
Posts: 23
Joined: Sat Feb 19, 2011 4:44 pm

Re: HOW TO: Solve your LMDE audio issues

Postby cecar on Tue Apr 12, 2011 1:54 pm

I had exactly same issue with the new kernel. Using old Kernel for now.
cecar
Level 4
Level 4
 
Posts: 364
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: HOW TO: Solve your LMDE audio issues

Postby rijnsma on Tue Apr 12, 2011 2:57 pm

Yes, I agree. :(

But when it runs, it runs fine.

So do I hate that Moonlight thing.
Very dangerous for Linux. I think.

And browsers:
And rtsp:// multimedia links are a problem too (that is more firefox).

Multimedia in Chrome is a real disaster. I don't know how to get things right. :roll:

But many small things can make the difference...
Qiana.... mind your backup..
User avatar
rijnsma
Level 4
Level 4
 
Posts: 282
Joined: Wed May 06, 2009 7:28 am
Location: NL

Re: HOW TO: Solve your LMDE audio issues

Postby Yeticannotski on Sun Apr 17, 2011 9:02 am

Jaime Frontero wrote:i love linux - i truly do. and Mint LMDE is exceptional. but:

* sigh * linux and sound...


Having the same problem after Kernel-upgrade and couldn't agree more with you point. :(
Yeticannotski
Level 1
Level 1
 
Posts: 15
Joined: Mon Mar 14, 2011 5:34 pm

Re: HOW TO: Solve your LMDE audio issues

Postby cecar on Wed Apr 27, 2011 11:19 am

Jaime Frontero wrote:looks like the latest kernel update has sound issues.

i booted into the new kernel, and my microphone was dead. i tried pretty much everything, admittedly without a rigorous approach to troubleshooting (bless you, clonezilla). finally, i purged pulseaudio to see what i could do and the alsa volume control showed both mic boosts as muted. i couldn't unmute them. i'd click 'unmute', close the volume control app, but when i reopened it to check they were muted again.

so now i'm booting back into the 2.6.32-5 kernel with pulseaudio, and the sound (mic) works again - in fact, in skype, so far i don't have to jump through the usual hoops: start skype, make a test call, close skype, and then change my hardware settings prefs to a different setting (like from Analog Duplex to 5.1 w/Analog Input. it doesn't really matter as long as you change it) - the usual workaround.

i love linux - i truly do. and Mint LMDE is exceptional. but:

* sigh * linux and sound...


Just for info so is my microphone back working again. Something must have been fixed because i have done nothing. :)
cecar
Level 4
Level 4
 
Posts: 364
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: HOW TO: Solve your LMDE audio issues

Postby mikebravo on Sun May 29, 2011 10:07 pm

SoundBlaster Audigy 2ZS sound card. New copy of LMDE from On-disc.com. NO SOUND. No help here.
For what it is worth, the sound levels can be seen to change on the Pulse Audio volume meter but it does not get to the speakers.
-------------------------------------------------------------------------------------
Complaint Department:
I used to be running Ubuntu but the first upgrade I did pooched my system. No surprise there because I was configured in RAID0, so perhaps I was expecting too much. My next Ubuntu upgrade also blew up, a real bummer because that time I was starting from a setup that was about as plain vanilla as you can get. So now, I'm thinking how about a rolling release with a few bells and whistles. LMDE might be just the thing, right? Wrong! (I kind of forgot that my last experience with MINT was a release that went out the door unable even to boot.) This time the install went beautifully, I was surfing the web in no time and a quick trip to HPLIP got my printer working. Do not care about wireless. Time to sit back and catch some news vids at http://www.cnn.com. Ran a clip and I could see the talking heads had their lips moving but NO SOUND. Checked the volume level settings, checked for muting. Went to control panel audio utility and found my audio card was identified correctly and turned up. Went to "users" to confirm I was in the audio group. Did apt-get update, wash, rinse, repeat. Still NO SOUND. I see on the PulseAudio volume monitor that I have audio but nothing is getting out. I come to the LMDE forum and follow all the suggestions in this sticky. NO SOUND. confused? By now I am getting desperate as only a noob can get. I Google for every variation of "LMDE NO SOUND" I can think of, and follow every suggestion I can no matter how harebrained. No joy. NO SOUND.
Lets make some comparisons. I have a few other live distros laying around. I run Fedora 14 Live. I got sound out when I ran the speaker test but CNN needed Flash. I ran PClinuxOS live. The talking heads on CNN came through loud and clear. Unfortunately the desktop filled only 2/3 of the screen horizontally. I ran CentOS Live. The speaker test gave me sound out but CNN needed Flash. Just to be thorough, I ran LMDE Live. NO SOUND.
I could have installed ARCH and have been a better man for it in the time I have spent futzing with this. Please tell me that I am doing something wrong. I find it hard to believe that a distribution would be released lacking such a fundamental feature as sound on a mainstream audio card. My experiences have been as if LINUX developers get together and apportion bugs and short comings so that all users can be equally disappointed in some fashion.
EDIT 3June2011 Ran a copy of Debian Live 6.0.1 Gnome. At least LMDE is true to its roots. There were no system sounds in Debian, no sound test buttons, and no talking heads and it did not even bother to ask for Flash.
EDIT 4 June 2011 Ran a copy of Ubuntu 11.04 a.k.a. Natty. Sound test buttons worked as expected. CNN wanted Flash for their talking heads. So far it looks like going back to Ubuntu is my best bet.
mikebravo
Level 1
Level 1
 
Posts: 12
Joined: Sat May 28, 2011 10:07 pm

Re: HOW TO: Solve your LMDE audio issues

Postby mikebravo on Wed Jun 15, 2011 5:28 pm

Addendum to my May 29 post. Still looking for a hassle free distro. Booted live CD of Chakra 0.3.2 (an Arch derivative) Wow, smooth, clean, and quick. I could learn to like KDE. As expected, the talking heads on http://www.cnn.com asked for flash. I did not bother. Went instead to look for a speaker test utility and found it. Too bad, it did not work. NO SOUND. Did not find anything to do with printers either. There were a lot of things to like about Chakra but NO SOUND was not one of them. Booted live CD of OpenSUSE 11.4 Live, Gnome version. This could be a winner. CNN talking heads asked for Flash but the speaker test utility worked like a champ. A well modulated feminine voice says "left channel" or "right channel" when I push the buttons. Do I want to use SUSE instead of Ubuntu? Not really. I will try another update of LMDE. Perhaps they will fix their NO SOUND problem.
EDIT 23June2011 So here I am with OpenSUSE installed and everything is working so far. Next task is to install HP LaserJet M1212nf printer. With that done I will have nothing to complain about with SUSE but I am not totally happy. LMDE never worked for me. The package makes me feel more like a beta tester than a user. Kudos to SUSE but the quest for a perfect out of box experience continues. Turning to the sick old man of Linux, I did a live test of Mandriva One 2010.2. Yes! I had sound with a single click. Alas! It did not configure my display correctly. If SUSE and Ubuntu and LMDE can, why is it Mandriva cannot? When I get around to it I shall see if Mageia can do any better.
EDIT 30June2011 Tried Mageia Live CD. It broke my hart. Once again I find beauty is only skin deep. It had speaker left and right test buttons but NO SOUND. Still looking for love, I slip in a copy of Scientific Linux 6.0. Wow! I think I have found my BFF. This is the best out of box experience I have had since Ubuntu. Sound works! Goodbye SUSE, Scientific Linux is going on my hard drive.
EDIT 25 July 2011 Alas, my fling with CERN Scientific Linux is over. I installed my printer in Ubuntu, no problem. I installed it in SUSE, no problem. But I try to install it in SL and I have one problem after another. Now what am I going to do? Perhaps if I mess around long enough LMDE will come out with a version that works for me. Can't imagine the fun it will be getting Skype to work with a webcam. Did it with Ubuntu a few releases back but it quit working with the first upgrade. Using Linux is like hitting your finger with a hammer. You want to do it again and again because it feels so good when it quits hurting.

Time passes...............and hardware changes. My Creative Sound-Blaster audio card got moved to my daughtors new computer and I replaced it with a $9.95 no name card from the Newegg bargin bin. Gave LMDE2011109 another try (I'm looking to get away from Unity) and joy oh joy sound works like it should. Hot to trot with LMDE but wait, installer will not install / on one drive and /home on another. Crap! Find more on that at:
viewtopic.php?f=201&t=83144
Last edited by mikebravo on Thu Dec 15, 2011 8:20 pm, edited 4 times in total.
mikebravo
Level 1
Level 1
 
Posts: 12
Joined: Sat May 28, 2011 10:07 pm

Re: HOW TO: Solve your LMDE audio issues

Postby lmde_freak on Sun Jun 26, 2011 7:12 pm

i'll tell you how to solve your lmde audio issues...purge that ridiculously sh*tty pulseaudio and use alsa, here's how:

$ killall pulseaudio
$ sudo killall pulseaudio
$ sudo apt-get purge pulseaudio pulseaudio-utils
gstreamer0.10-pulseaudio libpulse-browse0 paman pavumeter pavucontrol
$ sudo mv /etc/asound.conf /etc/asound.conf-bak
$ sudo rm ~/.pulse-cookie
$ sudo rm -r ~/.pulse

-->(oh no, my audio icon applet disappeared...don't worry) restart your computer

$ sudo apt-get install libalsaplayer0

-->right click panel, select “add to panel" and add "volume control" to panel

and voila, now you have awesome external audio/internal mic action! whether in skype or clementine

enjoy!
User avatar
lmde_freak
Level 1
Level 1
 
Posts: 4
Joined: Tue May 24, 2011 11:58 pm

Re: HOW TO: Solve your LMDE audio issues

Postby Sonsum on Tue Jun 28, 2011 8:30 pm

I replaced pulseaudio with alsa and STILL had no luck!

Then I realized that I had not updated the kernel from the original. That fixed it. :lol:
Sonsum
Level 3
Level 3
 
Posts: 111
Joined: Fri Jun 24, 2011 9:03 pm

Re: HOW TO: Solve your LMDE audio issues

Postby Darktrax on Wed Jun 29, 2011 7:10 pm

On my updated Mint LMDE, the /etc/asound.conf file comes already configured exactly as suggested.

Even so, I notice that MP4 and flash (.flv) files play with a significant latency delay in the audio to the point where spoken words are so far behind sync it is unwatchable.

Yet the identical same file, played with the same app (VLC Media Player), but from the previous Ubuntu distro partition, does not have that problem.

So before I blame PulseAudio, and set about removing it, might it be something else causing this mess?
D

EDIT: PS. I have just completed the "Remove PulseAudio Nuke-it" procedure and installed libalsaplayer0 instead.
Now it WORKS! I can see the cute country singer now has perfect lip sync. That PulseAudio was causing a
huge lag
, even though my box uses an Intel i7-860 with 4G of RAM!

My thanks to you folk for suggesting to trash it.
D
Darktrax
Level 1
Level 1
 
Posts: 11
Joined: Sun May 01, 2011 7:26 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 1 guest