Lost my desktop background and icons [NEVER SOLVED} REINSTAL

Forum rules
Before you post please read this

Lost my desktop background and icons [NEVER SOLVED} REINSTAL

Postby woodworks on Thu Jun 30, 2011 7:35 pm

just logged in for the afternoon, to find that my desktop background gone, icons usually displayed in the panel menu gone, opening the xfce menu I see applications, but icons missing. Trying to right click and change background, no images are available and when I try and add one, it doesn't display.

.xsession-errors seems to point to some sort of GTK error and complains about "unrecognized image file format" (gads, such as .png)

also nautilus error (nautilus:2412):GdkPixbuf-CRITICAL **: gdk_pixbuf_format_get_name: assertion "format != NULL' failed (this is just one of many following the same format)

about the only thing i had done unusual, just before morning shutdown was to apt-get purge opera as i already have firefox and chromium running.

I'm really at a loss, so don't know what to report
Last edited by woodworks on Sun Jul 03, 2011 5:49 pm, edited 1 time in total.
woodworks
Level 1
Level 1
 
Posts: 6
Joined: Wed Jun 08, 2011 1:43 pm

Linux Mint is funded by ads and donations.
 

Re: Lost my desktop background and icons

Postby merlwiz79 on Thu Jun 30, 2011 8:23 pm

Well the problem is that Nautilus is installed.
They make nautilus for Gnome.
It would be easier if they had it setup to run in any desktop environment.
It's actually simple to do but they don't seem to care too.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Lost my desktop background and icons

Postby woodworks on Fri Jul 01, 2011 3:00 am

merlwiz79 wrote:Well the problem is that Nautilus is installed.
.


well, that's not the problem because after much trial and error, removed with apt-get purge nautilus.

i'm still having a bunch of problems with missing icons, though after removing and reinstalling xfce4 most of them are back, here's the wierdest behavior though, when i select a file in thunar (removed and reinstalled also) it disappears from view.

still can't change desktop background, windows have no desernable scroll bars, though if you know where they should be they work, can't add Xfapplet to panel to gain mint menu (when clicking on it it dissapears as above, clicking on the Add button then does nothing)
woodworks
Level 1
Level 1
 
Posts: 6
Joined: Wed Jun 08, 2011 1:43 pm

Re: Lost my desktop background and icons

Postby woodworks on Fri Jul 01, 2011 10:35 am

well, cleared out .xsession-errors, rebooted and this is what is reported:
Code: Select all
/etc/gdm3/Xsession: Beginning session setup...
/usr/bin/startxfce4: X server already running on display :0
xrdb:  "Xft.hinting" on line 9 overrides entry on line 6
xrdb:  "Xft.hintstyle" on line 11 overrides entry on line 7
xfdesktop[2477]: starting up

(xfce4-xfapplet-plugin:2485): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
(xfce4-xfapplet-plugin:2488): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
(xfce4-xfapplet-plugin:2490): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
(xfce4-xfapplet-plugin:2489): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
(xfce4-xfapplet-plugin:2491): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
garcon-Message: Could not load menu file data from file:///home/daveo/.config/menus/wine-doors.menu
xfce4-settings-helper: Another instance is already running. Leaving...
Starting Dropbox...** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
Conky: forked to background, pid is 2602

Conky: desktop window (1600003) is subwindow of root window (100)
Conky: window type - override
Conky: drawing to created window (0x3600001)
Conky: drawing to double buffer
Couldn't recognize the image file format for file '/usr/lib/linuxmint/mintUpdate/icons/base.svg'
Done!
libxfce4panel-Message: Failed to load image "/usr/lib/linuxmint/mintInstall/icon.svg": Unrecognized image file format
libxfce4panel-Message: Failed to load image "/usr/lib/linuxmint/mintWelcome/templates/logo.svg": Unrecognized image file format
libxfce4panel-Message: Failed to load image "/usr/share/icons/hicolor/scalable/apps/emacs23.svg": Unrecognized image file format
libxfce4panel-Message: Failed to load image "/usr/share/pixmaps/vim.svg": Unrecognized image file format
libxfce4panel-Message: Failed to load image "/usr/share/icons/hicolor/scalable/apps/emacs23.svg": Unrecognized image file format
libxfce4panel-Message: Failed to load image "/usr/share/pixmaps/idle.xpm": Unrecognized image file format
libxfce4panel-Message: Failed to load image "/usr/share/pixmaps/python2.6.xpm": Unrecognized image file format


since nautilus is no longer installed, its not the one generating the error messages.
another symptom i've noticed is that thunar has lost file associations, on clicking emacs icon it wants to know if it should open with xarchiver!
woodworks
Level 1
Level 1
 
Posts: 6
Joined: Wed Jun 08, 2011 1:43 pm

Re: Lost my desktop background and icons [NEVER SOLVED} REIN

Postby moloch42 on Fri Aug 19, 2011 8:54 pm

I've Just experienced what I believe to be the same problem. My desktop background disapeared along with some of my desktop icons. When I tried so change some of my desktop setting it seemed as though it was trying to launch the gnome settings guis rather than the XFCE ones.

I solved this problem by deleting(re-naming) the .cache directory in my home folder.
moloch42
Level 1
Level 1
 
Posts: 1
Joined: Fri Aug 19, 2011 8:27 pm

Re: Lost my desktop background and icons [NEVER SOLVED} REIN

Postby deadline on Fri Feb 22, 2013 4:10 pm

I have this same problem and deleting teh cache didnt help does anyone have any ideas besides reinstalling?
deadline
Level 1
Level 1
 
Posts: 3
Joined: Fri Feb 22, 2013 3:44 pm


Return to XFCE

Who is online

Users browsing this forum: Chriskmint and 2 guests