M-Audio Audiophile 2496 - no sound under Mint 9

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

M-Audio Audiophile 2496 - no sound under Mint 9

Postby loserxyz8 on Sat Jul 03, 2010 1:06 pm

Hi,

i have been using the M-Audio Audiophile 2496 for some time now. It used to work flawlessly until I think Ubuntu 6 or 7, but not at all in any version higher than that, and now it's not working in Mint either.

The point is: the system DOES seem to recognize the sound card, at least it's listed in that "Audio Properties" windows (or whatever this is called in English), but I simply don't hear a thing.
While using the Live-CD I actually got that sound-output-display to correctly SHOW when there should have been sound, though I generally would prefer to actually hear it.

I know literally nothing about the inner workings of a Linux system, from the stuff I found on Google I think there appears to be something called "Alsa" (though I don't really get what to do with it), and the speakers ARE turned on, I checked all of that, so please take that into account if you have any idea how to solve this problem.


Yes, I did search the forums for a solution to this, but I didn't really find anything that appeared to be too helpful (like: lots of ideas what to type into a terminal that only lead to a "application doesn't exist" message with me, because those tips were apparently written with an Ubuntu system in mind, i guess).


Thanks in advance.
loserxyz8
Level 1
Level 1
 
Posts: 1
Joined: Sat Jul 03, 2010 9:22 am

Linux Mint is funded by ads and donations.
 

Re: M-Audio Audiophile 2496 - no sound under Mint 9

Postby JasonLG on Mon Jul 05, 2010 1:26 am

loserxyz8 wrote:Hi,

i have been using the M-Audio Audiophile 2496 for some time now. It used to work flawlessly until I think Ubuntu 6 or 7, but not at all in any version higher than that, and now it's not working in Mint either.

The point is: the system DOES seem to recognize the sound card, at least it's listed in that "Audio Properties" windows (or whatever this is called in English), but I simply don't hear a thing.
While using the Live-CD I actually got that sound-output-display to correctly SHOW when there should have been sound, though I generally would prefer to actually hear it.

I know literally nothing about the inner workings of a Linux system, from the stuff I found on Google I think there appears to be something called "Alsa" (though I don't really get what to do with it), and the speakers ARE turned on, I checked all of that, so please take that into account if you have any idea how to solve this problem.


Yes, I did search the forums for a solution to this, but I didn't really find anything that appeared to be too helpful (like: lots of ideas what to type into a terminal that only lead to a "application doesn't exist" message with me, because those tips were apparently written with an Ubuntu system in mind, i guess).


Thanks in advance.

Enter this into a terminal.
Code: Select all
alsamixer

Press F6 and select your card and press enter. Look at the faders and make sure they are not muted or turned all the way down. A "OO" at the bottom of the faders means it's not muted, "MM" means it is. Highlight any muted faders by using the left and right arrow keys and press m to unmute them. You can adjust a selected faders volume with the up and down arrows.
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.
JasonLG
Level 7
Level 7
 
Posts: 1624
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

Re: M-Audio Audiophile 2496 - no sound under Mint 9

Postby jadamso on Mon Jul 05, 2010 12:28 pm

Had exactly the same problem. Here's the solution:
1. Open up terminal. Type in su and press enter. Use the password that you created when you installed Mint. That will give you sudo privileges.
2. Type sudo gedit /lib/udev/rules.d/90-pulseaudio.rules and add the following line after the last Subsystems entry:
SUBSYSTEMS=="pci", ATTRS{vendor}=="0x1412", ATTRS{device}=="0x1712", ATTRS{subsystem_vendor}=="0x1412", ATTRS{subsystem_device}=="0xd634", ENV{PULSE_PROFILE_SET}="m_audio-audiophile-2496.conf"
3. Whilst still root in terminal type sudo gedit. Copy and paste the following in the new file:

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as
# published by the Free Software Foundation; either version 2.1 of the
# License, or (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

; M-Audio Delta Audiophile 2496
;
; This card, based on the Via ICE1712 chipset, has two stereo audio channels
; (1 in and 1 out) and a separate S/PDIF digital stereo channel. Like with
; all ICE1712-based cards, this is exposed by ALSA as a single 10-channel
; device with some of the channels not connected.
;
; See default.conf for an explanation on the directives used here.

[General]
auto-profiles = no

[Mapping analog-stereo-in]
description = Analog Stereo Input
device-strings = hw:%f,0
channel-map = front-left,front-right,aux0,aux1,aux2,aux3,aux4,aux5,aux6,aux7,aux8,aux9
direction = input

[Mapping analog-stereo-out]
description = Analog Stereo Output
device-strings = hw:%f,0
channel-map = front-left,front-right,aux0,aux1,aux2,aux3,aux4,aux5,aux6,aux7
direction = output

[Mapping analog-digital-stereo-out]
description = Analog/Digital Stereo Output
device-strings = hw:%f,0
channel-map = front-left,front-right,aux0,aux1,aux2,aux3,aux4,aux5,front-left,front-right
direction = output

[Mapping digital-stereo-out]
description = Digital Stereo Output
device-strings = hw:%f,0
channel-map = aux0,aux1,aux2,aux3,aux4,aux5,aux6,aux7,front-left,front-right
direction = output

[Mapping digital-stereo-in]
description = Digital Stereo Input
device-strings = hw:%f,0
channel-map = front-left,front-right,front-left,front-right,front-left,front-right,front-left,front-right,front-left,front-right,front-left,front-right
direction = input

[Mapping digital-stereo]
description = Digital Stereo Input/Output
#device-strings = hw:%f,1
device-strings = iec958:%f
channel-map = left,right
direction = any

[Profile output:stereo]
description = Analog Stereo Output
output-mappings = analog-stereo-out
input-mappings =
priority = 80
skip-probe = yes

[Profile output:stereo-da+input:stereo-analog]
description = Analog Stereo Input/Output
output-mappings = analog-stereo-out
input-mappings = analog-stereo-in
priority = 100
skip-probe = yes

[Profile output:stereo-da+input:stereo-analog]
description = Analog Stereo Input/Output, Digital Stereo Output
output-mappings = analog-digital-stereo-out
input-mappings = analog-stereo-in
priority = 90
skip-probe = yes

[Profile output:spdif]
description = Digital Stereo Output (Analog Disabled)
output-mappings = digital-stereo-out
input-mappings =
priority = 60
skip-probe = yes

[Profile output:spdif+input:spdif]
description = Digital Stereo Input/Output (Analog Disabled)
output-mappings = digital-stereo-out
input-mappings = digital-stereo-in
priority = 70
skip-probe = yes

4. Save as m_audio-audiophile-2496.conf in /usr/share/pulseaudio/alsa-mixer/profile-sets/
5. Restart your computer.
6. Once restarted go into Sound manager and ensure all options are set to PCI card. Be careful: I did this with the speakers on and almost had a heart attack when the music suddenly kicked in.
7. Enjoy!

Adapted from the following link:

http://ubuntuforums.org/showthread.php?t=1268856

Its a shame that people have had to find a work around for a soundcard from such a major manufacturer (though its not like avid/m-audio pander to the needs of linux in their audio software).
Just note the comments in the link about updating pulseaudio.

J.
jadamso
Level 1
Level 1
 
Posts: 2
Joined: Mon Jul 05, 2010 12:12 pm

Re: M-Audio Audiophile 2496 - no sound under Mint 9

Postby PeDr0 on Sat Aug 06, 2011 5:13 am

I've done all this, the only thing I haven't done is login as root http://forums.linuxmint.com/viewtopic.php?f=90&p=457878#p457878 but I have been using a user with admin rights, I believe I have put things in the correct place but I still aint getting sound?

By sound manager do you mean sound preferences :?: Oh well I might have to re-install anyway..

Pete
PeDr0
Level 1
Level 1
 
Posts: 25
Joined: Sat Aug 06, 2011 4:57 am

Re: M-Audio Audiophile 2496 - no sound under Mint 9

Postby PeDr0 on Sat Aug 06, 2011 8:18 am

I've sorted it now :-)

Thank you
PeDr0
Level 1
Level 1
 
Posts: 25
Joined: Sat Aug 06, 2011 4:57 am

Re: M-Audio Audiophile 2496 - no sound under Mint 9

Postby umma gumma on Fri Feb 08, 2013 7:18 pm

hey everyone I wanted to sat *THANKS* I just installed ubuntu 12 & had the exact same issue with my 2496 sound card

the instructions above worked 100%

google brought me here


cheers
umma gumma
Level 1
Level 1
 
Posts: 1
Joined: Fri Feb 08, 2013 7:07 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 14 guests