[SOLVED] Canon Pixma MG5200 driver problem

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

[SOLVED] Canon Pixma MG5200 driver problem

Postby rdanner3 on Mon Aug 08, 2011 12:06 am

Simply put, the install script dies after insisting
Code: Select all
An error occurred. The package management system cannot be identified.
Now, admittedly, this driver was downloaded from Canon Australia, but why should that make a difference? Or does it? Frustrating thing is, the Canon US site does not have this driver set available, to my knowledge. Anyone know how I can resolve this issue and get my printer's drivers installed?
Last edited by rdanner3 on Wed Aug 10, 2011 12:18 am, edited 1 time in total.
Toshiba Satellite A505-S6005 on LM17 x64 (MATE/LXDE).
Linux dabbler since 1996. Registered Linux User #547455
Serious Linux user since Linux Mint 9 (also x64).
User avatar
rdanner3
Level 2
Level 2
 
Posts: 89
Joined: Thu Jun 17, 2010 10:19 pm
Location: Central Alabama, USA

Linux Mint is funded by ads and donations.
 

Re: Canon Pixma MG5200 driver problem

Postby remoulder on Mon Aug 08, 2011 6:49 am

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Canon Pixma MG5200 driver problem

Postby rdanner3 on Mon Aug 08, 2011 2:38 pm

Have tried that. For some off-the-wall reason (although I know the printer's IP address) the printer cannot be found by the OS, even after installing the drivers manually via GDebi (the install.sh files both failed with the indicated error). Ideas?
Toshiba Satellite A505-S6005 on LM17 x64 (MATE/LXDE).
Linux dabbler since 1996. Registered Linux User #547455
Serious Linux user since Linux Mint 9 (also x64).
User avatar
rdanner3
Level 2
Level 2
 
Posts: 89
Joined: Thu Jun 17, 2010 10:19 pm
Location: Central Alabama, USA

Re: Canon Pixma MG5200 driver problem

Postby remoulder on Mon Aug 08, 2011 6:22 pm

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Canon Pixma MG5200 driver problem

Postby pdc_2 on Tue Aug 09, 2011 1:30 am

so your issue is that canon's install script does not run;

if you have the drivers

(eg from here http://software.canon-europe.com/softwa ... asp?model=)

if you have extracted them; (by right-clicking and selecting archive manager)

you should be able to install them with the debian gdebi installer; that should just work fine for you

let us know how we can help you with the details of all of this

____________

if you help us understand which version of this

https://linuxtidbits.wordpress.com/2011 ... ntu-setup/

you used:

ie you could download the file from here

http://software.canon-europe.com/softwa ... asp?model=

or use the weget command

I wonder if you were in the correct directory to issue the command

sudo ./install.sh


you would need to be inside the directory

cnijfilter-mg5200series-3.40-1-deb/


ALSO: are you using 32bit or 64bit Mint: you are using Mint 10 ?
pdc_2
Level 6
Level 6
 
Posts: 1181
Joined: Mon May 11, 2009 1:21 am

Re: Canon Pixma MG5200 driver problem

Postby rdanner3 on Wed Aug 10, 2011 12:17 am

pdc_2 wrote:so your issue is that canon's install script does not run;

if you have the drivers

(eg from here http://software.canon-europe.com/softwa ... asp?model=)

if you have extracted them; (by right-clicking and selecting archive manager)

you should be able to install them with the debian gdebi installer; that should just work fine for you

let us know how we can help you with the details of all of this

____________

if you help us understand which version of this

https://linuxtidbits.wordpress.com/2011 ... ntu-setup/

you used:

ie you could download the file from here

http://software.canon-europe.com/softwa ... asp?model=

or use the weget command

I wonder if you were in the correct directory to issue the command

sudo ./install.sh


you would need to be inside the directory

cnijfilter-mg5200series-3.40-1-deb/


ALSO: are you using 32bit or 64bit Mint: you are using Mint 10 ?
Correctly installed the drivers (test-page successful) after following a file download from http://ubuntuforums.org/showthread.php?t=1475336, although I will need to revisit said link to correctly install the scanner driver. Marking as solved.

OS: Linux Mint 10 x64
MG5200 driver version: 3.4.0-1 x64 (IIRC)

It turns out that the script contains a serious oops that causes installs to fail if ANY rpm packages have been installed on the system. Commenting out the code and hardcoding the correct responses works, but downloading the corrected install.sh is easier. LOL
Toshiba Satellite A505-S6005 on LM17 x64 (MATE/LXDE).
Linux dabbler since 1996. Registered Linux User #547455
Serious Linux user since Linux Mint 9 (also x64).
User avatar
rdanner3
Level 2
Level 2
 
Posts: 89
Joined: Thu Jun 17, 2010 10:19 pm
Location: Central Alabama, USA

Re: [SOLVED] Canon Pixma MG5200 driver problem

Postby joez on Tue Jan 01, 2013 9:25 am

It seems you can't have both dpkg and rpm installed and run the install.sh script. I removed rpm, and googleearth along with it, and he install.sh script ran fine.
joez
Level 2
Level 2
 
Posts: 80
Joined: Wed Oct 12, 2011 9:28 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 14 guests