Can't get vsync to work

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Can't get vsync to work

Postby Mozenrath on Thu Aug 18, 2011 3:58 am

This wasn't an issue until my BFG Tech graphics card gave out. So I replaced it with PNY card with a better Nvidia GPU. Everything seems to work fine except for horrible horizontal tearing.

It happens even when I switch over to Metacity. I normally use Mutter which gives me a good compromise between compositing and vsync, but that doesn't work either. I tried compiz, but it doesn't work either(actually causes a "blockier" tearing) and I just don't want to use it.

In the Nvidia settings, I have tried setting both video texture and opengl to sync to vblank. That doesn't seem to have any effect. I get the exact same thing if I have both options disabled.

What the heck am I doing wrong!? I don't want to return an otherwise awesome graphics card. :(
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Linux Mint is funded by ads and donations.
 

Re: Can't get vsync to work

Postby remoulder on Thu Aug 18, 2011 8:58 am

Is the nvidia driver the correct one for the new card? If you have an xorg.conf, try deleting/renaming it then re-running nvidia-settings.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Can't get vsync to work

Postby Mozenrath on Thu Aug 18, 2011 10:34 pm

remoulder wrote:Is the nvidia driver the correct one for the new card? If you have an xorg.conf, try deleting/renaming it then re-running nvidia-settings.


It should be, anyway. I didn't use a driver from the repos; None of them worked so I used the one specifically for this card from Nvidia and it worked.

I'll try the xorg.conf thing.
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Can't get vsync to work

Postby Mozenrath on Fri Aug 19, 2011 9:14 pm

Okay, I reinstalled the latest driver and I had it create a new xorg.conf. Now I'm back to where I was; Still tearing in every window manager/compositor. No combination of settings seem to work.

I'd like to mention that I am also using dual monitors with twinview, but this was the way I had it working before. I have it set to sync to my main monitor.
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Can't get vsync to work

Postby remoulder on Sat Aug 20, 2011 8:38 am

Mozenrath wrote:reinstalled the latest driver

The 'latest' driver is not always the best choice with nvidia cards, people sometimes report better results with different versions. I would suggest turning off any effects until you have a stable display, same for twinview. You might also want to consider completely removing any nvidia drivers as per https://www.linuxquestions.org/questions/debian-26/nvidia-issue-remove-debian-packages-875447/ and starting afresh, IOW go back to basics. Mutter is not part of the standard mint system, so installing this may have affected things. Other than that I have no more suggestions.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Can't get vsync to work

Postby Mozenrath on Sat Aug 20, 2011 6:05 pm

remoulder wrote:
Mozenrath wrote:reinstalled the latest driver

The 'latest' driver is not always the best choice with nvidia cards, people sometimes report better results with different versions. I would suggest turning off any effects until you have a stable display, same for twinview. You might also want to consider completely removing any nvidia drivers as per https://www.linuxquestions.org/questions/debian-26/nvidia-issue-remove-debian-packages-875447/ and starting afresh, IOW go back to basics. Mutter is not part of the standard mint system, so installing this may have affected things. Other than that I have no more suggestions.


I'm not saying that you're wrong, but that's ridiculous that the 'latest' driver wouldn't work properly. I could find an older driver, but it would have to be from the Nvidia site because the nvidia-current for Mint 10 doesn't work(I get a screen full of random colors). The only way for me to get the newer one from the repos is to upgrade, which I really don't want to do because I use rely on my system to do graphic-intensive work and I don't want to somehow wreck it.

I don't think Mutter should have effected anything because it worked fine with my last Nvidia card. I often switch between Mutter/Compiz/Metacity due to my needs, and I get the same problem with Compiz and Metacity.
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Can't get vsync to work

Postby remoulder on Sun Aug 21, 2011 9:43 am

Mozenrath wrote: that's ridiculous that the 'latest' driver wouldn't work properly

You may like to read my post again more carefully. I said sometime users report better results with other versions, just because a driver is the latest, does not always make it the best choice for a particular card, the Hardware Drivers applet normally offers a choice of versions. You asked for advice by posting here, if you choose not to take it that is up to you. Good luck in solving your problem.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Can't get vsync to work

Postby mbalazs81 on Sun Aug 21, 2011 10:27 am

Hello
Sorry for bad english.
(LMDE xfce 64bit,Nvidia 9600GT, nv driver: 280.13)
When I turn vsync on in the nvidia x server settings windows, dont work. I can save the configuration to a file. But this configuration file dont work if I rename to xorg conf. So what can I do with this file to save the vsync setting?

I found this ftp://download.nvidia.com/XFree86/Linux ... -guide.txt

So this is the key: nvidia-settings --load-config-only

but the output: http://pastebin.com/kqWcu7ws
Linux Mint KDE
mbalazs81
Level 2
Level 2
 
Posts: 56
Joined: Fri Mar 18, 2011 12:38 am

Re: Can't get vsync to work

Postby Mozenrath on Thu Aug 25, 2011 8:45 pm

This tearing issue is really bugging me. I don't want to have to buy yet another card.

I disabled twinview and there's no more tearing on my main monitor. But I need both monitors for the work I do, so I had to re-enable twinview and the tearing on my main monitor came back. There doesn't seem to be tearing on the other one.

Here's the driver I'm using. I can't figure out where to get an older driver that's compatible.
http://www.nvidia.com/object/linux-disp ... river.html

The nvidia-current for Mint 10(260.19.06-0ubuntu1) just gives me complete distortion gobbledygook on my screen. Basically, it doesn't work.

Also, here's my xorg.conf file:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 280.13 (buildmeister@swio-display-x86-rhel47-03.nvidia.com) Wed Jul 27 17:15:45 PDT 2011


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Princeton Graphics VL158"
HorizSync 30.0 - 60.0
VertRefresh 50.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 520"
EndSection

Section "Screen"

# Removed Option "TwinView" "1"
# Removed Option "metamodes" "CRT: nvidia-auto-select +1680+141, DFP: nvidia-auto-select +0+0"
# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: 1680x1050_60 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "CRT: nvidia-auto-select +1680+141, DFP: 1680x1050_60 +0+0; CRT: nvidia-auto-select +1680+0, DFP: 1680x1050_60_0 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


The Gateway monitor is my main monitor.
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Can't get vsync to work

Postby Mozenrath on Sat Aug 27, 2011 10:36 pm

Anybody?

Here's my output from xrandr:

xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 2704 x 1050, current 2704 x 1050, maximum 2704 x 1050
default connected 2704x1050+0+0 0mm x 0mm
2704x1050 50.0* 51.0
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Can't get vsync to work

Postby mbalazs81 on Sun Aug 28, 2011 2:35 pm

I have not found another solution only compiz 'on'. :/
Linux Mint KDE
mbalazs81
Level 2
Level 2
 
Posts: 56
Joined: Fri Mar 18, 2011 12:38 am

Re: Can't get vsync to work

Postby Mozenrath on Mon Aug 29, 2011 6:03 am

mbalazs81 wrote:I have not found another solution only compiz 'on'. :/


With my last card, running a compositor solved the vsync problem. Compiz worked but it really decreases FPS when using 3d applications. The reason I switched to Mutter was because I got some basic compositing without any noticeable difference from using Metacity with compositing turned off.

Now when I use Metacity or Compiz, I get multiple tear lines when pixels are changing on screen. My guess is that this happens because Compiz's vsync frequency is way off from the screen frequency. I only get one really slow tear line when using Mutter, which might mean that the vsync frequency for Mutter is closer but not quite close enough?
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Can't get vsync to work

Postby Mozenrath on Mon Aug 29, 2011 6:19 pm

So far, the closest I've gotten to solving the vsync problem is to use metacity with basic compositing turned on. I want some real compositing, though. :(
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Can't get vsync to work

Postby 3×5 on Thu Jan 03, 2013 9:22 pm

I'm running mate, and if I turn off compositing, VLC will play videos without tearing. Youtube, however, still has tearing, and inkscape also shows tearing when I draw shapes and things.

I have a desktop with an nvidia graphics card, and a laptop without one. Both have the same problem. If I go into nvidia x server settings, there isn't a setting to be found anywhere with regards to vsync. Do I need a specific package for this?

The fact that I'm getting tearing on the two different computers seems somehow significant to me.
3×5
Level 1
Level 1
 
Posts: 39
Joined: Sat Sep 01, 2012 11:36 am

Re: Can't get vsync to work

Postby mbalazs81 on Tue Jul 02, 2013 9:47 am

Solution:
sudo add-apt-repository ppa:richardgv/compton
sudo apt-get update && sudo apt-get install compton

To the startup: compton --vsync opengl
Linux Mint KDE
mbalazs81
Level 2
Level 2
 
Posts: 56
Joined: Fri Mar 18, 2011 12:38 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 6 guests