Wireless Not Enabled

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Re: Wireless Not Enabled

Postby Mattia on Sun Sep 04, 2011 1:43 pm

Hi!
I've got a problem with my wireless connection, the driver seems to be right-installed and connected, but when I try to surf the web, it just doesn't work.. I've also installed Wicd Network manager but it always give me some error, like "wrong password" (but I've tried to write it many times so I'm sure that it isn't the real problem) or "problem to find the IP".
I've used ubuntu for few months and I've installed Linux Mint 11 LXDE 32-bit two weeks ago on my netbook Acer Aspire One, so I'm not very expert as you can see..
If this can help, I wrote on the terminal "Lspci" and it gave me back "01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
03:00.0 Ethernet controller: Atheros Communications AR8132 Fast Ethernet (rev c0)" and I've also tried "jockey-text" but it doesn't work
"Additional Drivers
Searching for available drivers..." and then nothing.. I don't know what to do!!
Thanks to everyone!
Mattia
Mattia
Level 1
Level 1
 
Posts: 3
Joined: Sun Sep 04, 2011 8:04 am

Linux Mint is funded by ads and donations.
 

Re: Wireless Not Enabled

Postby jefrino on Wed Sep 07, 2011 7:01 pm

Chili555, So that you know just how useful your advice is, I have an Acer laptop (loaded with 64-bit Katya) with the same Broadcom BCM4311 wireless adapter which exhibited the same problems as the user immediately above (i.e. jogamedu).

I followed your instructions (getting almost exactly the same responses and error messages as above) which, of course, ultimately resulted in a functioning wireless network. Thank you for coming up with an elegant solution to this otherwise daunting problem!
jefrino
Level 1
Level 1
 
Posts: 11
Joined: Fri Sep 02, 2011 2:39 pm

Re: Wireless Not Enabled

Postby chili555 on Mon Sep 19, 2011 7:06 am

Mattia wrote:Hi!
I've got a problem with my wireless connection, the driver seems to be right-installed and connected, but when I try to surf the web, it just doesn't work.. I've also installed Wicd Network manager but it always give me some error, like "wrong password" (but I've tried to write it many times so I'm sure that it isn't the real problem) or "problem to find the IP".
I've used ubuntu for few months and I've installed Linux Mint 11 LXDE 32-bit two weeks ago on my netbook Acer Aspire One, so I'm not very expert as you can see..
If this can help, I wrote on the terminal "Lspci" and it gave me back "01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
03:00.0 Ethernet controller: Atheros Communications AR8132 Fast Ethernet (rev c0)" and I've also tried "jockey-text" but it doesn't work
"Additional Drivers
Searching for available drivers..." and then nothing.. I don't know what to do!!
Thanks to everyone!
Mattia
Please let us see:
Code: Select all
dmesg | grep b43
sudo iwlist wlan0 scan
Thanks.
chili555
Level 3
Level 3
 
Posts: 141
Joined: Sun Apr 22, 2007 12:07 pm

Re: Wireless Not Enabled

Postby AlbertP on Mon Sep 19, 2011 7:49 am

The 'STA' driver doesn't work correctly for this card in Mint 11. You'll need to uninstall it and use the B43 driver instead.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Not Enabled

Postby Amith Kumar U R on Mon Sep 19, 2011 8:37 am

hi, first of all am a newbie. Even am also facing some problem with my wifi. I don't know why it is not connecting.I have tried to connect wifi using wicd network manager but wifi is not conecting. :(

I tried this
Code: Select all
modprobe wl
FATAL: Module wl not found.


how to fix this? :(
Amith Kumar U R
Level 1
Level 1
 
Posts: 8
Joined: Wed Jul 20, 2011 3:34 pm

Re: Wireless Not Enabled

Postby chili555 on Mon Sep 19, 2011 9:03 am

Amith Kumar U R wrote:hi, first of all am a newbie. Even am also facing some problem with my wifi. I don't know why it is not connecting.I have tried to connect wifi using wicd network manager but wifi is not conecting. :(

I tried this
Code: Select all
modprobe wl
FATAL: Module wl not found.


how to fix this? :(
If you have the same card as the original poster, you should not find the module wl. If you do not have the same card, please start a new thread. Which is it?
Code: Select all
lspci -nn | grep 0280
chili555
Level 3
Level 3
 
Posts: 141
Joined: Sun Apr 22, 2007 12:07 pm

Re: Wireless Not Enabled

Postby Amith Kumar U R on Mon Sep 19, 2011 9:38 am

By chili555 : If you have the same card as the original poster, you should not find the module wl. If you do not have the same card, please start a new thread. Which is it?


well, i got this
Code: Select all
lspci -nn | grep 0280
03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1000 [8086:0083]
Amith Kumar U R
Level 1
Level 1
 
Posts: 8
Joined: Wed Jul 20, 2011 3:34 pm

Re: Wireless Not Enabled

Postby AlbertP on Mon Sep 19, 2011 10:11 am

To everyone with a 4311 card.

Please connect to wired internet and install b43-fwcutter from Package Manager.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Not Enabled

Postby chili555 on Mon Sep 19, 2011 3:31 pm

Amith Kumar U R wrote:
By chili555 : If you have the same card as the original poster, you should not find the module wl. If you do not have the same card, please start a new thread. Which is it?


well, i got this
Code: Select all
lspci -nn | grep 0280
03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1000 [8086:0083]
The posts in this thread deal with the Broadcom 4312 and 4311 cards. I suggest you start your own new thread and refer to Intel 1000 in the title. Post
Code: Select all
rfkill list all
dmesg | grep iwl
Thanks.
chili555
Level 3
Level 3
 
Posts: 141
Joined: Sun Apr 22, 2007 12:07 pm

Re: Wireless Not Enabled

Postby AlbertP on Mon Sep 19, 2011 4:07 pm

Amith Kumar U R:

Please make sure linux-firmware-nonfree is installed in Software Manager. You can, if needed, use a wired internet connection to install it. If it still does not work, please open a new topic.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Not Enabled

Postby Amith Kumar U R on Tue Sep 20, 2011 2:53 am

okay.. thanks chili .. thanks Albert... :)
Amith Kumar U R
Level 1
Level 1
 
Posts: 8
Joined: Wed Jul 20, 2011 3:34 pm

Re: Wireless Not Enabled

Postby flanna on Sat Sep 24, 2011 2:25 am

chili555 wrote:Is there any chance you'd like to make it permanent?? It looks to me like all it took was:
Code: Select all
sudo rfkill unblock all
Would you please reboot and issue that single command? If that's it, we'll tweak one file to make it persistent. If not, we'll dig deeper.


I have the same problem on my Lenovo x121e. After booting the wifi doesn't work.
When I run this code in terminal it works until it sleeps or is turned off, next wake-up or start, no wifi again:
Code: Select all
su
rfkill unblock all
This only works when logged in as su. It does not work with sudo.
I would really like to make this persistent. How can I do this?
flanna
Level 2
Level 2
 
Posts: 88
Joined: Sun Sep 18, 2011 11:10 am

Re: Wireless Not Enabled

Postby AlbertP on Sat Sep 24, 2011 6:09 am

We'll need to know what's causing your wireless to turn off every boot.

Please run this command, before running rfkill unblock all, and post the output:
Code: Select all
rfkill list
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Not Enabled

Postby flanna on Sat Sep 24, 2011 7:26 am

AlbertP wrote:We'll need to know what's causing your wireless to turn off every boot.

Please run this command, before running rfkill unblock all, and post the output:
Code: Select all
rfkill list


OK, here it is
Code: Select all
ThinkPad-X121e ~/Desktop $ rfkill list
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
2: tpacpi_bluetooth_sw: Bluetooth
   Soft blocked: no
   Hard blocked: yes
3: tpacpi_wwan_sw: Wireless WAN
   Soft blocked: no
   Hard blocked: yes
4: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
flanna
Level 2
Level 2
 
Posts: 88
Joined: Sun Sep 18, 2011 11:10 am

Re: Wireless Not Enabled

Postby AlbertP on Sat Sep 24, 2011 8:06 am

Can't you turn on your wireless with the on/off switch on the laptop?
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Not Enabled

Postby flanna on Sat Sep 24, 2011 8:08 am

AlbertP wrote:Can't you turn on your wireless with the on/off switch on the laptop?


It's already turned on. I know this because Bluetooth is available as soon as the system starts. The same switch turns on Wifi and Bluetooth.
flanna
Level 2
Level 2
 
Posts: 88
Joined: Sun Sep 18, 2011 11:10 am

Re: Wireless Not Enabled

Postby AlbertP on Sat Sep 24, 2011 8:45 am

Can you turn the switch off, and on again, to get wireless working?
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Not Enabled

Postby flanna on Sat Sep 24, 2011 4:17 pm

AlbertP wrote:Can you turn the switch off, and on again, to get wireless working?


Just tried that. Makes no difference. :(
flanna
Level 2
Level 2
 
Posts: 88
Joined: Sun Sep 18, 2011 11:10 am

Re: Wireless Not Enabled

Postby AlbertP on Sun Sep 25, 2011 4:38 am

Perhaps you can edit the file /etc/rc.local and add: rfkill unblock all (before the line that reads exit 0).
Code: Select all
gksudo gedit /etc/rc.local
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Not Enabled

Postby flanna on Sun Sep 25, 2011 5:24 am

AlbertP wrote:Perhaps you can edit the file /etc/rc.local and add: rfkill unblock all (before the line that reads exit 0).
Code: Select all
gksudo gedit /etc/rc.local


Hmm... It worked.
So easy.
Thanks a lot.
flanna
Level 2
Level 2
 
Posts: 88
Joined: Sun Sep 18, 2011 11:10 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Wireless

Who is online

Users browsing this forum: No registered users and 5 guests