Spell Check does not work in Libre Office - Solved

Questions about applications and software
Forum rules
Before you post please read this

Spell Check does not work in Libre Office - Solved

Postby brenmur777 on Mon Oct 03, 2011 8:12 am

I use Linux Mint with Libre Office 3.3.3

Spell-check does not work. It runs but returns no results.

I did a web search, and I followed instructions to use the menu Tools - Options - Language - Writing Aids - Hunspell SpellChecker and edit the language module.

However, I found that English UK, and English USA are already installed, i.e. they are marked with a checked blue spellcheck icon (abc)

This infuriates me, and I find that it would be quite useless to use a word processor that does not correct spelling.

Any help with this would be greatly appreciated.
Last edited by brenmur777 on Mon Oct 03, 2011 1:49 pm, edited 1 time in total.
brenmur777
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 03, 2011 7:49 am

Linux Mint is funded by ads and donations.
 

Re: Spell Check does not work in Libre Office

Postby remoulder on Mon Oct 03, 2011 8:51 am

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Spell Check does not work in Libre Office

Postby xenopeek on Mon Oct 03, 2011 8:59 am

Open a terminal and do:
Code: Select all
sudo apt-get purge libreoffice-common
mv ~/.libreoffice ~/OLDSETTINGS
sudo-apt-get install libreoffice-common

To brute-force reinstall LibreOffice and settings.

If all works fine, you can then delete the folder OLDSETTINGS in your home folder.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14965
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Spell Check does not work in Libre Office

Postby brenmur777 on Mon Oct 03, 2011 1:46 pm

I posted this problem earlier today, but I have now found a solution.

http://community.linuxmint.com/tutorial/view/615
brenmur777
Level 1
Level 1
 
Posts: 2
Joined: Mon Oct 03, 2011 7:49 am

Re: Spell Check does not work in Libre Office - Solved

Postby jayromeo on Thu Jan 05, 2012 8:22 pm

For me, none of the above worked.

Here is the most elegant solution:

Go to Software Manager and do a search for Hunspell.
Install the one for the right language you want and spellcheck in Libre Office will now work.


cheers,

J
jayromeo
Level 1
Level 1
 
Posts: 2
Joined: Thu Dec 08, 2011 10:07 pm

Re: Spell Check does not work in Libre Office - Solved

Postby rootchick on Tue Feb 14, 2012 11:19 am

I tried installing hunspell and it complained of dependency issues and wanted to uninstall Thunderbird, which I did not want to do. Installing myspell-en-us fixed it for me.

Note: this was on LMDE.
User avatar
rootchick
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 01, 2011 12:55 pm

Re: Spell Check does not work in Libre Office

Postby c-m on Thu Jul 12, 2012 7:04 am

Vincent Vermeulen wrote:Open a terminal and do:
Code: Select all
sudo apt-get purge libreoffice-common
mv ~/.libreoffice ~/OLDSETTINGS
sudo-apt-get install libreoffice-common

To brute-force reinstall LibreOffice and settings.

If all works fine, you can then delete the folder OLDSETTINGS in your home folder.


I followed this advice, but now I don't have writer or calc or anything.

In the menu there is a libreoffice icon. It opens a slash screen where I can select which program I want to run. The problem is all the programs (writer etc..) are greyed out.
c-m
Level 3
Level 3
 
Posts: 114
Joined: Mon Aug 24, 2009 2:01 pm

Re: Spell Check does not work in Libre Office - Solved

Postby ogfomk on Wed Jul 18, 2012 5:01 pm

I tried the above suggestions. The solution I found was at the bottom of the Libreoffice UI. My document was coded as having more than one language. I noticed this as I was going through my paragraphs. See if this is the same for you. Some of my documents go all the way back to Star Office, so there is bound to be something new and something old. I used CTRL-"A" to select everything then I mouse clicked over the Language Selection and chose English (USA)... Yours may currently say "None" as mine did. Choose your language. :shock:
ogfomk
Level 1
Level 1
 
Posts: 1
Joined: Wed Jul 18, 2012 4:54 pm

Re: Spell Check does not work in Libre Office

Postby turqoisehex on Tue Feb 12, 2013 6:24 pm

xenopeek wrote:Open a terminal and do:
Code: Select all
sudo apt-get purge libreoffice-common
mv ~/.libreoffice ~/OLDSETTINGS
sudo-apt-get install libreoffice-common

To brute-force reinstall LibreOffice and settings...


Not intending to be rude, but this is probably the worse advice I've seen an admin give. After doing this you will need to manually select and re-install all of your libreoffice programs, which is a huge pain and time consumer.
turqoisehex
Level 1
Level 1
 
Posts: 45
Joined: Tue Aug 03, 2010 9:33 pm

Re: Spell Check does not work in Libre Office - Solved

Postby mcheng on Tue Feb 26, 2013 9:48 pm

if all fail, probably you need to add a extensions. go to( http://extensions.libreoffice.org/exten ... Dictionary ) and pick your version and click on American British Canadian - spelling/hyphen/thesaurus dictionaries then download it.
add to your extensions.

i hope this work for you all. :D
mcheng
Level 1
Level 1
 
Posts: 1
Joined: Tue Feb 26, 2013 9:31 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 13 guests