Connecting LMDE to WHS shares

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Connecting LMDE to WHS shares

Postby pierrotlunairehh on Fri Oct 28, 2011 10:05 am

Hi, Folks!
After spending hours on searching for hints and help on the web I finally ask for your advice.

I am required to use Windows Home Server (as shipped with my Acer Easystore) to operate a homeserver/NAS in a microsoft-dominated household. While that might be my first fail (xD), here is my problem:
LMDE, which I'm currently using as my main OS, AND Mint_classic both fail to connect or show the shared directories via the network-browser / nautilus in gnome.
The server can be addressed using Firefox, ping and rdesktop, but still giving me no chance to mount the location.

Network-browser does recognise and list the domain created/used by the server but fails to access/mount, supplying the following error-message: "Einhängen des Ortes nicht möglich - Empfangen der Speicherliste vom Server ist gescheitert",
which would roughly translate as: "Unable to mount location - failed to receive volume-/memorylist from server."

Samba-packages and services are installed and running, the server can be properly addressed from any win7-machine.

Thanks for aiding my nooby self xD

chris
System: Kernel 2.6.39-2-amd64 x86_64 - LMDE;
Quad core Intel Core2 Quad Q6600;
nVidia G92 [GeForce 9800 GTX] X.Org 1.10.2.902;
GLX Renderer Software Rasterizer GLX Version 2.1 Mesa 7.10.3 Direct Rendering Yes
pierrotlunairehh
Level 1
Level 1
 
Posts: 3
Joined: Mon Oct 17, 2011 6:08 pm
Location: Hamburg, GER

Linux Mint is funded by ads and donations.
 

Re: Connecting LMDE to WHS shares

Postby sanderd on Fri Nov 04, 2011 6:13 pm

hi Chris,

I experience the same problem: my XP PC shows up in nautilus in WORKGROUP but no shares ;(

just so you know you're not alone ;)

hg.
Sander
sanderd
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 15, 2010 6:06 pm

Re: Connecting LMDE to WHS shares

Postby lebigouden on Sat Nov 05, 2011 5:32 am

Hi guys,

First, you need to have smbfs installed. If you don't do this:

aptitude update
aptitude install smbfs

To mount windows share drive you need to create a folder:

mkdir somefolder

As root or with root privileges (su root or sudo)
mount -t smbfs -o username=administrator,password=password //windowsservername/folder /home/lucas/somefolder

If you don't want the password to show up you could do
mount -t smbfs -o username=administrator //windowsservername/folder /home/lucas/somefolder
[Optional] You can replace administrator with your username. You can also replace windowsservername with ip address //192.168.1.10/folder ....


HowTo found on the debian wiki, here: http://wiki.debian.org/Manual-Howto#Mount_Windows_Share
lebigouden
Level 1
Level 1
 
Posts: 12
Joined: Mon Oct 31, 2011 6:18 am

Re: Connecting LMDE to WHS shares

Postby pierrotlunairehh on Wed Jan 11, 2012 6:56 am

Folks, I did it! xD

took me ages, nothing worked... but maybe you have to google the same bloody thing a dozen times to see the light...

http://ubuntuforums.org/showthread.php?t=1169149
i was up and running after step two!

good luck and thx for your aid!

chris
System: Kernel 2.6.39-2-amd64 x86_64 - LMDE;
Quad core Intel Core2 Quad Q6600;
nVidia G92 [GeForce 9800 GTX] X.Org 1.10.2.902;
GLX Renderer Software Rasterizer GLX Version 2.1 Mesa 7.10.3 Direct Rendering Yes
pierrotlunairehh
Level 1
Level 1
 
Posts: 3
Joined: Mon Oct 17, 2011 6:08 pm
Location: Hamburg, GER


Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 4 guests