Autohide Top Panel

Forum rules
Before you post please read this

Autohide Top Panel

Postby Oscar799 on Sat Nov 12, 2011 1:25 pm

Instructions and PPA details here for the gnome shell extension
http://www.webupd8.org/2011/11/autohide ... nally.html
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8813
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Linux Mint is funded by ads and donations.
 

Re: Autohide Top Panel

Postby blueXrider on Sat Nov 12, 2011 1:59 pm

In Lisa 12 RC

If you do this:

sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get update
sudo apt-get install gnome-shell-extensions-autohidetopbar

It won't work without changing the default distribution from "lisa" to "oneiric"
User avatar
blueXrider
Level 2
Level 2
 
Posts: 74
Joined: Thu Jun 30, 2011 11:49 am

Re: Autohide Top Panel

Postby esteban1uy on Sat Nov 12, 2011 4:22 pm

The repository way didn't work for me.
But the direct download and manual installation worked like a charm.
You can download the package from that page (http://www.webupd8.org/2011/11/autohide-top-bar-extension-finally.html), decompress it, then move the folder to /usr/share/gnome-shell/extensions, (use sudo nautilus to get the permissions or log in as root).
Log off, then log in, then go to Gnome Tweak Tool to enable "Autohidetopbar"... and the thing starts working.

I love that extension, it's not the perfect solution but it does exactly what I was looking for.
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Autohide Top Panel

Postby KBD47 on Sat Nov 19, 2011 10:52 pm

blueXrider wrote:In Lisa 12 RC

If you do this:

sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get update
sudo apt-get install gnome-shell-extensions-autohidetopbar

It won't work without changing the default distribution from "lisa" to "oneiric"


Just wanted to note this works well. I think perhaps having this added to the final release as an easy option for those wanting just the bottom panel visible would be a good idea IMO.
KBD47
KBD47
Level 6
Level 6
 
Posts: 1022
Joined: Fri Jul 29, 2011 12:03 am

Re: Autohide Top Panel

Postby chdslv on Mon Nov 21, 2011 9:04 am

Well, I tried this, but it won't work. There is no Autohide top panel in the Gnome Tweak.
chdslv
Level 2
Level 2
 
Posts: 76
Joined: Wed Dec 30, 2009 3:49 am

Re: Autohide Top Panel

Postby farimir on Thu Nov 24, 2011 4:40 am

chdslv wrote:Well, I tried this, but it won't work. There is no Autohide top panel in the Gnome Tweak.


For some reason this happened to me as well. If I start Gnome Tweak from the menu though, I do see Auto Hide Top Panel option (weird :D ). So go to Menu | All Applications | Advanced Settings (this should open Gnome Tweak Tool from the menu) and then go to Shell Extensions and you should find it there.

Hope this helps.
farimir
Level 1
Level 1
 
Posts: 11
Joined: Mon May 16, 2011 6:53 am

Re: Autohide Top Panel

Postby JustinGordon on Sat Nov 26, 2011 8:44 am

In gnome classic:

Install and start dconf-editor
Then navigate:
org - gnome - gnome-panel - layout - toplevels - bottom-panel
you'll see the auto-hide checkbox on the right.

then set it for the bottom-panel as well!

Cheers,

Justin
JustinGordon
Level 1
Level 1
 
Posts: 19
Joined: Sat Nov 26, 2011 8:36 am

Re: Autohide Top Panel

Postby phr33k on Wed May 09, 2012 2:06 pm

blueXrider wrote:
sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get update
sudo apt-get install gnome-shell-extensions-autohidetopbar



This worked for me. All I had to do was restart Gnome and the "autohide top panel" switch was available in the shell extensions settings.
phr33k
Level 2
Level 2
 
Posts: 53
Joined: Fri Feb 17, 2012 5:13 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 2 guests