Mint Constructor Fails to Open CHROOT Terminal

Questions about applications and software
Forum rules
Before you post please read this

Mint Constructor Fails to Open CHROOT Terminal

Postby Jeff91 on Sat Nov 27, 2010 3:58 pm

When I click "open a chroot terminal" in Mint constructor a window opens for a brief moment but then closes. The output in terminal is as follows -

Code: Select all
Copying DNS info...
cp: cannot create regular file `/home/bodhi/root/etc/resolv.conf': No such file or directory
Mounting /proc filesystem...
mount: mount point /home/bodhi/root/proc does not exist
Copying wgetrc configuration...
mv: cannot stat `/home/bodhi/root/etc/wgetrc': No such file or directory
cp: cannot create regular file `/home/bodhi/root/etc/wgetrc': No such file or directory
Launching Xterm for advanced customization...
Restoring wgetrc configuration...
mv: cannot stat `/home/bodhi/root/etc/wgetrc.orig': No such file or directory
Removing DNS info...
Umounting /proc...
umount: /home/bodhi/root/proc/: not found


What am I doing wrong/what is going wrong? I am running Mint Constructor as root, however I get the same dump when I run it as a normal user as well.

Cheers,
~Jeff
User avatar
Jeff91
Level 3
Level 3
 
Posts: 156
Joined: Sun Jul 19, 2009 6:37 pm
Location: Blue Island, IL

Linux Mint is funded by ads and donations.
 

Re: Mint Constructor Fails to Open CHROOT Terminal

Postby Tim-int on Tue Nov 29, 2011 2:34 pm

The same problem, here is my log from LMDE:

Code: Select all
INFO: Saving working directory information...
Custom Directory: /root
Create New Project: True
ISO Filename: /media/sf_ISO/linuxmint-12-gnome-dvd-32bit-rc.iso
INFO: Setting up working directory...
Using ISO for remastering...
mount: you must specify the filesystem type
Copying files...
Finished copying files...
umount: /media/cdrom: not mounted
Using ISO for squashfs root...
mount: you must specify the filesystem type
Mounting squashfs...
/media/cdrom/casper/filesystem.squashfs: No such file or directory
Extracting squashfs root...
Unmounting tmpsquash...
umount2: Invalid argument
umount: /root/tmpsquash: not mounted
Unmounting cdrom...
umount2: Invalid argument
umount: /media/cdrom: not mounted
Removing tmpsquash...
Setting proper permissions...
chmod: cannot access `/root/root/usr/bin/sudo': No such file or directory
chmod: cannot access `/root/root/etc/sudoers': No such file or directory
Finished extracting squashfs root...
Playing WAVE '/usr/lib/linuxmint/mintConstructor/done.wav' : Signed 16 bit Little Endian, Rate 22050 Hz, Mono
Finished setting up working directory...
 
Copying DNS info...
cp: cannot create regular file `/root/root/etc/resolv.conf': No such file or directory
Mounting /proc filesystem...
mount: mount point /root/root/proc does not exist
Copying wgetrc configuration...
mv: cannot stat `/root/root/etc/wgetrc': No such file or directory
cp: cannot create regular file `/root/root/etc/wgetrc': No such file or directory
Launching Xterm for advanced customization...
Warning: Tried to connect to session manager, None of the authentication protocols specified are supported
Restoring wgetrc configuration...
mv: cannot stat `/root/root/etc/wgetrc.orig': No such file or directory
Removing DNS info...
Umounting /proc...
umount: /root/root/proc/: not found
Tim-int
Level 1
Level 1
 
Posts: 38
Joined: Tue Nov 29, 2011 2:30 pm

Re: Mint Constructor Fails to Open CHROOT Terminal

Postby Tim-int on Thu Dec 08, 2011 5:12 pm

Well, Mint Constructor managed to open CHROOT terminal. But, after I updated packages, and it created ISO, I cannot find it. It is supposed to be in /root. Any help? It happens in LMDE.
Tim-int
Level 1
Level 1
 
Posts: 38
Joined: Tue Nov 29, 2011 2:30 pm

Re: Mint Constructor Fails to Open CHROOT Terminal

Postby Tim-int on Thu Jan 05, 2012 7:53 am

Tim-int wrote:Well, Mint Constructor managed to open CHROOT terminal. But, after I updated packages, and it created ISO, I cannot find it. It is supposed to be in /root. Any help? It happens in LMDE.


Any help, please? I can see only "iso_name" file in "/root" folder. Contents of the file is "Linux Mint <VERSION> <EDITION> <XX>-bit". There is no ISO.
MintConstructor version is 3.0.4 on Linux Mint Debian Edition.
Tim-int
Level 1
Level 1
 
Posts: 38
Joined: Tue Nov 29, 2011 2:30 pm

Re: Mint Constructor Fails to Open CHROOT Terminal

Postby fcasco on Fri Nov 30, 2012 11:24 pm

I'm having the same issue here, any help to fix it?

After creating a new project from this iso "linuxmint-14-cinnamon-dvd-32bit.iso", when I click the button to open a chroot terminal the terminal opens and closes inmediatly. In the console I get this:


Code: Select all
Setting up the GUI...
/usr/lib/linuxmint/mintConstructor/mintConstructor.py:77: GtkWarning: IA__gtk_radio_button_set_group: assertion `!g_slist_find (group, radio_button)' failed
  self.wTree = gtk.glade.XML(self.gladefile, domain='reconstructor')


INFO: Saving working directory information...
Custom Directory: /media/audio/000otros/mint14cd
Create New Project: False
ISO Filename:
Copying DNS info...
cp: cannot create regular file `/media/audio/000otros/mint14cd/root/etc/resolv.conf': No such file or directory
Mounting /proc filesystem...
mount: mount point /media/audio/000otros/mint14cd/root/proc does not exist
Copying wgetrc configuration...
mv: cannot stat `/media/audio/000otros/mint14cd/root/etc/wgetrc': No such file or directory
cp: cannot create regular file `/media/audio/000otros/mint14cd/root/etc/wgetrc': No such file or directory
Launching Xterm for advanced customization...
Restoring wgetrc configuration...
mv: cannot stat `/media/audio/000otros/mint14cd/root/etc/wgetrc.orig': No such file or directory
Removing DNS info...
Umounting /proc...
umount: /media/audio/000otros/mint14cd/root/proc/: not found


I'm running the Mint Constructor from and old version of Mint, 10 I think.
fcasco
Level 1
Level 1
 
Posts: 2
Joined: Sat Dec 18, 2010 9:40 am


Return to Software & Applications

Who is online

Users browsing this forum: Monsta, nomko, rotanibod and 17 guests