[Solved] LM12: No startup sound

Forum rules
Before you post please read how to get help

[Solved] LM12: No startup sound

Postby MC Beathoven on Wed Dec 07, 2011 5:28 pm

I installed Linux Mint 12 using a separate home-partiton that was formerly used with Ubuntu 10.10. When my Linux Mint 12 is finishing booting and showing the desktop (GNOME-Shell) I'm missing the startup sound. I guess it should be the file /usr/share/sounds/linuxmint-login.wav.

The dialog for the "startup applications" shows an entry "GNOME Login Sound" that has the command /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login". The command doesn't work in the terminal (says: "Failed to play sound: File or data not found"). I'm pretty sure, that this entry is useless because ist was "migrated" from the former Ubuntu 10.10. Maybe I disabled the startup-sound in my former Ubuntu-installation and this has an effect on mit current LM-installation.

Can someone tell me, where I can find the function to enable the startup sound? (Maybe Dconf-editor?).

Btw: The sound is absolutely OK on my computer. I can play mp3-files without any problem.

Edit: I forgot to mention, that a workarount would be: New Entry in the Startup Applications with the command
Code: Select all
aplay /usr/share/sounds/linuxmint-login.wav

But I'm seraching for the default-configuration
Last edited by MC Beathoven on Thu Dec 08, 2011 6:54 pm, edited 1 time in total.
MC Beathoven
Level 1
Level 1
 
Posts: 16
Joined: Mon Nov 28, 2011 2:57 pm

Linux Mint is funded by ads and donations.
 

Re: LM12: No startup sound

Postby lurkatron on Wed Dec 07, 2011 6:23 pm

the command looks correct, and it stopped working here too after i went to sound settings and changed alert sound. changing it back to default didnt help either

thansk for the workaround btw
lurkatron
Level 3
Level 3
 
Posts: 101
Joined: Tue Nov 01, 2011 2:18 pm

Re: LM12: No startup sound

Postby karashata on Wed Dec 07, 2011 6:56 pm

There seems to be a bug in the canberra packages that results in them not reading files from the sub-directories in /usr/share/sounds.

One work-around is to move the sounds from /usr/share/sounds/LinuxMint/stereo into /usr/share/sounds.

Another solution is to downgrade the canberra packages to the versions supplied for Natty, or to upgrade them to the versions supplied by Debian.

The packages in question are:

libcanberra-gtk-module
libcanberra-gtk0
libcanberra-gtk3-0
libcanberra-gtk3-module
libcanberra0
gnome-session-canberra

Ubuntu Natty packages: http://packages.ubuntu.com/search?keywords=canberra&searchon=names&suite=natty&section=all
Debian packages: http://packages.debian.org/search?keywords=canberra&searchon=names&suite=all&section=all&sourceid=mozilla-search (Grab the testing packages)

(I'm not sure exactly which package(s) actually need replacing but I feel it's safest to keep them all at the same versions anyway, so it's best to just replace them all. The Debian packages work without a problem in Ubuntu-based distros, but if you feel uncomfortable mixing Debian and Ubuntu packages, you may wish to use the older Natty packages instead.)
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LM12: No startup sound

Postby MC Beathoven on Wed Dec 07, 2011 7:37 pm

@ karashata: Thanks for your detailled reply!!

1) I moved the soundfiles from /usr/share/sounds/LinuxMint/stereo into /usr/share/sounds > Didn't work.

2) To downgrade the canberra packages to the versions supplied for Natty is a bit too tricky to me ;-) .... I will wait for bugfixes.

3) I'm irritated by the fact, that booting with a Linux Mint 12 Live-USB-Stick works fine (startupsound is playing). There seems no bug in the canberra packages when using a Live-USB-Stick.

4) Another strange thing I saw: Using Dconf-editor I can see that in org.gnome.desktop.sound the theme-name was originally "LinuxMint". When I start System Settings (I don't know the correct english word for this dialog) > Audio > change alert sound > the theme-name in org.gnome.desktop.sound changes from "LinuxMint" to "freedesktop". I have to enter the original theme-name to "LinuxMint" manually. I don't know if this fact has any reference to my original problem (no startsound) .... but I'm very much confused .....
MC Beathoven
Level 1
Level 1
 
Posts: 16
Joined: Mon Nov 28, 2011 2:57 pm

Re: LM12: No startup sound

Postby karashata on Wed Dec 07, 2011 7:48 pm

I wish I knew... All I know for sure is there's a bug in one of the packages and replacing them with older or newer packages seems to solve the problem definitively. Some people have had the problem solved simply by relocating the sound files to the sounds folder from the subfolder for the theme they wished to use. I tried this and it didn't work for me either the first time I encountered this problem, so I forced the packages to upgrade to the Debian versions. (I've had the Debian sources on my Mint 12 install for a while for other packages, so it seemed the easiest thing for me to do...) Since then I've had working login and other system sounds.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LM12: No startup sound

Postby MC Beathoven on Thu Dec 08, 2011 10:02 am

@ lurkatron: Try this (I tested with a Live-USB-Stick and it worked for your problem):

install dconf-editor:
Code: Select all
sudo apt-get install dconf-tools

Start the dconf-editor and go to org > gnome > desktop > sound > I guess the theme-name is "freedesktop"? If yes, then change the theme-name to LinuxMint. That might solve your problem.

BUT! Don't change the alert-sound in sound settings. Because this would once again change the theme-name to "freedesktop" and you had to change the theme-name manually to LinuxMint.

Let me know, if this helped you! Good luck!! (this How-To unfortunately didn't solve my problem ...)
Last edited by MC Beathoven on Thu Dec 08, 2011 10:36 am, edited 1 time in total.
MC Beathoven
Level 1
Level 1
 
Posts: 16
Joined: Mon Nov 28, 2011 2:57 pm

Re: LM12: No startup sound

Postby MC Beathoven on Thu Dec 08, 2011 10:20 am

@karashata:
It really seems as you said: "There seems to be a bug in the canberra packages that results in them not reading files from the sub-directories in /usr/share/sounds".

When I change the command of the startup-entry "GNOME Login Sound" from the original
Code: Select all
/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

to
Code: Select all
/usr/bin/canberra-gtk-play --id="linuxmint-login" --description="GNOME Login"

then the startup-sound works !!

I guess the reason is, that canberra now plays the file /usr/share/sounds/linuxmint-login.wav instead of the one in the sundirectory /usr/share/sounds/LinuxMint/stereo/desktop-login.ogg.

Although I'm still confused, because booting LM 12 by means of a Live-USB-Stick, there is no entry like "GNOME Login Sound" in the startup applications. The default LM 12 must use a different configuration to play the startup-sound than the one in the startup applications (I'm also missing the sound when I shut-down).
MC Beathoven
Level 1
Level 1
 
Posts: 16
Joined: Mon Nov 28, 2011 2:57 pm

Re: LM12: No startup sound

Postby karashata on Thu Dec 08, 2011 2:59 pm

I've never had a log off/shutdown sound since I've been using Linux Mint, I'm not sure why that is but I don't really mind anyway.

Changing the id as you did would change the file that canberra is looking for, and I believe that particular file is located in the /usr/share/sounds folder anyway so canberra would be able to find it since it doesn't have to look in the sub-directories.

I'm not sure what would be different about the LiveCD config that would allow it to work while an installed system would not, you'd have to talk to someone responsible for building the LiveCD images...

In any case, I'm glad you found a fix that worked for you.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image
User avatar
karashata
Level 4
Level 4
 
Posts: 441
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada

Re: LM12: No startup sound

Postby MC Beathoven on Thu Dec 08, 2011 6:50 pm

I found another way to solve the problem "No startup-sound" in the Thread: http://forums.linuxmint.com/viewtopic.php?p=462768#p462768

Because this thread here might be a bit confusing for someone who faces the same issue, let me summarize the 3 ways of a solution I found so far:

1. Solution: Workaround: Create a new entry in the Startup Applications with the command
Code: Select all
aplay /usr/share/sounds/linuxmint-login.wav


2. Solution: Change the command of the startup-entry "GNOME Login Sound" to
Code: Select all
/usr/bin/canberra-gtk-play --id="linuxmint-login" --description="GNOME Login"


3. Solution: Open a terminal and type in:
Code: Select all
gedit ~/.config/autostart/libcanberra-login-sound.desktop
Then remove the following line: AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
and set X-GNOME-Autostart-enabled=true

Good luck!!

Btw: Even the LM12 LiveCD doesn't play a sound at login-screen and at shutdown/logoff. So the startup-sound is maybe the only sound-goodie, that LM12 provides ;-)
MC Beathoven
Level 1
Level 1
 
Posts: 16
Joined: Mon Nov 28, 2011 2:57 pm

Re: LM12: No startup sound

Postby Majkl on Wed Dec 28, 2011 1:56 pm

Hey, MC,

just a quick question: I am having a like issue with Mint 11 - lost the logout sound looong ago (if indeed I have ever had it working but I recall having it once) and lost both the welcome beep (when user login pops in) and the login sound (when I get to my Desktop) today, out of a sudden.

I tried to change the command of the startup-entry "GNOME Login Sound" to
Code: Select all
/usr/bin/canberra-gtk-play --id="linuxmint-login" --description="GNOME Login"
with no success

so eventually created a new startup entry
Code: Select all
aplay /usr/share/sounds/linuxmint-login.wav
... which brought my login jingle back (thanks for that!).

Now, being concerned of all the cool Mint sounds, I tried to check the Canberra thing but the command
Code: Select all
sudo gedit ~/.config/autostart/libcanberra-login-sound.desktop
only gave me an empty file. Is the latter solution only related to Mint 12, or does it suggest there is something wrong with my libcanberra-login-sound.desktop file, please?

Would you please point me the direction I should be looking?

Thanks in advance!
--
Quidquid latine dictum sit, altum videtur
Majkl
Level 1
Level 1
 
Posts: 21
Joined: Wed May 21, 2008 9:07 pm
Location: Prague

Re: [Solved] LM12: No startup sound

Postby MC Beathoven on Wed Jan 04, 2012 2:16 pm

@ Majkl:

I'm really no expert to this case ... I'm some kind of try and error ;-)

1) The deafult content of my ~/.config/autostart/libcanberra-login-sound.desktop was:
Code: Select all
[Desktop Entry]
Type=Application
Name=GNOME Login Sound
Comment=Plays a sound whenever you log in
Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
OnlyShowIn=GNOME;
AutostartCondition=GSettings org.gnome.desktop.sound event-sounds
X-GNOME-Autostart-Phase=Application
X-GNOME-Provides=login-sound
X-GNOME-Autostart-enabled=true

I guess to remove the line AutostartCondition=GSettings org.gnome.desktop.sound event-sounds is specific for LM12, because GNOME 3 also uses dconf, not only gconf. So for LM11 keep the line.

2) Try another way:
- Open gconf-editor
- go to desktop > gnome > sound
- check if the theme_name is LinuxMint
MC Beathoven
Level 1
Level 1
 
Posts: 16
Joined: Mon Nov 28, 2011 2:57 pm

Re: LM12: No startup sound

Postby msx_ on Wed Jan 18, 2012 12:24 pm

MC Beathoven wrote:@ lurkatron: Try this (I tested with a Live-USB-Stick and it worked for your problem):

install dconf-editor:
Code: Select all
sudo apt-get install dconf-tools

Start the dconf-editor and go to org > gnome > desktop > sound > I guess the theme-name is "freedesktop"? If yes, then change the theme-name to LinuxMint. That might solve your problem.

BUT! Don't change the alert-sound in sound settings. Because this would once again change the theme-name to "freedesktop" and you had to change the theme-name manually to LinuxMint.

Let me know, if this helped you! Good luck!! (this How-To unfortunately didn't solve my problem ...)


Make my day, +1
User avatar
msx_
Level 1
Level 1
 
Posts: 29
Joined: Fri Dec 23, 2011 4:57 pm

Re: [Solved] LM12: No startup sound

Postby northcamel on Wed Jan 16, 2013 7:06 am

northcamel
Level 1
Level 1
 
Posts: 15
Joined: Wed Dec 05, 2012 10:51 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: tenfoot and 2 guests