How To Install EasyStroke ?

Questions about applications and software
Forum rules
Before you post please read this

How To Install EasyStroke ?

Postby rick99 on Tue Dec 27, 2011 11:34 am

Hi,

I am long time window users..i recently switch over Linux Mint, an I a so in love with it. I downloade a program EasyStroke equavalent to Strokeit for window..but i have no idea how to install it..Hope some one can help me out..

Software Link:
http://sourceforge.net/apps/trac/easystroke/wiki

Steps i did:
- run on on terminal ( ref http://sourceforge.net/apps/trac/easyst ... structions)
sudo apt-get install g++ libboost-serialization-dev libgtkmm-2.4-dev libxtst-dev libdbus-glib-1-dev intltool xserver-xorg-dev


- download easystroke-0.5.5.1.tar.gz and extract into easystroke-0.5.5.1 folder


Please tell me what to do next..Thanks
rick99
Level 1
Level 1
 
Posts: 3
Joined: Tue Dec 27, 2011 11:28 am

Linux Mint is funded by ads and donations.
 

Re: How To Install EasyStroke ?

Postby Aging Technogeek on Tue Dec 27, 2011 12:10 pm

Rather than downloading the source code and compiling it , go to this site https://launchpad.net/~easystroke/+archive/ppa and download the proper Ubuntu PPA that corresponds to your version of Mint (complete, easy to follow instructions on how to download and install the PPA are available by clicking the blue link "Read About Installing").

Once the PPA is installed, open Software Manager and enter "Easystroke" in the search box. Click on the Easystroke entry in the search results (it should be the only entry), and when the Easystroke information box opens click "Install". From there on it's all automatic.

Ubuntu equivalents for Mint versions.

Mint 12 - Ubuntu 11.10 (Oneiric Ocelot)
Mint 11 - Ubuntu 11.04 (Natty Narwhal)
Mint 10 - Ubuntu 10.10 (Maverick Meerkat)
Mint 9 - Ubuntu 10.04 (Lucid Lynx)
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: How To Install EasyStroke ?

Postby rick99 on Tue Dec 27, 2011 5:00 pm

Hi,

i am running LMDE (Linux Mint Debian) lastest version, what easystroke version should i download
rick99
Level 1
Level 1
 
Posts: 3
Joined: Tue Dec 27, 2011 11:28 am

Re: How To Install EasyStroke ?

Postby rick99 on Tue Dec 27, 2011 5:18 pm

btw, i followed the instruction, i received this error.. am i missing something . I got libboost-serialization installed but it's not 1.40.0

Code: Select all
sudo apt-get install easystroke
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 easystroke : Depends: libboost-serialization1.40.0 (>= 1.40.0-1) but it is not installable
E: Broken packages
rick99
Level 1
Level 1
 
Posts: 3
Joined: Tue Dec 27, 2011 11:28 am

Re: How To Install EasyStroke ?

Postby Aging Technogeek on Wed Dec 28, 2011 9:06 am

If I had known you were running LMDE, I would not have steered you to Launchpad. LMDE does not handle most PPAs well since they are basically written for Ubuntu.

Try this instead. http://sourceforge.net/projects/easystroke/files/. Click on the link for the latest version (easystroke - 0.5.4-lucid-i386.deb) to download the package to your desktop or download folder. When the download is complete, right click on the package and open with Gdebi Package Installer. The installer will check for dependencies and install any that are in the repos or let you know about any unsatisfied dependencies and stop the install. If all dependencies are satisfied, the installation will proceed automatically.
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: How To Install EasyStroke ?

Postby geoffm on Sat Nov 24, 2012 4:32 am

So, did you ever get it to work?
I want to give LMDE a try but if I can't run easystroke there's no point in going through all the install process and screwing around with the bootloader.

If your issue is solved, please add [solved] to your post's title.
Custom build w/ Gigabyte Z87MX-D3h | Intel Core i5 4670 | 8GB DD3 | 250GB SSD
geoffm
Level 3
Level 3
 
Posts: 119
Joined: Thu Jul 16, 2009 8:34 am

Re: How To Install EasyStroke ?

Postby amb1402 on Thu Aug 21, 2014 3:24 am

here how i got the deb file for easy stroke :
https://launchpad.net/~easystroke/+arch ... /+packages
amb1402
Level 1
Level 1
 
Posts: 2
Joined: Tue Sep 29, 2009 4:53 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 2 guests