Linux mint 12 and Intel GMA 500 = no GUI

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Linux mint 12 and Intel GMA 500 = no GUI

Postby miez on Mon Nov 28, 2011 7:58 am

Dear fellow Mint users,

Anyone already got Linux mint 12 properly running with the Intel GMA 500 card? Tried it on my netbook, but cannot get the live-session running in Gnome. It ends up in the Terminal when I boot from my usb-stick. When I use the command startx, it says "no screens found". This is the same problem I had with Ubuntu 11.10. Again this seems to be the problem because of that stupid Intel GMA 500 card.

Thx in advance.
Last edited by miez on Tue Nov 29, 2011 2:09 pm, edited 1 time in total.
miez
Level 1
Level 1
 
Posts: 28
Joined: Thu May 27, 2010 2:47 am

Linux Mint is funded by ads and donations.
 

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby remoulder on Mon Nov 28, 2011 9:47 am

Try the suggestion in the 1st post of http://ubuntuforums.org/showthread.php?t=1792777
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby miez on Mon Nov 28, 2011 10:34 am

Thx for the link, :) I'll try it and see if it works.
miez
Level 1
Level 1
 
Posts: 28
Joined: Thu May 27, 2010 2:47 am

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby mcasassa on Mon Nov 28, 2011 2:14 pm

I have an HP slate 500 with the same Intel GMA500 video card, and it didnt boot the live USB into the graphical mode, linux Mint 12 DVD. Saw all those posts about downloading the correct driver.

What I did was to add at the end of the grub kernel line (shows when pressing tab on the grub selection line), before the "--", the configuration option
Code: Select all
vga=0x315
which puts the config VGA 800x600 pixels in the video driver, enough to allow the vesa Xorg driver to boot up correctly. Just hope it's not too late :D
mcasassa
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 28, 2011 2:09 pm

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby mcasassa on Mon Nov 28, 2011 2:17 pm

Oh and, pretty cool, the touchscreen works out of the box :!:
mcasassa
Level 1
Level 1
 
Posts: 4
Joined: Mon Nov 28, 2011 2:09 pm

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby critter42 on Tue Nov 29, 2011 7:32 am

I had to add both the vga=0x315 and the dummy poulsbo environment variables listed in the first post of that other link given above on the "compatibility mode" menu option in order to get Linux Mint 12 to boot on my Dell Mini 1010 (good ol' GMA500 :twisted: )
critter42
Level 1
Level 1
 
Posts: 1
Joined: Tue Nov 29, 2011 7:29 am

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby rkline1963 on Wed Dec 28, 2011 1:01 am

The directions above and in the link to the Ubuntu forums post (http://ubuntuforums.org/showthread.php?t=1792777) worked for getting my Acer Aspire One AO751h working. I was having some of the windows during the install run off the bottom of the screen so I used vga=0x318 to get 1024x768 mode (the AO751h has a 1366x768 resolution screen). The instructions on the ubuntuforums post also got the screen brightness controls to work as well.

So far my linux Mint 12 install experiences have felt like a trip in the way back machine to the late 1990s when hardware support was abysmal unless you checked supported hardware lists for your linux distribution before buying anything. I've had to do 3 do over reinstalls each on the Aspire One and an AMD/ATI graphics laptop (non-working proprietary fglrx driver) to end up with installs that work without fully supported graphics hardware. I've been spoiled in the past few years into expecting linux to work better than windows.
rkline1963
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 28, 2011 12:41 am

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby SThom27 on Mon Jan 02, 2012 3:05 am

I'm installing on a Dell Mini 10 (1010) and the vga=318 isn't an option for me. This may be an issue with all Dell Mini 1010's. You'll just have to deal with the install window running off the bottom of the screen. It's not too difficult to pay attention to button order and just [TAB] over to the where the [NEXT] button should be. There is really only one screen that is a problem on and the rest of the install will go smoothly.
SThom27
Level 1
Level 1
 
Posts: 12
Joined: Sun Jul 03, 2011 1:10 am

Re: Linux mint 12 and Intel GMA 500 = no GUI

Postby Niks on Fri Jan 18, 2013 6:50 am

Got a Asus EEEPC 1202 HA running LMDE 32 which uses a Intel GMA 500

It runs Mate but uses xserver-xorg-video-fbdev 1:0:4.2 which is not very fast at all.

The xserver-xorg-video-intel 2:2.19.0 install ok but if I go to cinnamon I get a blank screen.

Have tried to install "Poulsbo" drivers without success.

Anyone got any great :idea:
User avatar
Niks
Level 3
Level 3
 
Posts: 164
Joined: Thu Feb 11, 2010 6:59 am
Location: Netherlands

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot], kwelch007 and 24 guests