Mint 12 - how verbose/no splash boot?

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help

Mint 12 - how verbose/no splash boot?

Postby tpprynn on Thu Jan 05, 2012 6:36 am

With previous versions of Mint I'd put a hash in one line of /etc/default/grub to get a verbose boot but this doesn't seem to do anything now. I like to see something happening at boot and it seems for a while an animated logo has been absent - a black screen has too often for many of us suggested problems so it seems inadequate. So how can I get the boot gibberish back?

If this isn't normal, this is happening on both a 2gb 3ghz AMD pc with very new Radeon card and a 3gb 1.6ghz Intel 965-based laptop, both 64 bit.

Thanks.
tpprynn
Level 3
Level 3
 
Posts: 150
Joined: Fri May 27, 2011 7:09 pm

Linux Mint is funded by ads and donations.
 

Re: Mint 12 - how verbose/no splash boot?

Postby soccerz619 on Thu Jan 05, 2012 6:48 am

I want to know the answer to this too. SuSe has a cool thing where you can hit escape during the graphical bootloader and go to a verbose one, and I think that is the only thing Mint is missing!
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 234
Joined: Mon Sep 05, 2011 10:05 pm

Re: Mint 12 - how verbose/no splash boot?

Postby remoulder on Thu Jan 05, 2012 8:10 am

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Mint 12 - how verbose/no splash boot?

Postby soccerz619 on Thu Jan 05, 2012 10:17 am

This is my grub in /etc/default/grub. To fix it, I should change the ="quiet splash" to ="verbose" or ="verbose splash" ?
Code: Select all
[# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"]
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 234
Joined: Mon Sep 05, 2011 10:05 pm

Re: Mint 12 - how verbose/no splash boot?

Postby lutterworth on Fri Jan 20, 2012 4:05 am

answer:


GRUB_CMDLINE_LINUX_DEFAULT=""
User avatar
lutterworth
Level 1
Level 1
 
Posts: 24
Joined: Fri Jan 20, 2012 4:02 am
Location: germany

Re: Mint 12 - how verbose/no splash boot?

Postby soccerz619 on Mon Jan 23, 2012 5:49 am

@lutterworth: Should I back it up the default first? And just clearing it and leaving it blank will give me the verbose?
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 234
Joined: Mon Sep 05, 2011 10:05 pm

Re: Mint 12 - how verbose/no splash boot?

Postby tpprynn on Mon Jan 23, 2012 7:56 pm

I've just tried this and it seems fine. Just removing quiet splash and leaving the quotes and then doing sudo update-grub in the terminal and rebooting. It's not quite the full Debian 6 display of gibberish that I like, as it is slightly intermittent with some black screen still, but it will do. It stops the impression being given that the computer has had a stroke.
tpprynn
Level 3
Level 3
 
Posts: 150
Joined: Fri May 27, 2011 7:09 pm

Re: Mint 12 - how verbose/no splash boot?

Postby soccerz619 on Tue Jan 24, 2012 7:23 am

@ tpprynn: "It stops the impression being given that the computer has had a stroke." haha ok. Thanks for the heads up. I had Suse which had a very verbose boot, but maybe this will be better than nothing, like you say!
Everyone is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing it is stupid.
Image
User avatar
soccerz619
Level 4
Level 4
 
Posts: 234
Joined: Mon Sep 05, 2011 10:05 pm

Re: Mint 12 - how verbose/no splash boot?

Postby pixpax on Thu Oct 11, 2012 7:26 pm

Hi Folks,

this is my first post on this forum.

Just to confirm that setting:
GRUB_CMDLINE_LINUX_DEFAULT=""
(removing "quiet splash" between the quotes)

in /etc/default/grub , followed by update-grub did the trick.

A boot blank screen is a bit scary... As soccerz619 said, (open)SUSE had an excellent verbosing just pressing the ESC key during boot...

So far, so good: Mint ROCKS!

Cheers!
pixpax
Level 1
Level 1
 
Posts: 2
Joined: Thu Oct 11, 2012 7:15 pm

Re: Mint 12 - how verbose/no splash boot?

Postby pixpax on Sat Jan 12, 2013 1:18 pm

[SOLVED] Linux Mint - How verbose boot / no splash boot

Just for sharing with everyone a PM i received regarding this issue:

Hi!!

Well, in Mint 11 i don't know, but works fine in Mint 13/MATE.

1. If you just change this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
into
GRUB_CMDLINE_LINUX_DEFAULT=""
in /etc/default/grub
the verbose starts at the fsck section.

2. Please try to uncomment, in the same file, this line:
#GRUB_TERMINAL=console
(to
GRUB_TERMINAL=console
)

3. and finally to sudo update-grub2

This should work fine. You'll be in 640X480 instead of 1024X768 or whatever, but it works fine here.

***
Maybe uncommenting this line:
#GRUB_GFXMODE=640x480 to GRUB_GFXMODE=1024X768 (and recommenting the "console" line)
but haven't tried yet...
***

Remember to sudo update-grub2 after
HTH

Kind regards,
pixpax
pixpax
Level 1
Level 1
 
Posts: 2
Joined: Thu Oct 11, 2012 7:15 pm

Re: Mint 12 - how verbose/no splash boot?

Postby baj on Wed Mar 27, 2013 8:47 pm

Nice! GRUB_TERMINAL=console gives lots-o-boot info. Problem is it flies by so fast, especially with an SSD.
baj
Level 1
Level 1
 
Posts: 30
Joined: Mon Feb 11, 2013 1:36 am

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 3 guests