Weird Xorg problem

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

Weird Xorg problem

Postby TheGreatSudoku on Sat Jan 28, 2012 2:47 am

I've been having issues lately where upon booting up my laptop into LMDE I'll get a movable Xorg mouse pointer, but I'll also get a "_" cursor in the upper left hand corner of my screen (as if it's mixing fb and X). In any event I have to either Alt-PrtSc-K one or more times to kill the X server, eventually after killing X enough times, it takes me to my KDM login screen. Or if I'm really unlucky I have to reboot several times until a working KDM screen comes up. I'm kind of baffled because /var/log/Xorg.0.log doesn't contain any helpful information.. no errors, no warning.. kind of infuriating.. anyone else had this happen to them? any suggestions as to a fix would be appreciated.
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Linux Mint is funded by ads and donations.
 

Re: Weird Xorg problem

Postby richyrich on Sat Jan 28, 2012 9:53 am

Any errors found in the dmesg log ?
User avatar
richyrich
Level 13
Level 13
 
Posts: 4638
Joined: Mon May 04, 2009 8:31 pm

Re: Weird Xorg problem

Postby TheGreatSudoku on Sat Jan 28, 2012 10:06 am

Not sure if this helps or if it's just standard warning messages, but these caught my eye in dmesg

Code: Select all
fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
drm: registered panic notifier
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Re: Weird Xorg problem

Postby TheGreatSudoku on Sun Feb 12, 2012 3:26 pm

This problem is becoming a real pain in the butt to track down and fix.

This page seems to verify my i915 problem is shared by others:
http://wiki.debian.org/KernelModesetting

Unfortunately recompiling the kernel with:
Code: Select all
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_AGP=y
CONFIG_AGP_INTEL=y
CONFIG_DRM=y
CONFIG_DRM_I915=y


(building them in as opposed to being modules as I had them previously) made absolutely no difference.
I still get the static cursor in the upper left of the screen, and have to Alt-SysRq-K one or more times to kill the X-Server until it finally decides to start in a usable state (or until it locks up and I have to hard boot it).

This section of the page explains exactly my problem:
Code: Select all
vbetool
    Running this will cause X to fail to start up (black screen except for a static cursor at the top left, can't switch vt), and may cause other problems. (This is a kernel bug.) To avoid this, set SAVE_VBE_STATE=false in /etc/default/acpi-support.


I noticed I didn't have an /etc/default/acpi-support file.
so I installed the package ACPI-SUPPORT , then added SAVE_VBE_STATE=false to /etc/defualt/acpi-support and rebooted.

BIG MISTAKE! I booted into a never-ending blank black screen, and ended up having to boot into recovery mode where I immediately apt-get --pure remove acpi-support.

Rebooted and X started with no problems, but that would happen on occasion with the modular kernels too. Next time I get that annoying cursor in the upper left of my screen, the only things I can think to do are:

1. Add SAVE_VBE_STATE=false to /etc/defualt/acpid (unless someone can tell me this is a BAD idea. Just guessing but is acpi-support now depreciated in favor of acpid?)

2. Disable KMS by setting i915 modeset=0 in /etc/modprobe.d/i915-kms.conf

3. Really grasping at straws here, but removing vbetool? (as the wiki said running vbetool causes X to lock up)

Other than that I'm fresh out of ideas. Anyone else familiar with this kind of thing that can assist me?
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am

Re: Weird Xorg problem

Postby TheGreatSudoku on Sun Feb 12, 2012 4:44 pm

I disabled KMS but the results were horrible!
My max resolution went from my usual 1440x900 to 1024x786. Also compiz no longer worked. Disabling KMS therefore is not an acceptable solution.

After re-enabling KMS, I tried adding SAVE_VBE_STATE=false to /etc/default/acpid
I rebooted, and I still get the annoying cursor.
[edit]: disabling VBE state in /etc/default/acpid makes it so my laptop no longer goes to sleep when I close the lid. :( so this option is out, not that it "worked" anyway, but I ended up removing it from acpid, and rebooting to restore normal lid closing behavior.

Not sure what els to try at this point :(
↯Acer Aspire 7730 17" laptop ↝ Intel Core Duo 2.00Ghz x2  4gig DDR2 RAM ⤗ Intel Mobile 4 Graphics ➫ Kernel: 3.2.0-14-liquorix ZEN SMP PREEMPT x86_64  Linux Mint Debian Edition using Sid Repositories ⇨ KDE 4.7.4 ⟿ Installed: 11/23/2010↯
User avatar
TheGreatSudoku
Level 3
Level 3
 
Posts: 149
Joined: Tue Dec 07, 2010 12:05 am


Return to Other Topics

Who is online

Users browsing this forum: No registered users and 2 guests