Shared desktop (vino) not working.

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Shared desktop (vino) not working.

Postby robfish on Wed Nov 09, 2011 11:58 pm

My shared desktop (vino) was working before I updated and now with kernel 3.0 it does not work any more. (LMDE)

The same problem happens with Ubuntu 11.10 but the fix described in post #14 at this page does not work with LMDE.

https://answers.launchpad.net/ubuntu/+question/174568

Any help is welcome.

This is now also a problem with Linux Mint 12 (LM11 works fine on the same VM host).
robfish
Level 1
Level 1
 
Posts: 14
Joined: Tue Jun 29, 2010 1:10 am

Linux Mint is funded by ads and donations.
 

Re: Shared desktop (vino) not working.

Postby gyorik on Tue Dec 20, 2011 3:25 am

The problem is that after you set up the shared desktop(vino-preferences) the vino-server does not start automatically. You can start it manually: open a terminal-> type /usr/lib/vino-server & (don't close this terminal because if you close then it will kill the process of the vino-server)
I think the developers will fix this bug later.
gyorik
Level 1
Level 1
 
Posts: 1
Joined: Tue Dec 20, 2011 3:17 am

Re: Shared desktop (vino) not working.

Postby robfish on Mon Jan 30, 2012 9:13 pm

Thanks gyorik but that fix does not work for me.

I think this bug https://bugs.launchpad.net/ubuntu/+sour ... mments=all
may be the problem but the new version is not in the repos yet.

There are lots of people using either Ubuntu 11.10 or LM12 with the same problem and no fix yet - it is very frustrating.
robfish
Level 1
Level 1
 
Posts: 14
Joined: Tue Jun 29, 2010 1:10 am

Re: Shared desktop (vino) not working.

Postby robfish on Mon Feb 06, 2012 4:54 pm

At last - the fix is now in the repos.
I updated, rebooted and all is well again.
robfish
Level 1
Level 1
 
Posts: 14
Joined: Tue Jun 29, 2010 1:10 am

Re: Shared desktop (vino) not working.

Postby bdantas on Sat Feb 11, 2012 12:02 am

Using LMDE with MATE here.
Was having trouble accessing my machine remotely but finally figured it out:

1. sudo apt-get update
2. sudo apt-get install vino
3. sudo vino-preferences (configure to taste. Note: Running vino-preferences without sudo--as normal user--didn't seem to work)
4. Go to your "Startup Applications" and create a new item. Call it anything you want (e.g., "Vino server"). This is the command you want: /usr/lib/vino/vino-server --sm-disable
5. Make sure your router is forwarding port 5900 to your host computer's (computer you want to connect to) local IP address*

Now you should be able to connect to your computer remotely. If you are using Linux at the remote site, use vinagre (Applications > Internet > Remote Desktop Viewer) to connect. The settings you want are the following: protocol=VNC, host=your host computer's PUBLIC IP address**. If you setup a password in step 3, you will be asked to enter it after you press "Connect."

Works perfectly for me.

* IP address listed when you right-click your connection icon and choose "connection information"
** IP address listed when you google "what is my ip"
bdantas
Level 2
Level 2
 
Posts: 56
Joined: Tue Jan 03, 2012 8:42 pm

Re: Shared desktop (vino) not working.

Postby Landie_UK on Sun Jun 17, 2012 1:59 am

Still doesn't work for me, I did all the above including setting the vino preferences both as a user and as a superuser. When i connect I get a black screen, the desktop appears when I move the mouse, as soon as I move the mouse again the connection is closed. This happens with mate, cinnamon and the gnome desktops. This happens using vinigre and remmina, I also have ubuntu 12.04 installed, remote desktop works sort of, i can connect and use it but as soon as I closed a window I have to mouse over everything to clear the window from the desktop.
Linux User# 479698

AMD Athlon XP2200+// ECS/SiS M/Board// ATI Radeon9550// Ubuntu12.04/LinuxMint 13
Netbook Gateway LT3110h AMD Athlon 64// ATI Radeon// Ubuntu 12.04
Landie_UK
Level 1
Level 1
 
Posts: 7
Joined: Tue Dec 15, 2009 1:10 am

Solution for Linux Mint 15

Postby QuaziLinuxMaster on Wed Dec 11, 2013 4:00 pm

I got this all to work on my MintBox2 by doing the following. I can now run the MintBox 2 entirely headless with: ssh + vino + Tight VNC.

Type into putty via ssh connection to the LinuxMint MintBox2 machine:

Code: Select all
sudo su
[enter your root password]
echo $DISPLAY
export DISPLAY=:0.0
startx &   }This loads up LinuxMint on screen as "root" user
[press the return key again to get back to BASH prompt]

Now, if you like (this isn't necessary) on a LinuxMint terminal (i.e. not on putty) type:

Code: Select all
echo $DISPLAY

=> You get an output of :1 [i.e. this caused me a lot of trouble to figure out i.e this is not 0:0 !!!!!!!!!!]

Now, go back to putty and type:

Code: Select all
echo $DISPLAY
export DISPLAY=:1
/usr/lib/vino/vino-server


=> It now loads & you can use window 7 Tight VNC Viewer to access Linux Mint etc or AndroidVNC (free VNC app for Android phones) :D

I hope this helps some one out there...
QuaziLinuxMaster
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 11, 2013 3:52 pm

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 0 guests