Printing not using default settings

Forum rules
Before you post please read this

Printing not using default settings

Postby sdd on Mon Jan 23, 2012 4:37 pm

I am using KDE on linux mint 12 (not the KDE RC). It is the 64bit version.

The printer defaults are set for text on plain paper - this is what it shows in CUPS and in KDE System Settings.

Everytime I print from a program (Firefox, Thunderbird, Libreoffice) it wants to print in Best Photo quality on Photo paper, unless I change the settings. If I do change them, it does not remember the change for the next print run, whether I restart the program or not.

How do I get the programs to use the default settings automatically?

Stephen.
sdd
Level 1
Level 1
 
Posts: 13
Joined: Thu Sep 22, 2011 3:14 am

Linux Mint is funded by ads and donations.
 

Re: Printing not using default settings

Postby sdd on Fri Jan 27, 2012 6:32 pm

UPDATE

If I change the printer settingsd in Okular, they will stick when I go to Libreoffice or Firefox, but if I change the settings in Libreoffice, they do not stick at all (though they work for that print run).

Nevertheless, none of the programs are picking up the defaults from CUPS.
sdd
Level 1
Level 1
 
Posts: 13
Joined: Thu Sep 22, 2011 3:14 am

Re: Printing not using default settings

Postby fabio on Wed Mar 07, 2012 3:27 am

I have a similar problem with a Kyocera FS-1020D in Mint 9 LTS Isadora. Sometime in the past (don't remember from what program) I set the printer to duplex printing and now I get it as standard option all the time when I print (unless I change it expressly for every printing job in the "page setup" options), although in Control center > Printing > KyoceraLaser > Printer Options I read "Duplexing: None", which I assume to be the CUPS default.
Any idea how I could revert to simplex printing as default for print jobs ?
fabio
Level 1
Level 1
 
Posts: 7
Joined: Sun Oct 21, 2007 5:01 pm

Re: Printing not using default settings

Postby prativasic on Thu Mar 08, 2012 5:37 am

I faced the similar problem, running LM12x64 KDE here. Can't change the settings from Portrait to Landscape in Okular. In fact I was having some other issues as well. Finally I updated to KDE 4.8 with ubuntu backport and now most of the issues are gone- including this printing issue.
prativasic
Level 1
Level 1
 
Posts: 14
Joined: Tue May 03, 2011 7:28 am
Location: Dhaka, Bangladesh

Re: Printing not using default settings

Postby lambda165 on Tue Jan 22, 2013 5:47 pm

NOT fixed. Mint 14 kde WILL NOT print duplex at all.
lambda165
Level 1
Level 1
 
Posts: 5
Joined: Tue Jan 22, 2013 5:40 pm


Return to KDE

Who is online

Users browsing this forum: No registered users and 5 guests