[workaround]I see blue people- Flash Plugin

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[workaround]I see blue people- Flash Plugin

Postby wyrdoak on Tue Mar 06, 2012 11:04 am

I know I saw a post about this somewere, but can't find the fix now. In flash player now my colors are BGR and should me RGB. Unless I cross connected to the Pandora web. :lol:
Last edited by wyrdoak on Mon Apr 02, 2012 9:07 pm, edited 2 times in total.
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Linux Mint is funded by ads and donations.
 

Re: I see blue people- Flash Plugin

Postby alquimista on Sat Mar 31, 2012 11:40 am

I just got the same problem.

I think it was after an upgrade of Chrome to version 18. Colors in some video players just went crazy... yes; blue skin people... and redish skyes.

When Chrome got updated, not just colors went wrong... Several browser errors regarding Shockwave Pligin broken showed up. In Firefox, errors were not there, yet the colour problem persisted. Same for Opera.

I executed the Software Packages Admin... reinstalled everything related to Flash and Shockwave... same error. I installed an older version od Chrome (v9) and works ok.

What could be the problem? I have Mint 10 Gnome... first time this happens since I begun using Mint.
alquimista
Level 3
Level 3
 
Posts: 145
Joined: Thu Nov 25, 2010 12:59 pm

Re: I see blue people- Flash Plugin

Postby alquimista on Sat Mar 31, 2012 12:48 pm

Ok... I solved it for Firefox: just downgraded from Flash 11 to 10.

Google Chrom 18 still crashes and send errors regarding the plug-in

BTW... I see a slight better video performance and sharpness in Firefox....
alquimista
Level 3
Level 3
 
Posts: 145
Joined: Thu Nov 25, 2010 12:59 pm

Re: I see blue people- Flash Plugin

Postby vger7 on Sat Mar 31, 2012 5:00 pm

vger7
Level 2
Level 2
 
Posts: 96
Joined: Tue Nov 24, 2009 1:55 am
Location: Third Stone From The Sun

Re: I see blue people- Flash Plugin

Postby altair4 on Sun Apr 01, 2012 1:59 pm

What has worked for me in Firefox:

Right click the video that has "blue people" and select "Settings" then un-check "Enable hardware acceleration". Restart Firefox.

Seems to be related to flash + nvidia which may explain why this is affecting some folks and not others.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6044
Joined: Tue Feb 03, 2009 10:27 am

Re: I see blue people- Flash Plugin

Postby alquimista on Sun Apr 01, 2012 6:40 pm

Hi,

I applied solution explained in "viewtopic.php?f=48&t=98453", and it works well, as downgrading to flash 10. Yet Google Chrome 18 still shows Shockwave errors and no flash video works

I have Nvidia card; is it the same in Mint 12 ? As far as Chrome 18 and Shockwave errors on Mint 10... has anybody else experienced this?

I like Chrome... its my default browser; yet with these problems and a bit better quality of video in Firefox (with no shkwave errors), I'll change it for a while
alquimista
Level 3
Level 3
 
Posts: 145
Joined: Thu Nov 25, 2010 12:59 pm

Re: I see blue people- Flash Plugin

Postby Chris M on Sun Apr 01, 2012 7:29 pm

This thread is in the Main Edition Support Multimedia forum. I don't know if this should be here, or perhaps moved to the LMDE Sound, Multimedia & Codecs sub-forum. I know wyrdoak is using Debian Edition SID. I'm using DE Testing. Are Main Edition users also having this problem? My guess is yes.

altair4 wrote:Seems to be related to flash + nvidia which may explain why this is affecting some folks and not others.


It's definitely a flash + nvidia issue: http://www.nvnews.net/vbulletin/showthr ... 664&page=9

See post #104 by NVIDIA Corporation's Plagman:

For people running into either the "leaking overlay" or the "blue people" problems, I wrote a patch to libvdpau_trace.so designed to suppress them.

Please clone libvdpau from git and apply this:

http://plagman.net/stuff/0001-vdpau_tra ... irks.patch

This will cause the resulting trace library to change the VDPAU behavior of any clients that have tracing enabled, so make sure you only enable tracing for the web browser that loads the Flash plugin (eg. for Firefox in Ubuntu, you'd add an "export VDPAU_TRACE=1" line to /usr/lib/firefox-n.n/firefox.sh). Trying to use tracing on any other VDAU client after this has been installed won't work right as it suppresses all the tracing messages and swaps color channels for some operations. Please make sure to restore a vanilla build of libvdpau_trace.so on your system before filing a VDPAU bug against something else.


I reached up into sid to get the latest flashplayer-mozilla 3:11.2.202.228-0.0, and that's when it happened. It didn't happen with 3:11.1.102.63-0.0 (which is still in the Debian Testing Multimedia repo).

It also did not affect my laptop with Intel graphics. And it did not happen on an ATI graphics machine with Xubuntu 11.10. I wonder if Debian includes some kind of fix before letting the latest flashplayer-mozilla flow down into Testing?
Chris M
Level 2
Level 2
 
Posts: 85
Joined: Mon Nov 29, 2010 10:01 pm

Re: I see blue people- Flash Plugin

Postby wyrdoak on Mon Apr 02, 2012 9:04 pm

altair4 wrote:What has worked for me in Firefox:

Right click the video that has "blue people" and select "Settings" then un-check "Enable hardware acceleration". Restart Firefox.

Seems to be related to flash + nvidia which may explain why this is affecting some folks and not others.



This worked for me, On this computer I'm using Nvidia. Thankyou
-Dell Mini Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(Maya-Xfce) LInux 3.2.0.57-generic(i686)
SolydX (32bit)
User avatar
wyrdoak
Level 6
Level 6
 
Posts: 1313
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: [workaround]I see blue people- Flash Plugin

Postby nomko on Tue Apr 03, 2012 4:26 am

ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router (WLR-5100)

Visit my website:
My personal website
nomko
Level 9
Level 9
 
Posts: 2765
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: [workaround]I see blue people- Flash Plugin

Postby Chris M on Sat Apr 07, 2012 12:53 am

flashplayer-mozilla (3:11.2.202.228-0.0) came down into testing. No more blue people problem. I wonder if Adobe or Debian instituted a fix. I did not un-check "Enable hardware acceleration".

wyrdoak, I realized that your using the main Mint 12 with the nvidia card. I wonder if you'd still have a problem if you checked Enable hardware acceleration now - although I don't know where you draw that file from.

This will be the last version of flash for Linux - unless you're using Chrome.
Chris M
Level 2
Level 2
 
Posts: 85
Joined: Mon Nov 29, 2010 10:01 pm

Re: [workaround]I see blue people- Flash Plugin

Postby danger89 on Sat Apr 21, 2012 4:57 pm

Too bad I have the same problem as destribbes above, not only at my desktop (NVidia GT275 card) as well as at my laptop (GT55M -> Optimus/Intel HD). It's very irritation that the flash keep crashing when watching (fullscreen) youtube video's :cry:

I'm using the offical non-free Adobe Flash player in the hope to have more native Flash support. Afterall I hope HTML5 well be the future as soon as possible ><
9 years Linux experience, and still counting
User avatar
danger89
Level 1
Level 1
 
Posts: 11
Joined: Mon May 03, 2010 9:25 am
Location: The Netherlans

Re: [workaround]I see blue people- Flash Plugin

Postby Chris M on Sun Apr 22, 2012 1:56 am

This is a real stinker from Adobe. But to be honest, it started again for me after updating the nvidia driver to version 295.40. Can't believe they completely blew the last version of Flash. Real nice.

I'm using Mint Debian. If you're using Mint Main, there are a number of posted Ubuntu solutions on the web. Here's another one (if you really want to maintain hardware acceleration in Flash). It's a play on my link above.

But in Debian, I reinstalled libvdpau1 in Synaptic, and this issue seems to have been resolved.
Chris M
Level 2
Level 2
 
Posts: 85
Joined: Mon Nov 29, 2010 10:01 pm

Re: [workaround]I see blue people- Flash Plugin

Postby HaddadRC on Mon Apr 30, 2012 3:19 am

Solution :
#Flash videos are blue:

Problem
Since a few days ago, Flash videos became blue on Ubuntu.

Solution
Create the folder “/etc/adobe” and add the following lines to “/etc/adobe/mms.cfg”:

First create the folder:

$sudo mkdir /etc/adobe

Second, create the mms.cfg

$sudo pico /etc/adobe/mms.cfg

Third, add these lines:

EnableLinuxHWVideoDecode=1
OverrideGPUValidation=true

Save, then restart Firefox
D;


solution works for me :)
HaddadRC
Level 1
Level 1
 
Posts: 5
Joined: Sat Feb 11, 2012 12:47 pm

Re: [workaround]I see blue people- Flash Plugin

Postby vishalvishnoi on Mon May 21, 2012 9:51 pm

I have mint 12 installed and solved this problem by just uncheck hard acceleration option from flash settings. (right click -> settings -> uncheck hardware acceleration option and refresh )
vishalvishnoi
Level 1
Level 1
 
Posts: 1
Joined: Mon May 21, 2012 9:48 pm

Re: [workaround]I see blue people- Flash Plugin

Postby android on Tue May 22, 2012 11:02 am

Yes, I had this problem too. All I did to fix was clear data/cache in the adobe flash player gtk.

Sent from my HTC One X using Tapatalk 2
android
Level 1
Level 1
 
Posts: 31
Joined: Wed May 02, 2012 2:28 am

Re: [workaround]I see blue people- Flash Plugin

Postby v_2ryann on Mon Jun 18, 2012 3:43 am

Hey All...Here is the real fix...
(I've tried flashaid and everything...nothing really solves it...and if they did they were very unstable)
You can read about the entire issue here:
http://askubuntu.com/questions/117127/flash-video-appears-blue/131040#131040
The problem is with most newer versions of Adobe Flash 64bit while using NVIDIA drivers. Adobe is the one with the problem, and of course they refuse to fix it.
Again its 64bit systems running 64bit flash.
First I used flashaid to install the latest 64bit flash. You can do it manually or however you want.

As listed in the above post, you need to install a patched version of libvdpau.
The patched versions can be found here:
https://launchpad.net/~tikhonov/+archive/misc/+packages

64bit Precise Patch (mint 13)
https://launchpad.net/~tikhonov/+archive/misc/+files/libvdpau1_0.4.1-3ubuntu1%2Bfixbluefaces%7Eprecise_amd64.deb
32bit Precise Patch (mint 13)
https://launchpad.net/~tikhonov/+archive/misc/+files/libvdpau1_0.4.1-3ubuntu1%2Bfixbluefaces%7Eoneiric_i386.deb

64bit Oneiric Patch (mint 12)
https://launchpad.net/~tikhonov/+archive/misc/+files/libvdpau1_0.4.1-3ubuntu1%2Bfixbluefaces%7Eoneiric_amd64.deb
32bit Oneiric Patch (mint 12)
https://launchpad.net/~tikhonov/+archive/misc/+files/libvdpau1_0.4.1-3ubuntu1%2Bfixbluefaces%7Eoneiric_i386.deb

I'm actually using Linux Mint Debian Edition (LMDE 201204 with MATE and mintMenu)
I just downloaded the 64bit Oneiric Patch and installed the .deb file and it fixed my flash and doesn't seem to have broken anything.
If you don't want to do it that way, I did see a debian fix on the site to:
https://launchpad.net/~tikhonov/+archive/misc/+files/libvdpau_0.4.1-3ubuntu1%2Bfixbluefaces%7Eoneiric.debian.tar.gz
or
https://launchpad.net/~tikhonov/+archive/misc/+files/libvdpau_0.4.1-3ubuntu1%2Bfixbluefaces%7Eprecise.debian.tar.gz
I just don't know how to make it into a deb!
Maybe someone can make this into a tutorial or something, or Clem or one of 'em can see about pushing out a mint one for those of us with nvidia cards.
Hope this helps.........This has been driving me crazy for a long time now!
v_2ryann
Level 1
Level 1
 
Posts: 3
Joined: Fri Jun 04, 2010 12:32 am

Re: I see blue people- Flash Plugin

Postby drefooty on Tue Jun 19, 2012 2:32 pm

altair4 wrote:What has worked for me in Firefox:

Right click the video that has "blue people" and select "Settings" then un-check "Enable hardware acceleration". Restart Firefox.

Seems to be related to flash + nvidia which may explain why this is affecting some folks and not others.



Thanks! This worked for me on Linux Mint 9 with Flash 11.2.
Just turning off the hardware acceleration was in fact the fix for my setup.
drefooty
Level 1
Level 1
 
Posts: 2
Joined: Mon May 10, 2010 5:50 pm

Re: [workaround]I see blue people- Flash Plugin

Postby Intangir on Mon Jan 21, 2013 1:46 pm

solution worked

thank you!
Intangir
Level 1
Level 1
 
Posts: 4
Joined: Fri Sep 09, 2011 12:34 am

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests