Disable workspace switcher

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Disable workspace switcher

Postby Beyond on Mon Apr 16, 2012 10:41 am

Hello,
I upgraded to gnome 3 (+ cinnamon) and now have a very irritating issue. WHen I press ctrl-alt-down/up what I believe is gnomes workspace switcher kicks in and shows all the application windows. Which would be fine, except for that I use the same shortcut to copy a line of code up/down. After 2h search, I must give up and turn to linux mint gurus. How do I change/disable/remove it?


Thanks in advance.
Beyond
Level 1
Level 1
 
Posts: 6
Joined: Thu Feb 17, 2011 9:20 am

Linux Mint is funded by ads and donations.
 

Re: Disable workspace switcher

Postby äxl on Mon Apr 16, 2012 2:12 pm

http://live.gnome.org/KeyboardShortcuts
To change them go to System > Preferences > Keyboard Shortcuts
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Disable workspace switcher

Postby Beyond on Tue Apr 17, 2012 4:50 am

Aha! Thanks for the reply. It seems that these shortcuts are not available under cinnamon, but they are under gnome.
So if anyone else is having similar issues:
    1. login with gnome
    2. change the shortcuts (Preferences > Keyboard > Shortcuts)
    3. log back in with cinnamon


Thanks for the help.
Beyond
Level 1
Level 1
 
Posts: 6
Joined: Thu Feb 17, 2011 9:20 am

Re: Disable workspace switcher

Postby äxl on Tue Apr 17, 2012 12:01 pm

There are no applications for Keyboard Preferences (keyboard-properties) or Keyboard Shortcuts (keybinding-properties) in Cinnamon?

You could also look for settings via Configuration Editor (gconf-editor) or command line gconftool in path /apps/metacity/
For Compiz (Fusion?) look for /apps/compiz/general/allscreens/options/ or use CompizConfig Settings Manager - General - Commands

Maybe someone could also look what changes are done while in Gnome 3 with:
Code: Select all
dconf watch /
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Disable workspace switcher

Postby Beyond on Wed Apr 18, 2012 5:08 am

I have neither "keyboard-properties" nor "keybinding-properties". The way I managed to change the setting was via "gnome-control-center keyboard".
However, the interesting thing is that it has significantly less configurable shortcuts when I'm logged in with Cinnamon as opposed to Gnome.

Just to make sure we are on the same page. I have resolved the issue.
Beyond
Level 1
Level 1
 
Posts: 6
Joined: Thu Feb 17, 2011 9:20 am

Re: Disable workspace switcher

Postby benwetherbee on Wed Nov 28, 2012 5:59 pm

I'm sure the original poster has figured it out by now, but for those that are looking for help:

MENU>PREFERENCES>CINNAMON SETTINGS>Keyboard>Keyboard Shortcuts
TOGGLE SCALE/EXPO is under CINNAMON and NOT Workspace Management (as I originally thought).

For those annoyed by the corner opening up Expo, you can turn it off under HOT CORNER.
benwetherbee
Level 1
Level 1
 
Posts: 1
Joined: Wed Nov 28, 2012 5:51 pm


Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 6 guests