[SOLVED] How to set default programs/applications?

Questions about applications and software
Forum rules
Before you post please read this

[SOLVED] How to set default programs/applications?

Postby DC80 on Mon Apr 23, 2012 5:56 am

Hi all,

I was wondering if it were possible to set default programs. For example mozilla firefox is installed by default, however, if you install google's chrome you can set it by default. I'm happy with my choice on the browser things but like I said, I was wondering if other programs can be set as default.

For example, i like foxit pdf reader. Now, the default is Evince (aka document viewer) but how do i set foxit reader to default pdf reader?

Kind regards,

DC80
Last edited by DC80 on Mon Apr 23, 2012 6:45 am, edited 1 time in total.
"The future is predeterment by those who shape it"
DC80
Level 2
Level 2
 
Posts: 86
Joined: Fri Jan 06, 2012 5:37 am

Linux Mint is funded by ads and donations.
 

Re: [mint 12] How to set default programs/applications?

Postby DC80 on Mon Apr 23, 2012 6:44 am

Hi all,

I do not know what i have done to get what i wanted but when i open an pdf file foxit opens it. I did the following actions:

- install foxit pdf reader by downloading the .deb file and execute it. Now you have two readers on your system (evince and foxit).

- after installing foxit i did go to a terminal and executed:

Code: Select all
sudo apt-get remove evince


And for last, open an pdf file and foxit comes up. I will set this topic to solved.

Kind regards,

DC80
"The future is predeterment by those who shape it"
DC80
Level 2
Level 2
 
Posts: 86
Joined: Fri Jan 06, 2012 5:37 am

Re: [SOLVED] How to set default programs/applications?

Postby cluelesscoder on Sun Nov 18, 2012 6:05 pm

The correct answer to setting a default is not this. See http://www.libre-software.net/change-the-default-application-ubuntu-linux titled "How to change the default application for a given type of file in Ubuntu Linux" for example. Basically, right-click and there will be a "Properties" menu. There's a button called "Set as default" under the "Open With" menu there. Unfortunately, the programs I've installed that I'm not looking for (PDFshuffler or PDFsam) aren't showing up, so I'll have to figure out another way. For those who are looking into getting more programs to show up on the list of applications, you might want to consult the thread over at viewtopic.php?f=47&t=103669 ("Can't set Adobe Reader as default application") which suggestions changing the file in usr/share/applications somehow.

EDIT: I figured this out. LInux Mint Cinammon (or perhaps Nautilus is to blame) HIDES FILE EXTESIONS like .desktop. So if you go to /usr/share/applications and see a bunch of filenames without a .desktop on them, and you try to open one with gedit, it won't open. You hve to append the .desktop to it. Once you do that, you follow the directions in the above noted thread: 'Find the line that says "Exec=acroread" and change it to "Exec=acroread %f"'. Change the acroread to match the program you're fixing. Quite frustrating that Cinammon/Nautilus does this.

As in many cases (in my limited experience 6 month or so experience), KDE is superior. If you go to System Settings, you'll find under the "Common Appearance and Behavior" menu a "File Associations" section which will handle this (haven't tested it yet). Confusingly, there's also a "Default Applications" section under the "Workspace Appearance.." menu, but that doesn't seem to hit what you and I want.
cluelesscoder
Level 1
Level 1
 
Posts: 12
Joined: Wed Sep 26, 2012 8:59 pm


Return to Software & Applications

Who is online

Users browsing this forum: kyphi and 16 guests