Custom DNS -> LAN disappears!

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Custom DNS -> LAN disappears!

Postby dclement on Fri Apr 27, 2012 5:00 am

Hello,

I have LMDE XFCE and it works nicely, but I have this strange issue when I try to set the DNS servers to custom addresses (for OpenDNS).

I'm doing it as described on their site, that is: Network Manager -> Modifiy connections -> (my wired connection) -> IPv4 settings -> method: automatic addresses only (DHCP). This unlocks the box where I can enter the custom DNS.

But when I apply and reconnect, I lose access to my LAN (NAS, other PC) -- there's even no more 'network' item in Thunar.

I'm very surprised with this behavior as this used to work under Gnome (Ubuntu). What am I doing wrong?

TIA for any advice - regards, Daniel.
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am

Linux Mint is funded by ads and donations.
 

Re: Custom DNS -> LAN disappears!

Postby Brian49 on Fri Apr 27, 2012 6:43 am

Can't give you a definitive answer, but here are a couple of thoughts:

- I've found that when I use the method you describe to set the DNS servers, for some reason the local network name in the etc/hosts file gets changed. So it's a matter of changing it back to what it should be.

- I find it easier and more trouble-free to set the DNS servers directly in my router. How straightforward this is obviously depends on what router you have.
Brian49
Level 5
Level 5
 
Posts: 610
Joined: Thu Oct 29, 2009 2:27 pm

Re:[SOLVED] Custom DNS -> LAN disappears!

Postby dclement on Fri Apr 27, 2012 8:33 am

Thank you Brian for your quick reply. It put me on the track of the right setting.

What did the trick was not the /etc/hosts file (which remained unchanged) but the /etc/samba/smb.conf.

It had to be edited at these places:

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = WORKGROUP
netbios name = M6400

(last line added with the network name of my PC - probably not essential)

and:

# What naming service and in what order should we use to resolve host names
# to IP addresses
name resolve order = lmhosts wins bcast host

(apparently the _order_ of items on the right hand side is critical, and is _not_ the same as the original.)

I'm almost sure I already had to edit this file in my previous setup; I only had forgotten that...

Granted, it would be _much_ more convenient to do that in the router. But I don't have a 'real' router; only one of those "boxes" which also provide telephony, TV... It's far from being as feature-packed as a full-blown router.

Regards - Daniel
dclement
Level 3
Level 3
 
Posts: 155
Joined: Thu Apr 19, 2012 9:59 am


Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 3 guests