No wireless for BCM4321 Linksys WPC300N V1

Questions about WIFI networks and devices
Forum rules
Before you post please read this

No wireless for BCM4321 Linksys WPC300N V1

Postby taytong888 on Fri Apr 27, 2012 10:25 pm

Hello,

I just installed LMDE201204 Mate/Cinnamon 32bit on my laptop which has a built-in miniPCIe Atheros AR-5001 wireless G adapter (ath5k driver). Since I want to use wireless N, I installed an external PCMCIA card called Linksys WPC300N v1. I have Windows and Ubuntu on this laptop and Broadcom STA (i.e. wl) wireless driver which works fine for wireless N connections.

With LMDE201204, Broadcom STA doesn't seem to work, so I installed b43-fwcutter and firmware-b43-installer via Software Manager. When finished, I tried typing:

Code: Select all
sudo modprobe b43


and after reboot, the screen says to the effect that module modprobe is not found in unix...

Also, the terminal shows;
Code: Select all
#lspci -nnk

0a:00.0 Network controller [0280]: Broadcom Corporation BCM4321 802.11b/g/n [14e4:4329] (rev 01)
   Subsystem: Linksys WPC300N v1 Wireless-N Notebook Adapter [1737:0058]


I keep seeing a wireless authentication window and another one to authorize modification of network settings. Nothing happens after I enter my passwords in these two.

I would very much appreciate your help.
:(
taytong888
Level 1
Level 1
 
Posts: 41
Joined: Tue Nov 15, 2011 10:29 pm

Linux Mint is funded by ads and donations.
 

Re: No wireless for BCM4321 Linksys WPC300N V1

Postby taytong888 on Sun Apr 29, 2012 11:35 pm

Update:
First of all, I removed the built-in wireless G miniPCIe adapter card, to prevent interference with configuring wireless N connection, since blacklisting ath and ath5k didn't work.

I suspected Network Manager has issues with setting static addresses in wireless connections. Based on the post by altair4 called "Network-Manager issues" dated Dec. 4, 2011, I did the following:

Code: Select all
gksudo gedit /etc/network/interfaces


Deleted all, except the first 2 lines as in the following:

Code: Select all
auto lo
iface lo inet loopback


Saved the file and closed.

I then purged broadcom-sta-common, b43-fwcutter and firmware-b43-installer and reinstalled the latter two:

Code: Select all
sudo apt-get purge broadcom-sta-common b43-fwcutter  firmware-b43-installer


Code: Select all
sudo apt-get install b43-fwcutter  firmware-b43-installer


After this I tried to configure wireless connection in NM, but it was difficult to do so because either nothing happens or the fields were not available. Eventually I managed to configure. Signal strength was only 1 Mbps.

Then wireless connection was lost forever.

Now I got solid pilot light on the adapter card for LINK and POWER for the first time ever, but I keep getting authentication prompts for wireless network connection secrets and permission to change network settings. I think NM still has a long way to go until the release of LMDE final edition. By the way, I also tried WICD but it does not work for PPPOE wireless connection yet.

Any suggestions?

:(
taytong888
Level 1
Level 1
 
Posts: 41
Joined: Tue Nov 15, 2011 10:29 pm

Re: No wireless for BCM4321 Linksys WPC300N V1

Postby taytong888 on Wed May 02, 2012 8:04 pm

Hello,

I gave up on LMDE. In LMDE, I installed broadcom-sta-common which is the only one available, via synaptic. Under lspci -nnk, the screen shows only the Broadcom BCM 4321 wireless b/g/n adapter but not kernel driver wl. If I purge wl and replace it with firmware-b43-installer, the screen shows b43-pci-bridge as kernel driver in use and the PCMCIA card shows 2 solid pilot lights but no wireless. For some reasons Network Manager with static IP cannot send wireless secret passphrase to the system, so wireless authentication requests keep popping up with either wl or b43 installed.

Installed Linux Mint 12, which detects and suggests installation of proprietary driver Broadcom STA (i.e. wl). Wireless connection is established!

:P
taytong888
Level 1
Level 1
 
Posts: 41
Joined: Tue Nov 15, 2011 10:29 pm


Return to Wireless

Who is online

Users browsing this forum: No registered users and 0 guests