Howto Disable Hibernate when I close my Laptop Lid?

Howto Disable Hibernate when I close my Laptop Lid?

Postby officialhopsof on Sat May 05, 2012 3:04 pm

I can't seem to find a setting for this. How can I make my computer not hibernate/sleep when I close my laptop lid?

Just in case you are wondering I have the following:
Dell XPS 17
2nd gen i7
LMDE w/ Cinnamon (freshly installed and fully up to date)
Nvidia GTS 555m

I can make this change in Mate fairly easily via the screen saver settings dialog. Cinnamon seems to have no such dialog or similar setting.

Thank you for your time,
Brandon Murphy
officialhopsof
Level 1
Level 1
 
Posts: 1
Joined: Sat May 05, 2012 2:56 pm

Linux Mint is funded by ads and donations.
 

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby xenopeek on Sat May 05, 2012 4:49 pm

Moved here by moderator
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14697
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby TomRoche on Sat May 05, 2012 7:47 pm

I am also having this problem, which is one reason why I'm running MATE (though cinnamon is definitely prettier).
TomRoche
Level 3
Level 3
 
Posts: 172
Joined: Thu Jan 13, 2011 2:52 pm

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby azertywarrior12 on Mon May 07, 2012 7:19 am

Could you test this:

Hit Alt + F2 and type in dconf-editor.

When that's open, in the left on the tree list do this:

Code: Select all
Expand: Org
Expand: Gnome
Expand: settings-daemon
Expand: Plugins
Click: Power

Change:
lid-close-ac-action: nothing (or your choice)
lid-close-battery-action: nothing (or your choice)

Close dconf-editor.

Hit alt + F2 and type r and try to close the lid. Post your conclusion, did it work or not?
azertywarrior12
Level 1
Level 1
 
Posts: 12
Joined: Tue Aug 02, 2011 11:17 am
Location: Belgium

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby Inkit on Mon May 07, 2012 9:01 am

I can't seem to find a setting for this.


:idea: Why not try xfce, or even KDE. :D

Not meaning to cast any doubts on warrior's suggestions.
Inkit
Level 5
Level 5
 
Posts: 681
Joined: Fri Jun 25, 2010 4:44 am

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby mixolyd on Mon May 21, 2012 1:35 am

Use gnome-tweak-tool under shell setting. It will show up in menu as "Advanced Settings"
mixolyd
Level 1
Level 1
 
Posts: 6
Joined: Thu May 17, 2012 7:47 am

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby phishsauce on Tue Jul 24, 2012 12:42 pm

I can confirm that azertywarrior12 solution works on LMDE gnome3 + cinnamon.
phishsauce
Level 1
Level 1
 
Posts: 18
Joined: Tue Jan 04, 2011 7:18 pm

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby uvajed on Tue Sep 25, 2012 11:19 pm

I can also happily confirm that the solution above works for me! Is there some other power manager built into CInnamon that I am missing? If not, there needs to be, as 99% of users would never be able to solve this on their own or by trial and error. Thank you SOOO much for this!

I had been reluctant to use CInnamon solely due to the fact that it would hibernate when I closed the laptop's lid, as my Toshitba Satellite L775D will not resume correctly when told by Mint to sleep/hibernate. As a result of this I have been trying to use MATE (which presents me with sound and volume issues), and trying out Mint Maya with KDE. Now I think I might be able to stick with LMDE and CInnamon, which is what I would rather do. Of course I was perfectly happy with Gnome 2, but that is beside the point now.
uvajed
Level 1
Level 1
 
Posts: 23
Joined: Sun Nov 22, 2009 2:09 am

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby bkn on Thu Sep 27, 2012 1:15 am

azertywarrior12's suggestion doesn't seem to work for me. I used dconf-editor to set my lid-close action on battery to "suspend", but nothing seems to happen on lid close when I'm on Cinnamon.

I have another user id on the machine that uses MATE, and suspend on lid-close seems to be working fine there. In fact if both users are logged in, I can get the system to suspend on lid close if I close the lid after switching to the second user's screen using Ctrl-Alt-F8, but when I'm on the CInnamon desktop user's screen, suspend on lid-close doesn't happen.
bkn
Level 1
Level 1
 
Posts: 1
Joined: Thu Sep 27, 2012 1:03 am

Re: Howto Disable Hibernate when I close my Laptop Lid?

Postby X3MBoy on Wed Mar 27, 2013 1:12 am

The problem with Gnome 3.X is that systemd override gnome configuration for ACPI. A fix is to edit the /etc/systemd/logind.conf and set the HandleLidSwitch to ignore and restart systemd with sudo systemctl restart systemd-logind.service

Hope that help,

Eduard "X3MBoy" Lucena
X3MBoy
Level 1
Level 1
 
Posts: 1
Joined: Wed Mar 27, 2013 1:08 am

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 1 guest