Ctrl + Super shortcut for MintMenu not working

Ctrl + Super shortcut for MintMenu not working

Postby cb474 on Mon Apr 23, 2012 9:17 pm

I noticed that with the new live .iso, shifting from Gnome to Mate, the Ctrl + Super_L shortcut to bring up the MintMenu is not working. When I go to preferences for MintMenu it is set to be working, but doesn't. Are other's having this problem? Any way to fix it? Thanks.
cb474
Level 2
Level 2
 
Posts: 52
Joined: Thu Dec 11, 2008 9:01 am

Linux Mint is funded by ads and donations.
 

Re: Ctrl + Super shortcut for MintMenu not working

Postby slashvanyoung on Mon Apr 30, 2012 11:22 am

I'm having the same problem here. No matter what shortcut I set, it won't open the mint menu...
slashvanyoung
Level 1
Level 1
 
Posts: 3
Joined: Mon Apr 30, 2012 11:11 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby BLaZuRE on Thu May 03, 2012 4:39 am

I read somewhere that the version of Mate packaged by default on Mint is a bit out of date and that this problem was fixed in the newest Mate version. Instructions on how to update are here: http://wiki.mate-desktop.org/download#linux_mint. That being said, I haven't had much luck with <ctrl>Super_L on the newest version of Mate (though I'm on the main edition of Mint 12).
BLaZuRE
Level 1
Level 1
 
Posts: 6
Joined: Mon Apr 30, 2012 6:55 pm

Re: Ctrl + Super shortcut for MintMenu not working

Postby Monsta on Thu May 03, 2012 6:54 am

Hmm, it seems that deskbar-applet either hasn't been ported to MATE or hasn't been added to the repo. :)
Okay... let's try telling mintMenu that it needs to use the little python-keybinder package instead of the fat deskbar-applet one.

1. Install python-keybinder.
Code: Select all
sudo apt-get install python-keybinder
This will also install libkeybinder0.

2. Backup mintMenu.py just in case.
Code: Select all
cd /usr/lib/linuxmint/mintMenu
sudo cp mintMenu.py mintMenu.py.old

3. Edit mintMenu.py with your favorite text editor (as root of course). Change this line
Code: Select all
from deskbar.core.keybinder import tomboy_keybinder_bind as bind_key
to
Code: Select all
from keybinder import bind as bind_key
and save the file.

4. Run mintMenu in the terminal (it will show up in the separate window) just to test if the global hotkey works now.
Code: Select all
mintmenu

5. Press the hotkey you've set earlier (if you haven't, it's Ctrl + Left Super key).

6. If it works, log out and log in again to make it work for the "real" mintMenu (the one on the panel).
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby slashvanyoung on Fri May 04, 2012 12:01 pm

@BLaZuRE: The most recent version, 1.2.0, is already in lmde as of update pack 4. :wink:

@Monsta: Tried this. Step by step. Didn't work for me. :(
slashvanyoung
Level 1
Level 1
 
Posts: 3
Joined: Mon Apr 30, 2012 11:11 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby Monsta on Sat May 05, 2012 3:19 am

slashvanyoung wrote:Tried this. Step by step. Didn't work for me. :(

Hmm, strange. Were there any error messages (run mintmenu in the terminal to check for them)? Did you try various hotkeys?
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby slashvanyoung on Sat May 12, 2012 4:55 am

Monsta wrote:
slashvanyoung wrote:Tried this. Step by step. Didn't work for me. :(

Hmm, strange. Were there any error messages (run mintmenu in the terminal to check for them)? Did you try various hotkeys?


So I finally managed to successfully bind the "F2" key to the mint menu, using your method. That key is (obviously) less than ideal, but it's better than nothing. I couldn't get Ctrl + Super, Super + anything, just Super or even something like Ctrl + Alt to work, no matter how I entered the shortcut.

"F2" will do it for now, so I can retire the Synapse launcher for now. :wink:

Thanks again!
slashvanyoung
Level 1
Level 1
 
Posts: 3
Joined: Mon Apr 30, 2012 11:11 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby Monsta on Sat May 12, 2012 5:56 am

I can only suppose some other program has captured these keys in your system... because I really can't figure out what else it could be. :?
Need more testers :D
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby Oscar799 on Mon May 14, 2012 9:11 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8825
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Ctrl + Super shortcut for MintMenu not working

Postby BLaZuRE on Fri May 18, 2012 2:25 pm

I found an error, but I don't know how to fix it. I ran mintmenu and got:

Code: Select all
*********** Keybind Driver Load Failure **************
Error Report :  No module named deskbar.core.keybinder
Opacity is: 98
Setting opacity to: 0.98
__init__ took 58.800 ms
[2012-05-18 10:36:55,838 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/engrampa.desktop WD=-1 Errno=No such file or directory (ENOENT)
[2012-05-18 10:36:55,845 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/file-roller.desktop WD=-1 Errno=No such file or directory (ENOENT)
[2012-05-18 10:36:55,846 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/brasero.desktop WD=-1 Errno=No such file or directory (ENOENT)
[2012-05-18 10:36:55,855 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/gcalctool.desktop WD=-1 Errno=No such file or directory (ENOENT)
[2012-05-18 10:36:55,856 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/mate-calc.desktop WD=-1 Errno=No such file or directory (ENOENT)
[2012-05-18 10:36:55,857 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/gucharmap.desktop WD=-1 Errno=No such file or directory (ENOENT)
... [a lot more errors]
[2012-05-18 10:36:56,046 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/display-properties.desktop WD=-1 Errno=No such file or directory (ENOENT)
[2012-05-18 10:36:56,051 pyinotify ERROR] add_watch: cannot watch /home/alex/.config/autostart/gnome-system-monitor.desktop WD=-1 Errno=No such file or directory (ENOENT)
Binding to Hot Key: <Control>Super_L
** WARNING ** - Menu Hotkey Binding Error
Error Report :
global name 'bind_key' is not defined
/usr/lib/linuxmint/mintMenu/mintMenu.py:857: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  main_window.show()


When I look at /usr/lib/linuxmint/mintMenu/mintMenu.py, I see it tries to open deskbar.core.keybinder which is supposed to be from deskbar-applet, which is not on my computer. Nothing with deskbar in the name is on my computer except two .png files. I was going to start compiling & installing deskbar-applet from gnome.org, but there was a python error not finding the headers, so I gave up for now.

Anyone have any ideas?
BLaZuRE
Level 1
Level 1
 
Posts: 6
Joined: Mon Apr 30, 2012 6:55 pm

Re: Ctrl + Super shortcut for MintMenu not working

Postby Monsta on Sat May 19, 2012 7:06 am

Doesn't my post above explain how to deal with this problem?
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby äxl on Sat May 19, 2012 7:27 pm

Works for me, Monsta. Big thanks! :!:
(Tracking {MATE+Debain} Wheezy)
My Linux history: Ubuntu 10.04 - 10.10 - LMDE 201109 - UP4 My sources.list/preferences

Computers is not science. And it's not magic - it's something in between.
User avatar
äxl
Level 5
Level 5
 
Posts: 524
Joined: Fri Apr 06, 2012 6:14 am
Location: Germany

Re: Ctrl + Super shortcut for MintMenu not working

Postby Monsta on Sun May 20, 2012 4:50 am

Good. :)

Now I have to mention that this hack isn't required anymore in Mint 13. There's a new mintmenu-keybinder package which seems to include the whole old deskbar-applet package contents, and so the global menu hotkey is working again.

Update: LMDE now has this package too. Mint 12 hasn't received it yet (and maybe it never will).
Last edited by Monsta on Sun Sep 02, 2012 1:13 pm, edited 1 time in total.
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby peridox91 on Wed Jun 06, 2012 9:53 am

slashvanyoung wrote:
Monsta wrote:
slashvanyoung wrote:Tried this. Step by step. Didn't work for me. :(

Hmm, strange. Were there any error messages (run mintmenu in the terminal to check for them)? Did you try various hotkeys?


So I finally managed to successfully bind the "F2" key to the mint menu, using your method. That key is (obviously) less than ideal, but it's better than nothing. I couldn't get Ctrl + Super, Super + anything, just Super or even something like Ctrl + Alt to work, no matter how I entered the shortcut.

"F2" will do it for now, so I can retire the Synapse launcher for now. :wink:

Thanks again!


Interestingly, my Ctrl+Super_L did once work for the Mint Menu. Then somehow, it stopped working. I don't know if my playing around with iBus did anything to it, but yeah, it seems that my Super key may be not functioning. Strangely, I could not start my Firefox with my custom Ctrl+Alt+M using the internet shortcut I set up (though I could earlier in my login session). I had to disable that shortcut and make a custom one for firefox...

So something seems weird. I could use the MintMenu Ctrl+Super_L shortcut, but then no longer. It might have to do with my toying around iBus and alt+Super to shift between language/keyboards, but I don't know.
peridox91
Level 1
Level 1
 
Posts: 9
Joined: Wed Jun 06, 2012 9:40 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby peridox91 on Wed Jun 06, 2012 10:12 am

OKAY! THIS MAY BE A BUG ... BUT I GOT MY MINT MENU TO WORK!

I am currently running Linux Mint 13 MATE. (I have installed the python thing described earlier in this post or some related post and also synapse, though I believe they are both not necessary, as I was able to open mintMenu with the Ctrl+Super_L shortcut before but then for a while could not. But now I can.

SHORTCUT FOR MENU [somewhat changed]: Ctrl+SUPER_L+SUPER_L (i.e. hold control and double tap Super_L)

Now I did use the "hack" earlier and had to edit mintmenu, though I'm not sure if you have to do it. But apparently, it works like a charm when you hold down Ctrl and press Super_L (Windows button) twice. Very interesting. Everytime I release Control, the first time I try the Ctrl+Super_L shortcut, it doesn't work. But after holding Ctrl and pressing Super_L once, subsequent (single) pressing of Super_L toggles the Mint Menu on and off.

Oh, and being a newb, if there is any bug reporting that I need to do, please do for me or tell me where I should report this (if indeed it is reportable).

Actually, I turned off the hack, so I changed my /usr/lib/linuxmint/mintMenu/mintMenu.py back to the original (with the line changed back to the original, that is ``from deskbar.core.keybinder . . ."). It still works. So if you despair, try holding Ctrl and then hit Super_L twice! From then on, as long as you hold control, the menu will toggle on and off with one Super_L key.
peridox91
Level 1
Level 1
 
Posts: 9
Joined: Wed Jun 06, 2012 9:40 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby jaderiver on Sun Sep 02, 2012 11:22 am

I have Mint 13 Mate, and my mintmenu hotkey also worked at first, and then, not. :? Used Monsta's solution, above, involving python-keyring. Now, even though the command is <Control>Super_L, I need to press Ctrl+Super_L+Super_L (the last twice). Then, I can clear mintmenu by pressing Super_L once.

This fix not the most ideal, but at least I can keystroke mintmenu. Thanks, Monsta. :)

jaderiver
ASUS U56E 64-bit Mint 13 MATE Maya w/Petra backported - dualboot WIN 7
Zoom #3095 dialup USB modem
jaderiver
Level 2
Level 2
 
Posts: 78
Joined: Wed Jun 27, 2012 1:43 pm
Location: Oregon Coast

Re: Ctrl + Super shortcut for MintMenu not working

Postby Monsta on Sun Sep 02, 2012 1:16 pm

This double-tap thing is strange... On the other hand, my hack is not really needed in Mint 13 (see my post about mintmenu-keybinder above).
Monsta
Level 8
Level 8
 
Posts: 2392
Joined: Fri Aug 19, 2011 3:46 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby mali radnik on Fri Sep 14, 2012 1:27 pm

The double-tap did not work for me. Here is what I got in terminal:

rudar@rudarlmde ~ $ sudo apt-get install python-keybinder
[sudo] password for rudar:
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-keybinder is already the newest version.
The following packages were automatically installed and are no longer required:
libdbusmenu-qt2 libqzeitgeist0 virtuoso-minimal libqca2 libqt4-qt3support
libpolkit-qt-1-1 libknewstuff3-4 libvirtodbc0 libsox-fmt-base
libnepomukquery4a libthreadweaver4 libsox-fmt-alsa libkdecore5 phonon
libnepomukutils4 libktexteditor4 libkmediaplayer4 oxygen-icon-theme
plasma-scriptengine-javascript libkrosscore4 virtuoso-opensource-6.1-bin
libqt4-opengl libsolid4 libdlrestrictions1 libnepomuk4 libkdegames5a
libsoprano4 virtuoso-opensource-6.1-common libkdnssd4 libkparts4
phonon-backend-vlc libclucene0ldbl shared-desktop-ontologies kdoctools
libmikmod2 libkidletime4 katepart libkcmutils4 libntrack0 python-rsvg
soprano-daemon libkfile4 libkpty4 libphonon4 sox libkntlm4 libnuma1
libplasma3 libsdl-net1.2 libkemoticons4 ntrack-module-libnl-0 libutempter0
kdelibs-bin libkdewebkit5 libattica0 libkjsembed4 libkio5 libkjsapi4
libstreams0 libntrack-qt4-1 kdelibs5-data libsox1b libkde3support4 libssh-4
libknotifyconfig4 kdelibs5-plugins libiodbc2 libkhtml5 libkdeui5 libkdesu5
libkatepartinterfaces4 libsdl-sound1.2 kate-data libstreamanalyzer0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
rudar@rudarlmde ~ $ cd /usr/lib/linuxmint/mintMenu
rudar@rudarlmde /usr/lib/linuxmint/mintMenu $ sudo cp mintMenu.py mintMenu.py.old
rudar@rudarlmde /usr/lib/linuxmint/mintMenu $ from keybinder import bind as bind_key
from: can't read /var/mail/keybinder
rudar@rudarlmde /usr/lib/linuxmint/mintMenu $ mintmenu
Opacity is: 98
Setting opacity to: 0.98
__init__ took 46.441 ms
Binding to Hot Key: <Super_L>

** (mintMenu.py:5400): WARNING **: Binding '<Super_L>' failed!

/usr/lib/linuxmint/mintMenu/mintMenu.py:857: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
main_window.show()
mali radnik
Level 1
Level 1
 
Posts: 39
Joined: Wed Dec 28, 2011 4:34 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby mali radnik on Fri Sep 14, 2012 1:55 pm

Sorry, I just found a simple solution to my problem: right click on menu, open preferences, set down what I want, then close preferences, then Logout and Login. And that's it, now I can open Menu bar with single press on Super_L (or Win key). Well done to LMDE!
mali radnik
Level 1
Level 1
 
Posts: 39
Joined: Wed Dec 28, 2011 4:34 am

Re: Ctrl + Super shortcut for MintMenu not working

Postby jaderiver on Sat Sep 22, 2012 1:52 am

OK... now I am able to kick in the Menu with just one tap of the Super_L/Windows key. Seems as if changing the Menu Preference, then logging out, then logging back in, as previously suggested, did the trick. Thought I had tried all these steps before but... :?:

Anyway, glad the button works with one tap now. :P
ASUS U56E 64-bit Mint 13 MATE Maya w/Petra backported - dualboot WIN 7
Zoom #3095 dialup USB modem
jaderiver
Level 2
Level 2
 
Posts: 78
Joined: Wed Jun 27, 2012 1:43 pm
Location: Oregon Coast

Linux Mint is funded by ads and donations.
 
Next

Return to MATE

Who is online

Users browsing this forum: No registered users and 4 guests