Black screen when booting LMDE 201204 with Intel graphics

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Black screen when booting LMDE 201204 with Intel graphics

Postby rootchick on Thu May 10, 2012 12:08 pm

Hi all,

This should probably be marked [SOLVED] since I managed to find a workaround, but I thought I would post my experiences here in case it might help somebody else with the same problem.

The problem: When booting a Foxconn 45CSX barebones system (which has an Intel GMA 950 graphics chip) from the 201204-mate-cinnamon image, the system seems to boot normally, but when the gui starts loading, the screen goes black, the mouse cursor makes a brief appearance, and then the screen goes black again. I managed to install by hitting Ctrl+Alt+Backspace, which took me to the mdm login screen, changing the session to Cinnamon and logging in with username "mint" and no password. That loaded Cinnamon and I was able to run the installer.

However, after the install completes, when it tries to load MATE it exhibits the same behavior with the screen going black. I found that if I added "nomodeset acpi=off" to the grub boot options I could get MATE to load, but then there's no acpi. After a lot of googling, I found this:

http://wiki.debian.org/KernelModesetting (See the section under known bugs for 945GM and 82865G)

Which led me to experiment with setting options for i915 at boot. I found that if I added "i915.modeset=0" to the grub boot options, I could load MATE without having to disable acpi or using nomodeset, so I added that to /etc/default/grub under the GRUB_CMDLINE_LINUX_DEFAULT option and ran update-grub to make it permanent. This must override the setting in /etc/modprobe.d/i915-kms.conf, which has modeset=1. So probably changing that would work too.

So, those are my findings. Not sure if it warrants a bug report.

Cheers,
rootchick
User avatar
rootchick
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 01, 2011 12:55 pm

Linux Mint is funded by ads and donations.
 

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby Supamarioana on Fri May 11, 2012 6:30 am

This helped me out on my Thinkpad L420 with Intel HD3000 graphics. Thanks!
Supamarioana
Level 1
Level 1
 
Posts: 14
Joined: Thu Nov 05, 2009 1:48 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby rootchick on Fri May 11, 2012 9:37 am

Supamarioana wrote:This helped me out on my Thinkpad L420 with Intel HD3000 graphics. Thanks!


Great, I'm glad it worked for you!
User avatar
rootchick
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 01, 2011 12:55 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby Darvon on Sun May 13, 2012 11:11 am

What could I do, if ctrl + alt + backspace doesn't do anything when I boot up the live CD? If compatibility mode or not, it doesn't matter. I have a Thinkpad L520, also with intel hd3000 graphics.
Darvon
Level 1
Level 1
 
Posts: 13
Joined: Tue Dec 13, 2011 4:26 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby Supamarioana on Sun May 13, 2012 11:58 am

You could try Ctrl-Alt-Delete instead. What I also noticed was that the laptop tried to display via external monitor. Although none was connected! :roll:
So maybe you could try connecting an external monitor for installation.
Supamarioana
Level 1
Level 1
 
Posts: 14
Joined: Thu Nov 05, 2009 1:48 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby Darvon on Sun May 13, 2012 12:34 pm

ctrl + alt + del doesn't work either. And unfortunately I don't have an external monitor, but even if I had, I usually take my notebook with me, so that's not really an option. But thanks for the reply.
Darvon
Level 1
Level 1
 
Posts: 13
Joined: Tue Dec 13, 2011 4:26 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby rootchick on Mon May 14, 2012 9:38 am

Do you get a console when you hit Ctrl+Alt+F1?
User avatar
rootchick
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 01, 2011 12:55 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby rootchick on Mon May 14, 2012 10:01 am

Darvon, you could try adding i915.modeset=0 to the grub boot options. I think this could get you there (working from memory here, things may be slightly different):

When you see text about grub during boot, press Esc.

On the list of boot options, hit Tab to edit the Linux Mint entry.

Arrow down to the line ending with "quiet". After "quiet", add i915.modeset=0.

Hit F10 to boot.

If that works, after you install you'll have to change it permanently.
User avatar
rootchick
Level 1
Level 1
 
Posts: 33
Joined: Fri Apr 01, 2011 12:55 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby HogNation on Mon May 14, 2012 10:06 am

rootchick wrote:Darvon, you could try adding i915.modeset=0 to the grub boot options. I think this could get you there (working from memory here, things may be slightly different):

When you see text about grub during boot, press Esc.

On the list of boot options, hit Tab to edit the Linux Mint entry.

Arrow down to the line ending with "quiet". After "quiet", add i915.modeset=0.

Hit F10 to boot.

If that works, after you install you'll have to change it permanently.


For some reason with Intel this is the best solution. Don't ask me why, but it always works for me.
"Keep Calm & Call On"
Linux Number: 551803
User avatar
HogNation
Level 1
Level 1
 
Posts: 26
Joined: Mon Apr 30, 2012 11:02 am
Location: United States

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby Darvon on Mon May 14, 2012 4:20 pm

Hey thanks, it helped!

The problem was that when you enter the boot options, there are two dashes at the end, something like that:

Code: Select all
... quiet --


And I tried to enter that i915 parameter at the end, but you have to enter it before the dashes, like this:

Code: Select all
... quiet i915.modeset=0 --


Now I could finally boot up the CD! Installing will have to wait until tomorrow :) So, thanks for the help!
Darvon
Level 1
Level 1
 
Posts: 13
Joined: Tue Dec 13, 2011 4:26 pm

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby penzoiders on Tue Feb 12, 2013 12:05 pm

adding this to boot options in grub works great also on my DELL Latitude E6430 with HD4000 graphics

Code: Select all
i915.modeset=0


thanks a lot for pointing this solution!

now I can successfully install and run LMDE!
User avatar
penzoiders
Level 1
Level 1
 
Posts: 17
Joined: Sun Feb 03, 2013 10:17 am

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby lmdewheezy on Tue Feb 12, 2013 3:19 pm

rootchick wrote:If that works, after you install you'll have to change it permanently.


See post below...
Last edited by lmdewheezy on Tue Feb 12, 2013 4:16 pm, edited 1 time in total.
lmdewheezy
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 12, 2013 12:49 pm
Location: In-between cities

Re: Black screen when booting LMDE 201204 with Intel graphic

Postby lmdewheezy on Tue Feb 12, 2013 4:15 pm

This must override the setting in /etc/modprobe.d/i915-kms.conf, which has modeset=1. So probably changing that would work too.

So, those are my findings. Not sure if it warrants a bug report.

Cheers,
rootchick


Yep, that works too.
lmdewheezy
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 12, 2013 12:49 pm
Location: In-between cities

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: Google Adsense [Bot] and 7 guests