LMDE/XFCE update has gone berserk

deb http://debian.linuxmint.com

LMDE/XFCE update has gone berserk

Postby rayandrews on Tue May 15, 2012 7:55 pm

All,

So I'm running LMDE XFCE version (didn't that used to have a forum all to itself?) Anyway, I hadn't done an update for a while, so hit the 'updates' button, and it wants to do 1177 updates! I made a backup of my install, ran the updates, and ended up looking at 'update pack 4' which seemed determined to install Gnome 3. Previous updates have not attempted to do that, and have left my XFCE system unmolested. Just for the halibut, I gave the thing free reign and it hung. On reboot and retry I got a msg. to the effect that I had 17 broken packages, and nothing I did would would fix them.

Anyway, I don't want anything to do with Gnome 3. How can I update my XFCE system without any G3 contamination? It does look like there's many many other things that could do with an upgrade but I'd rather not pick them one at a time. I've resored my system from backup and would like to try updating again, but no G3 puuuleeeze.

here's my sources.list:

deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

Thanks!
rayandrews
Level 2
Level 2
 
Posts: 99
Joined: Sun Jul 10, 2011 8:56 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE/XFCE update has gone berserk

Postby zerozero on Tue May 15, 2012 8:58 pm

hi,
i've seen that a couple times already, it means that you have some gnome app, pkgs lib in the install right now that will pull in gnome3 and gnome-shell as dep with this UP4.

what to do? before updating, look at the usual culprits: nautilus, evolution, epiphany, maybe gedit, totem, eog, see how much of that you can strip down and replace with xfce conterparts (be careful anyway that some of those pkgs have dep in core components of the system that you don't want to loose: keyring, networkmanager)

good luck.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6482
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE/XFCE update has gone berserk

Postby rayandrews on Wed May 16, 2012 10:52 am

zerozero wrote:hi,
i've seen that a couple times already, it means that you have some gnome app, pkgs lib in the install right now that will pull in gnome3 and gnome-shell as dep with this UP4.

what to do? before updating, look at the usual culprits: nautilus, evolution, epiphany, maybe gedit, totem, eog, see how much of that you can strip down and replace with xfce conterparts (be careful anyway that some of those pkgs have dep in core components of the system that you don't want to loose: keyring, networkmanager)

good luck.


Nuts, so there's no simple solution then? :( I'd have thought that Clem would give as a separate update stream for the xfce version that would not tie in G3. But as you say, maybe this is due to some Gnome thing that I have installed. Is there some way to do a forensic on this? I mean somehow search a list of dependencies and find where the tug on G3 originates?
rayandrews
Level 2
Level 2
 
Posts: 99
Joined: Sun Jul 10, 2011 8:56 pm

Re: LMDE/XFCE update has gone berserk

Postby zerozero on Wed May 16, 2012 11:13 am

nahh, xfce and gnome share the same repository, so if a particular setup has some gnome dep it will update them to the latest (bring the latest here gnome3 :mrgreen: )

the only option i see is the one i outlined in the post above: uninstall the prime gnome app (with the due attention of course) and try to perform the dist-upgrade after that;
repeat that until you are happy with the result.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6482
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE/XFCE update has gone berserk

Postby rayandrews on Wed May 16, 2012 12:03 pm

zerozero wrote:nahh, xfce and gnome share the same repository, so if a particular setup has some gnome dep it will update them to the latest (bring the latest here gnome3 :mrgreen: )

the only option i see is the one i outlined in the post above: uninstall the prime gnome app (with the due attention of course) and try to perform the dist-upgrade after that;
repeat that until you are happy with the result.


Yikes .... Ok, I'll try to be a man about this, wish me luck.
rayandrews
Level 2
Level 2
 
Posts: 99
Joined: Sun Jul 10, 2011 8:56 pm

Re: LMDE/XFCE update has gone berserk

Postby rayandrews on Fri May 18, 2012 10:23 am

zerorero,

I had some luck, but not much. I'm going to repost my problems in Update/Upgrade issues.

Tx.
rayandrews
Level 2
Level 2
 
Posts: 99
Joined: Sun Jul 10, 2011 8:56 pm


Return to Update Packs Repositories

Who is online

Users browsing this forum: Exabot [Bot] and 2 guests