Cannot rename eth1 back to eth0

Questions about cabled networking
Forum rules
Before you post please read this

Cannot rename eth1 back to eth0

Postby dclement on Sat May 19, 2012 6:10 am

Hello,

My default cable network interface is called eth1 by LMDE (XFCE). That's fine for me and my network is working very well.

However, I have some awkward (proprietary) software (which I have to use for professional reasons) that requires activating, and this process won't complete without an eth0 network interface!

I have found solutions involving the file /etc/udev/rules.d/70-persistent-net.rules. I have tried to edit it and set the name for my ethernet card back to eth0. But no luck, it's still called eth1 when I restart.

What am I missing?

TIA, regards - Daniel
dclement
Level 3
Level 3
 
Posts: 148
Joined: Thu Apr 19, 2012 9:59 am

Linux Mint is funded by ads and donations.
 

Re: Cannot rename eth1 back to eth0

Postby Axzercion on Sat May 19, 2012 9:37 am

You can find the answer at http://www.debianhelp.co.uk/udev.htm
However instead of creating a new file in /etc/udev/rules.d, you can just modify 70-persistent-net.rules (as the file is called on my system)
After that you still need to modify /etc/network/interfaces to reflect the change you've made.
Also in case you cannot ping hostnames on your local domain, modify /etc/nsswitch.conf where you will find a line hosts: files dns, which you will need to modify to: files mdns4_minimal [NOTFOUND=return] dns mdns4

That solved all of my networking problems in LMDE
Axzercion
Level 1
Level 1
 
Posts: 1
Joined: Sat May 19, 2012 9:30 am

[SOLVED] Re: Cannot rename eth1 back to eth0

Postby dclement on Mon May 21, 2012 10:09 am

Thank you Axzercion for the valuable link.

Axzercion wrote:You can find the answer at http://www.debianhelp.co.uk/udev.htm
However instead of creating a new file in /etc/udev/rules.d, you can just modify 70-persistent-net.rules

That was my mistake: I made backups of the original file, but I left them in the same directory (silly me). I'm almost sure that udev was still taking these "backups" files for real.

After that you still need to modify /etc/network/interfaces to reflect the change you've made.

That part of the Debian tutorial caused me some hair-scratching. My eth0 was there (ifconfig confirmed it), but Network Manager kept saying that the wired network card was "not managed".

I finally got this sorted out thanks to this thread (essentially, write managed=true in /etc/NetworkManager/NetworkManager.conf). I believe that if there had been no reference at all to eth0 in /etc/network/interfaces, I wouldn't have had this last problem.

However, I wonder how all this worked, because under system > services, udev is unchecked in my case...
dclement
Level 3
Level 3
 
Posts: 148
Joined: Thu Apr 19, 2012 9:59 am


Return to Ethernet

Who is online

Users browsing this forum: No registered users and 1 guest