Speakers go mute - bug - solved

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Speakers go mute - bug - solved

Postby Bonsaii on Wed May 23, 2012 9:09 am

Hi,

On a fresh installation LMDE 20124 Mate/Cinnamon on a Thinkpad T410s the internal speakers go mute.
This happens with evolution notification sounds, flash videos in Firefox, during Skype calls or videos played in VLC or MPlayer.
After reboot the speakers work for a while, then they go mute again.

Initially the same happened with the headset.
After installing Pavucontrol, Pavumeter, etc. the sound on the plugged in headset works.

Nothing is muted in Alsamixer or Gnome Mixer.
Gnome Mixer only recognizes the HDMI soundcard.
And funny enough, Pavumeter shows sound being played,
but the speakers don't make a sound.

Does anyone have an idea, what I am missing?
Thanks in advance!

PS: No, I do not want to switch to XFCE/KDE/etc and I do not want to remove pulseaudio completely.

Update:
Removing mono is one solution.
According to quite a few forum posts elsewhere,
Banshee does not work well with gnome3 and
leads to hangups and freezes and mute speakers.

Update2:
If you install the Thinkpad specific packages from
the Software Manager: tpd, hdapsd, tp-smapi-source,
tp-smapi- dkms, you get a virtual soundcard.
This soundcard is not recognized by pulseaudio.
Pulseaudio 2.0 ignores it.

Removing the complete Mate desktop and all
its config files solved ALL remaining sound problems.
It runs perfectly well now.

Update3:
I was able to reproduce the problem by
installing PulseAudio Preferences and
adding a virtual device for multiple output.
When two sounds are played (like music and
an email notification, or a sound event while
doing a Skype call) the speakers go mute.

Removing "tbd" (a Thinkpad special keys program)
solved the problem somewhat

Update 4:
I gave up and changed the motherboard.
What a nice disaster that was.
Last edited by Bonsaii on Mon Nov 26, 2012 10:23 am, edited 5 times in total.
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am

Linux Mint is funded by ads and donations.
 

Re: Speakers go mute (solved)

Postby Bonsaii on Wed Jun 20, 2012 4:27 am

Last but perhaps most important:

In Firefox -> Preferences -> Advanced -> General

do NOT select "Use hardware acceleration when available"

This solved all problems with online video,
playing flash, etc.
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am

Re: Speakers go mute (solved)

Postby Bonsaii on Sun Jun 24, 2012 3:18 pm

Out of curiosity, I tested it again.

The problem is caused by Pulseaudio.
Removing it solved the problem.

Unfortunately, PulseAudio is integrated into Cinnamon,
so the removal isn't really an option.
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am

Re: Speakers go mute again

Postby Bonsaii on Fri Jul 06, 2012 4:05 pm

Did LMDE change anything?

I did an "sudo upgrade-system" and the sound problem is back.
After 2-5 Minutes of playing music, video or Skype, the speakers go mute.
Here is system info:
lspci -nn | grep -i audio
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b57] (rev 06)

lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
Subsystem: Lenovo Device 215e
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at f2520000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06) (prog-if 00 [Normal decode])

Sometimes, rarely, I hate sound in linux!

Here are xsession error messages (without the tons of clutter warnings), in case it helps, :
Code: Select all
    JS ERROR: !!!   WARNING: 'anonymous function does not always return a value'
    JS ERROR: !!!   WARNING: file '/usr/share/cinnamon/applets/window-list@cinnamon.org/applet.js' line 377 exception 0 number 157
      JS LOG: Cannot find connection for active (or connection cannot be read)

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported
** Message: applet now embedded in the notification area
/usr/lib/linuxmint/mintUpdate/mintUpdate.py:1781: GtkWarning: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
  gtk.main()
      JS LOG: Cannot find connection for active (or connection cannot be read)

** (nautilus:2207): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (nautilus:2207): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (nautilus:2207): WARNING **: Can not get _NET_WORKAREA

** (nautilus:2207): WARNING **: Can not determine workarea, guessing at layout

(gnome-settings-daemon:2009): updates-plugin-WARNING **: failed to get upgrades: Timeout was reached

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported

(cinnamon:2172): St-WARNING **: percentage lengths not currently supported
[0x22ed108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Window manager warning: Log level 16: STACK_OP_ADD: window 0x2600009 already in stack
Window manager warning: Log level 16: STACK_OP_ADD: window 0x2600009 already in stack

(cinnamon:2172): Clutter-CRITICAL **: clutter_actor_queue_relayout: assertion `CLUTTER_IS_ACTOR (self)' failed
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
[0x23fd108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Window manager warning: Invalid WM_TRANSIENT_FOR window 0x2600006 specified for 0x260000f (Privacy an).
Window manager warning: Log level 16: STACK_OP_ADD: window 0x2600017 already in stack
Window manager warning: Log level 16: STACK_OP_ADD: window 0x2600017 already in stack

(cinnamon:2172): Clutter-CRITICAL **: clutter_actor_queue_relayout: assertion `CLUTTER_IS_ACTOR (self)' failed
[0x1014108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Window manager warning: Log level 16: STACK_OP_ADD: window 0x2600009 already in stack
Window manager warning: Log level 16: STACK_OP_ADD: window 0x2600009 already in stack


Any help is appreciated.

Update:
/etc/asound.conf had been removed. Restoring it solved part of the problem.
Playing music or video remains flawed. After a minute or two the speakers
go mute.
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am

Re: Speakers go mute

Postby Bonsaii on Sun Jul 08, 2012 6:10 pm

Update:

My first mistake was:

Both, mplayer and mplayer2 were installed.

removing mplayer lead to a new xsession-error message,
the gstreamer-plugin-crystalHD bug.
So I removed that plugin.

But the problem remains. :-(

x-error message is among others:

Code: Select all
(gnome-settings-daemon:2029): PackageKit-WARNING **: couldn't parse execption 'GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code4: GetDistroUpgrades not supported by backend', please report

To which I found nothing online.
Thanks for your attention.
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am

Re: Speakers go mute - bug

Postby Bonsaii on Sat Nov 10, 2012 6:50 pm

This is a bug, and neither a new one, nor rare.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/761171

http://www.spinics.net/linux/fedora/alsa-user/msg11219.html

It was assigned to the "genial" developer of pulseaudio, Mr. Lennart Poettering:

https://bugzilla.redhat.com/show_bug.cgi?id=849194

the guy who is breaking your audio for almost a decade.
What could possibly go wrong???
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 88
Joined: Sat Oct 09, 2010 8:49 am


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 1 guest