shortcut keys?

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

shortcut keys?

Postby anderigs on Wed Mar 14, 2012 12:16 pm

I am still a bit of a cinnamon newbie - spent most of my LM12 life using fluxbox but after just reading a rave review of cinnamon in linux mag I decided to give it a spin and LOVE it. Seems to be the perfect mix between glamour & usability.
But I can't find out how to define shortcut keys. I use these all the time for the most regular used apps.
The settings used by gnome3 don't seem to work.
Thanks for any tips.
Cheers
andE
anderigs
Level 2
Level 2
 
Posts: 50
Joined: Mon Dec 28, 2009 5:54 am

Linux Mint is funded by ads and donations.
 

Re: shortcut keys?

Postby xenopeek on Wed Mar 14, 2012 2:08 pm

Menu > Preferences > Keyboard > Shortcuts tab :wink:
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14891
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: shortcut keys?

Postby RHTopics on Wed Mar 14, 2012 2:14 pm

Vincent beat me to it, but I added a little more explanation.

One way to get to the Keyboard dialog window is to select it from the Menu -> Preferences -> Keyboard.

Click on the Shortcuts tab and then click the "Custom Shortcuts" from the list on the left side of the dialog window.

Click the "+" sign to add a new custom shortcut.

I am using the "Ctrl" + "Alt" keys to assign a shortcut to a keyboard letter (i.e. Firefox is Ctrl+Alt+F)
RHTopics
Level 1
Level 1
 
Posts: 34
Joined: Fri Sep 10, 2010 2:32 pm

Re: shortcut keys?

Postby mojosmail2003 on Thu Mar 15, 2012 7:54 pm

Speaking of shortcuts... Do you know if it is possible to add shortcuts to the snap the windows to either left or right (previously used compiz to obtain this), thus without using the mouse. For some reason this does not seem to be an option in the keyboard menu?
mojosmail2003
Level 1
Level 1
 
Posts: 10
Joined: Tue Feb 28, 2012 4:41 pm

Re: shortcut keys?

Postby anderigs on Thu Apr 05, 2012 12:04 pm

hi
I had actually found this but it hadn't worked for me. This is cos I always use Mod4 (windows or super key) for my shortcuts.
For some reason this doesn't work. E.g. Mod4+F does not open firefox. Looks like something else is snapping up the Mod4 before cinnamon can process it. This is strange as in fluxbox this worked all the time.
I checked and if I do ALT+F it does work. So thanks for the pointer but is this Mod4 limit a bug or a feature?
Cheers,
andE
anderigs
Level 2
Level 2
 
Posts: 50
Joined: Mon Dec 28, 2009 5:54 am

Re: shortcut keys?

Postby igel_au on Thu Apr 05, 2012 11:01 pm

I'm suffering the same issue with Mod4 (Win/Super/Hyper) shortcuts not working. It works fine if the shortcut is default (e.g. Mod4-D for show desktop), but some newly-created ones don't run properly.

For example, I can change Terminal from <ctrl><alt>T to <Mod4>T and it works fine. I can also launch Home Folder by <ctrl><alt>E, or even <Mod4>T which worked for Terminal.

I've tested creating a custom shortcut for
Code: Select all
nautilus ~
as well as Launcher > Home folder, and if you're looking at the desktop something like the edge of a window appears in the bottom left. I'm too slow to launch looking-glass to see what it is, unfortunately.

Running x64 Mint 12 cinnamon. Hope this extra information might help someone find a solution. Or at least what the actual problem is.
igel_au
Level 1
Level 1
 
Posts: 5
Joined: Thu Apr 05, 2012 10:34 pm

Re: shortcut keys?

Postby anderigs on Fri Apr 06, 2012 7:12 am

Hi
ok, thanks to a archlinux buddy I worked out a cinnamon adapted solution based on:
https://bbs.archlinux.org/viewtopic.php ... 31#p929631

Soooooo, we need to disable [super] as the muffin (cinnamon's window manager) overlay key:

Start gconf-editor and set /apps/muffin/general/overlay_key to empty string, then restart gnome-shell (easiest & surest way is to reboot but logout/in should also be enough).

Worked for me anyway - hope this helps and doesn't break something else ;-)
anderigs
Level 2
Level 2
 
Posts: 50
Joined: Mon Dec 28, 2009 5:54 am

Re: shortcut keys?

Postby igel_au on Fri Apr 06, 2012 7:40 pm

anderigs wrote: hope this helps and doesn't break something else ;-)


That works great! only problem is that the mint menu doesn't open with the Super key... which I'm guessing is exactly what we just turned off?

Is there a way to set super_L as the shortcut to open the mint menu a different way, say using the keyboard shortcuts box? I have no idea if there's even a command line way to open it.
igel_au
Level 1
Level 1
 
Posts: 5
Joined: Thu Apr 05, 2012 10:34 pm

Re: shortcut keys?

Postby scimor5 on Sun Apr 15, 2012 5:37 pm

I'm having the same problem except anything with numbers in it ( ctrl+alt+1 ) doesn't do anything.
scimor5
Level 1
Level 1
 
Posts: 1
Joined: Sun Apr 15, 2012 5:34 pm

Re: shortcut keys?

Postby Unlimited2K11 on Thu May 24, 2012 12:12 pm

Hey,
just upgraded to LM13 and my beloved Super+D-shortcut won't work anymore... I already tried anderigs' solution with the gconf-editor - after that, the mint-menu won't open after super-key-press anymore, but I still get a little inputbox in the lower right, wenn hitting super+<some_key>...

Any new ideas anybody? :)
Unlimited2K11
Level 1
Level 1
 
Posts: 6
Joined: Sat Nov 26, 2011 4:05 pm

Re: shortcut keys?

Postby totalizator on Sun Jun 17, 2012 2:26 pm

Unlimited2K11 wrote:Hey,
just upgraded to LM13 and my beloved Super+D-shortcut won't work anymore... I already tried anderigs' solution with the gconf-editor - after that, the mint-menu won't open after super-key-press anymore, but I still get a little inputbox in the lower right, wenn hitting super+<some_key>...

Any new ideas anybody? :)


Finally got it working:

1) Alt+F2
2) gconf-editor
3) app->metacity->global_keybindings
4) add show_desktop with text value <Super>d
totalizator
Level 1
Level 1
 
Posts: 1
Joined: Sun Jun 17, 2012 2:22 pm

Re: shortcut keys?

Postby occulens on Tue Jun 26, 2012 6:16 pm

I can confirm that the instructions above work.

I would also like to add that by using the gconf-editor, there is a way to make <Super>f open Firefox:

1) in apps > metacity > global_keybindings,
set run_command_1 to <Super>f

2) in apps > metacity > keybinding_commands,
set command_1 to firefox

Hope this Helps!
occulens
Level 1
Level 1
 
Posts: 3
Joined: Tue Jun 26, 2012 5:57 pm

Re: shortcut keys?

Postby jerkey on Thu Nov 29, 2012 5:53 pm

I don't seem to have gconf-editor. Is there another way to activate the menu key with a keyboard shortcut?
jerkey
Level 1
Level 1
 
Posts: 3
Joined: Wed Nov 28, 2012 6:20 pm

Re: shortcut keys?

Postby pindar on Mon Dec 03, 2012 6:23 am

I would like to ask the same question. The instructions given above do not work with newer versions of cinnamon. So: how can I set a shortcut key to bring up the Mint menu (and allow me to type into the "Search" box of the window so I can start applications without having to use the mouse).

Thanks!

pindar
pindar
Level 1
Level 1
 
Posts: 10
Joined: Mon Dec 03, 2012 6:19 am

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: No registered users and 4 guests