[SOLVED] No/Slow Wireless Lenovo B570

Questions about WIFI networks and devices
Forum rules
Before you post please read this

[SOLVED] No/Slow Wireless Lenovo B570

Postby yoyo58 on Thu May 24, 2012 10:34 pm

Greetings

When I run Mint 13 32bit Cinnamon live USB, my wireless connection very slow or non-existent.

Here's the requested output.

mint@mint ~ $ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
-------------------------
* I. scanning WIFI PCI devices...
-- Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
==> PCI ID = 168c:002b (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"JohnsonNetwork3"
Mode:Managed Frequency:2.412 GHz Access Point: 00:1D:7E:98:33:7B
Bit Rate=135 Mb/s Tx-Power=14 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-32 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:35 Invalid misc:79 Missed beacon:0

eth0 no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr f0:de:f1:82:9e:c3
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:42 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3194 (3.1 KB) TX bytes:3194 (3.1 KB)

wlan0 Link encap:Ethernet HWaddr d0:df:9a:ed:ce:0a
inet addr:192.168.1.107 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::d2df:9aff:feed:ce0a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:136 errors:0 dropped:0 overruns:0 frame:0
TX packets:224 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:71775 (71.7 KB) TX bytes:32848 (32.8 KB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 75.75.75.75
Address: 75.75.75.75#53

Non-authoritative answer:
Name: google.com
Address: 74.125.137.100
Name: google.com
Address: 74.125.137.101
Name: google.com
Address: 74.125.137.139
Name: google.com
Address: 74.125.137.102
Name: google.com
Address: 74.125.137.113
Name: google.com
Address: 74.125.137.138

mint@mint ~ $


and this is the hardware from my working Mint 11 install



I would appreciate any help you can provide.

Thank you.
Last edited by yoyo58 on Wed Nov 21, 2012 5:32 pm, edited 2 times in total.
yoyo58
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 17, 2012 12:14 pm

Linux Mint is funded by ads and donations.
 

Re: No/Slow Wireless Lenovo B570

Postby yoyo58 on Thu May 24, 2012 10:38 pm

oops, let's try again

bill@bill-Lenovo-B570 ~ $ inxi
CPU[-Dual core Intel Pentium B950 (-MCP-) clocked at 800.000 Mhz-] Kernel[-2.6.38-8-generic-pae i686-] Up[-26 min-] Mem[-780.3/2924.0MB-] HDD[-320.3GB(3.7% used)-] Procs[-166-] Client[-Shell-] inxi[-1.4.23-]
bill@bill-Lenovo-B570 ~ $
yoyo58
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 17, 2012 12:14 pm

Re: No/Slow Wireless Lenovo B570

Postby yoyo58 on Wed Nov 21, 2012 5:19 pm

I found a solution online to my wireless connection problem. I took the following steps.

open terminal
sudo rmmod ath9k
sudo modprobe ath9k nohwcrypt=1

I had a stable connection, so I made this fix permanent by doing the following.

in terminal, gksu gedit
this will launch the editor in superuser mode
type the following into the new document: options ath9k nohwcrypt=1
the file needs to be saved to the appropriate location. i did it this way.

file, save as
in the left panel, double click on File System
in the right panel, double click on etc
in the right panel, scroll down and double click on modprobe.d
name the file ath9k.conf and click on save

this worked beautifully for me.

here is the link where i found my solution.

http://my1.fr/blog/how-to-fix-packets-l ... ntu-12-04/
yoyo58
Level 1
Level 1
 
Posts: 3
Joined: Tue Apr 17, 2012 12:14 pm


Return to Wireless

Who is online

Users browsing this forum: No registered users and 4 guests