Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixed)

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixed)

Postby ammon on Thu May 10, 2012 2:19 pm

***UP4***

## Update 1 ; just never version of compat-wireless

## Update 2; new version of compat-wireless (3.5-3)
Anyway, for start make sure that you have all build-essentials and headers for you current kernel, which is 3.2 for latest UP4.

We will compile compat wireless from kernel 3.5 (so this is update of wireless stack too), this version worked for me and it is just fine.

1) Download compat-wireless

Use your favorite browser and http://www.orbit-lab.org/kernel/compat- ... sn.tar.bz2 / save it wherever you want.

Or simple

2) Now extract the archive

tar jxvf compat-wireless-*tar.bz2


3) Open terminal in compat-wireless directory:

cd compat-wireless-*


3) Download needed patches:



4) Apply the patch:

patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch


5) Compile/Install

make clean
make
sudo make install


Now, easiest way is to reboot.

Enjoy working aircrack-ng/updated wifi drivers.

If you have any trubles/questions post here I will help if I can.
Last edited by ammon on Thu Aug 09, 2012 12:57 am, edited 4 times in total.
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Linux Mint is funded by ads and donations.
 

Re: Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixe

Postby noah++ on Sun May 27, 2012 3:10 am

Thanks, pal! I used your howto to grab a fresher RTL8187 wireless driver. The one in 3.2.9 is awful. The new one seems fine so far.

For posterity, I would only change your post to instruct us to recurse from the http://www.orbit-lab.org/kernel/compat-wireless-3-stable/ directory to find the latest tarball, instead pointing us directly to that particular 3.3 subdirectory. Someone using your howto probably wants to be on the bleeding edge. In fact, 3.4 is already available there, and that's what I downloaded. (It's unfortunate there's no 'latest' symlink there!)
noah++
Level 1
Level 1
 
Posts: 14
Joined: Wed Nov 03, 2010 10:10 pm

Re: Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixe

Postby ammon on Sun May 27, 2012 2:03 pm

Hello, I'm glad I helped.

It is not nice to point people to bleeding edge tarball, because sometimes it can fail to build or be unstable.

There is my reason to use "stable" tarball.

I will update my guide to 3.4 when it reaches .1 (3.4.1) :)
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Re: Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixe

Postby ammon on Thu Jun 28, 2012 9:02 am

Update to newer compat-wireless, dropped redundant patch.
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Re: Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixe

Postby fluffernutjob on Thu Jul 12, 2012 3:43 pm

Sorry for the basic question, but what is LMDE? Your post is a very detailed explanation of a problem I want to solve and I want to make sure my setup is compatible.
fluffernutjob
Level 1
Level 1
 
Posts: 6
Joined: Thu Apr 19, 2012 2:13 am

Re: Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixe

Postby ammon on Thu Aug 09, 2012 12:57 am

Bump,

Update to 3.5
User avatar
ammon
Level 1
Level 1
 
Posts: 24
Joined: Sun Jul 24, 2011 9:12 am

Re: Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixe

Postby shideneyu on Sat Nov 24, 2012 9:50 am

Hi,

Thanks I followed this tutorial for my Awus036h.
I would like to know, How can I be sure that after the "make install", this is the new drivers that are being used and not the former one?
shideneyu
Level 1
Level 1
 
Posts: 14
Joined: Tue Oct 23, 2012 3:12 pm

Re: Patched Compat-wireless in LMDE (aircrack-ng mon -1 fixe

Postby scorpicus on Wed May 22, 2013 1:22 pm

Thanks for this great solution!also you can check what driver you're using in system profiler(if you're using cinnamon LMDE)
You say the patch is redundant,so there is no need to install it?
scorpicus
Level 1
Level 1
 
Posts: 1
Joined: Fri Feb 15, 2013 2:07 pm

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 1 guest