USB auto-mount issue [SOLVED]

Forum rules
Before you post please read this

USB auto-mount issue [SOLVED]

Postby Manatee on Tue Jun 05, 2012 6:02 pm

Good evening!

I have a small problem with auto-mounting USB drives on Linux Mint 9 Xfce. I did a lot of forum searching, and this doesn't seem to be an uncommon problem. Unfortunately, I couldn't seem to find a reliable solution. More specifically, this might be an issue with Thunar, as the USB-drive itself is recognized (say by "Gigolo" or "system menu -> storage media") and can be mounted manually, but Thunar will not display the drive.

So in an attempt to fix this, I installed the package "usbmount" (see details here).

This was successful (in parts), as USB drives are now being auto-mounted and Thunar recognizes and displays them. However, when trying to manually unmount them via r-click in Thunar, I get a message saying that this can't be done, possibly because mounting was done via command line. "Remove safely" in the storage media menu didn't work either, but at least the unmount button there worked.

So now I'm a bit at a loss when it comes to removing USB drives safely. While the package description says un-mounting is done automatically on removal, I'm not exactly sure whether this means safe removal.

As you can probably tell from this post, I don't work with Linux very regularly. In case someone happens to have an idea, please keep in mind that I'm still making my first steps here.
Last edited by Manatee on Sat Jun 16, 2012 7:24 am, edited 1 time in total.
Manatee
Level 1
Level 1
 
Posts: 16
Joined: Thu Mar 03, 2011 8:32 am

Linux Mint is funded by ads and donations.
 

Re: USB auto-mount issue

Postby dajare on Wed Jun 06, 2012 11:08 am

I'm a very long way from knowledgeable about this myself, but have experienced some USB mount/unmount flakiness in the past. However, ever since I started using the Disk Utility, USB unmount and removal has not been a problem. Might also work for you?
dajare
Level 1
Level 1
 
Posts: 32
Joined: Thu Apr 05, 2012 5:02 pm
Location: Edinburgh, UK

Re: USB auto-mount issue

Postby edwardr on Thu Jun 07, 2012 1:18 pm

There is a bug in Mint 9 XFCE with automounting USB drives. When you installed Mint XFCE, did you choose the option during the installation to auto-login without without a password (when you turn on your computer does Mint boot up without you ever seeing a login screen or having to enter your password)? Try this and see if it works: Turn on the computer and boot in to Mint XFCE like you normally do. Uninstall "usbmount". Shut down and restart the computer to get back into Mint Xfce. Then Log out of XFCE (not turn off, just log out). At the log in screen, click on your name and enter your password to log back in to XFCE. Try to plug in a USB drive now and see if it appears.

If this works, one workaround is to change the settings to require the log in screen, but set your user id to log in automatically with a 2 or 1 second delay. This will only add a couple of seconds to your boot time, but it should be a work around for the problem you described.
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
User avatar
edwardr
Level 4
Level 4
 
Posts: 221
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: USB auto-mount issue

Postby edwardr on Thu Jun 07, 2012 1:20 pm

Note also that Clem says they are working on an Xfce version of Mint 13, which should not have that bug.
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true
User avatar
edwardr
Level 4
Level 4
 
Posts: 221
Joined: Thu Jun 03, 2010 1:09 pm
Location: USA - Texas

Re: USB auto-mount issue

Postby Manatee on Sat Jun 09, 2012 1:31 am

Hello again!

I just wanted to drop a quick thank you and let you know I'm (theoretically) still working on this. Unfortunately I didn't have the time to fiddle with Disk Utility, over the last two days.
However, I'm definitely using the proper log-in already, so that isn't the cause of the problem. I also wasn't aware that an Xfce version of Mint 13 had already been released. Looking at the Maya editions right now, I can only see MATE and Cinnamon versions. Unfortunately those are a bit too resource-intensive for this fairly aged PC.
Manatee
Level 1
Level 1
 
Posts: 16
Joined: Thu Mar 03, 2011 8:32 am

Re: USB auto-mount issue

Postby dajare on Sat Jun 09, 2012 6:21 am

Manatee wrote:... I also wasn't aware that an Xfce version of Mint 13 had already been released. ...


It has not yet been released, but I'm very much looking forward to trying it when it appears.

I'm currently on LM 12 LXDE, which is great on this old laptop. I'm hoping the LM 13 Xfce LTS will work equally well, in which case it will probably be the last OS this laptop ever gets!
dajare
Level 1
Level 1
 
Posts: 32
Joined: Thu Apr 05, 2012 5:02 pm
Location: Edinburgh, UK

Re: USB auto-mount issue

Postby Manatee on Sat Jun 16, 2012 7:23 am

Short update:

I finally found the time to try and fiddle with this problem again, and as suggested by dajare, I uninstalled "usb-mount". When looking for the "gnome-disk-utility" package, I noticed this was already installed. From what I can tell, it came with the standard distro.
Next thing, I plugged in an usb-stick to see which settings might help auto-mounting it. To my surprise, I didn't have to do anything at all. It was auto-mounted and showed up in Thunar, and could also be un-mounted from there without problems. Goes without saying that I am at a complete loss as to what happened there, and why it suddenly worked when before it didn't - without me really contributing anything to this rather fantastic change (as far as I can tell).

In any case, I wanted to say thank you for the help again, and I hope things continue working this way.
Manatee
Level 1
Level 1
 
Posts: 16
Joined: Thu Mar 03, 2011 8:32 am

Re: USB auto-mount issue [SOLVED]

Postby jjaythomas on Sat Jun 16, 2012 9:52 pm

Just seen this...

Haven't used that version (LMint9) for awhile (on LMDEish currently).
It was probably a dependency of usb-mount you needed. If curious you can maybe find in synaptic (look at dependencies for package). I once had to install 'pcmanfm' (had no idea what dependency needed :oops: ) and uninstall 'pcmanfm' for something to work right in thunar (was on Xubuntu I think).

P.S. There's usually a menu>settings>removable drives and media, first tab list option to "mount removable media when inserted' that may do the trick also :wink:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: USB auto-mount issue [SOLVED]

Postby JonoClouds on Fri Nov 02, 2012 8:00 am

In Linux Mint 13 Maya, the autostart settings for removable drives are at:
System Tools - System Settings - Details - Removable Media.

I had to search about for quite a while to find it. I needed to stop it running two instances of VLC player each time I inserted an audio CD. Why it started two, I still don't know.
JonoClouds
Level 1
Level 1
 
Posts: 1
Joined: Fri Nov 02, 2012 7:56 am

Re: USB auto-mount issue [SOLVED]

Postby jjaythomas on Fri Nov 02, 2012 11:48 am

In Linux Mint 13 Maya, the autostart settings for removable drives are at:
System Tools - System Settings - Details - Removable Media.

Not Xfce (unless have other DE installed also :roll:
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: USB auto-mount issue [SOLVED]

Postby NOB on Wed Nov 14, 2012 11:04 am

jjaythomas wrote:
In Linux Mint 13 Maya, the autostart settings for removable drives are at:
System Tools - System Settings - Details - Removable Media.

Not Xfce (unless have other DE installed also :roll:


Xfce: Settings / Removable Drives and Media

HTH

Norbert.
NOB
Level 1
Level 1
 
Posts: 19
Joined: Sun Sep 30, 2012 4:31 am

Re: USB auto-mount issue [SOLVED]

Postby jjaythomas on Thu Nov 15, 2012 12:28 am

Xfce: Settings / Removable Drives and Media

Yes
But I got impression the problem was the showing (mounting) and unshowing (unmounting) in thunar.
That bug (If remember) a CD icon even after un-mounting stayed on desktop and thunar (annoying but livable) till reboot or another CD Mounted/unmounted manually. :roll:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 0 guests