Firefox not saving a setting

Questions about applications and software
Forum rules
Before you post please read this

Firefox not saving a setting

Postby takis123 on Sat Jun 02, 2012 5:33 pm

Screenshot:
http://i.imgur.com/tXZSo.png

I clicked on "Quit" and "Do not show again" on the dialog window appeared when I've tried to close a firefox window with many tabs opened, it showed that dialog again. Then I went at about:config and turned into "false" the option in bold at the screenshot. It does not save that particular preference and continues asking me when I have more than one tabs opened if I want to save them and exit or simply exit and "do not show again" is unchecked. I've uninstalled firefox, deleted firefox's profile, reinstalled via synaptic and the problem persists. Any ideas to solve that problem? Thank you
takis123
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 29, 2012 5:36 pm

Linux Mint is funded by ads and donations.
 

Re: Firefox not saving a setting

Postby 300wm on Sun Jun 03, 2012 10:56 am

type the following into your navigation toolbar:

about:config

then, hit enter. You will see a warning. Click the "I'll be careful...etc." box.
this will take you into the configuration settings of firefox.
Carefully scroll down to the entry that says:

browser.tabs.warnOnClose

double-click this entry and the value will change from true to false.
close the about:config tab.
restart firefox, open a few tabs and then close firefox to test.
300wm
Level 1
Level 1
 
Posts: 1
Joined: Sun Jun 03, 2012 10:44 am

Re: Firefox not saving a setting

Postby takis123 on Sun Jun 03, 2012 11:33 am

Thanks for your help, I've tested it, but it doesn't work. :| I have mint 13 MATE at two laptops and this problem occurs at both of them.
takis123
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 29, 2012 5:36 pm

Re: Firefox not saving a setting

Postby tjr4d on Mon Jun 04, 2012 5:00 pm

I can confirm exactly the same results using Linux Mint 13 x64 and Cinnamon. On the same laptop I checked ubuntu 12.04 and xubuntu 12.04 (all standard x64 images) and this problem is not apparent there. Something unusual to Mint, but in both Cinnamon and MATE flavours.
Hope this helps.
T
tjr4d
Level 1
Level 1
 
Posts: 2
Joined: Sun Jun 14, 2009 1:21 pm
Location: Canada, Vancouver BC

Re: Firefox not saving a setting

Postby redschuart on Sat Jun 09, 2012 8:35 am

takis123 wrote:Screenshot:
http://i.imgur.com/tXZSo.png

I clicked on "Quit" and "Do not show again" on the dialog window appeared when I've tried to close a firefox window with many tabs opened, it showed that dialog again. Then I went at about:config and turned into "false" the option in bold at the screenshot. It does not save that particular preference and continues asking me when I have more than one tabs opened if I want to save them and exit or simply exit and "do not show again" is unchecked. I've uninstalled firefox, deleted firefox's profile, reinstalled via synaptic and the problem persists. Any ideas to solve that problem? Thank you


I am getting exactly the same issue. Linux Mint 13 64bit Cinnamon, I've checked the relevant about:config setting is 'false', uninstalled Firefox and started again from a fresh install and the problem is still there.

This does not happen in Win7 or Fedora 17 - same Firefox version, addons etc, so it looks like it's a Mint only issue.
redschuart
Level 1
Level 1
 
Posts: 7
Joined: Mon Jun 04, 2012 1:31 pm

Re: Firefox not saving a setting

Postby mank_in on Sat Jun 09, 2012 10:01 pm

This is the problem start from LM12

the correct solution is :
browser.warnOnQuit set to false in about:config
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Firefox not saving a setting

Postby rustleg on Sun Jun 10, 2012 2:18 pm

Same here - the about:config setting does not stick. This is definitely a bug.
rustleg
Level 1
Level 1
 
Posts: 36
Joined: Mon Sep 13, 2010 12:37 pm

Re: Firefox not saving a setting

Postby takis123 on Sun Jun 10, 2012 3:48 pm

The problem is what causes it. The first time I've realised that bug, I thought that I had installed something unwanted without noticing it, like a toolbar or something, and changed the default settings. Then I realised that there are many pleople with that problem here, so it is probably a bug. I've got used to it now and it doesn't bother me
takis123
Level 1
Level 1
 
Posts: 43
Joined: Wed Feb 29, 2012 5:36 pm

Re: Firefox not saving a setting

Postby rustleg on Sun Jun 10, 2012 5:03 pm

takis123 wrote:... Then I realised that there are many pleople with that problem here, so it is probably a bug. I've got used to it now and it doesn't bother me

Agreed - not too serious, just annoying. Hopefully it will be fixed eventually but there are probably more important issues to fix.
rustleg
Level 1
Level 1
 
Posts: 36
Joined: Mon Sep 13, 2010 12:37 pm

Re: Firefox not saving a setting

Postby Bolbi on Sat Jun 16, 2012 9:01 am

Same here : using linux mint 13, MATE.
It is definitly annoying.

Maybe we can temporaly fix this by getting the source code and compiling it ourself ? Or installing Ubuntu Package that seems to do not have any bug ?
I wonder if i can downoad that package, because i cannot find source files, and the installation using /opt/ directory didnt work with me.
-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
GMD d- s+: a? C++ UL++ P+ L+++ E W+ N+ o K w
O+++ M+ V-- PS PE Y+ PGP- t+ 5+ X++ R tv b+++ DI D+
G++ e h r- y
------END GEEK CODE BLOCK------
User avatar
Bolbi
Level 1
Level 1
 
Posts: 18
Joined: Sat Jun 16, 2012 8:47 am
Location: Lyon, France

Re: Firefox not saving a setting

Postby maxmm5 on Sun Jul 01, 2012 10:01 am

Hi All, Here's the right procedure to get rid of that message; check the "Do not show again" and hit " Save and Quit", repeat... Save and Quit button and not Quit button. Enjoy, maxmm5
maxmm5
Level 1
Level 1
 
Posts: 6
Joined: Sat Oct 01, 2011 5:34 am

Re: Firefox not saving a setting

Postby rustleg on Mon Jul 02, 2012 5:29 am

maxmm5 wrote:Hi All, Here's the right procedure to get rid of that message; check the "Do not show again" and hit " Save and Quit", repeat... Save and Quit button and not Quit button. Enjoy, maxmm5
We know what the procedure is - the thing is it doesn't work if you don't want tabs to be saved and reopened next time.
rustleg
Level 1
Level 1
 
Posts: 36
Joined: Mon Sep 13, 2010 12:37 pm

Re: Firefox not saving a setting

Postby SciFiDude79 on Mon Jul 16, 2012 11:57 am

mank_in wrote:This is the problem start from LM12

the correct solution is :
browser.warnOnQuit set to false in about:config


Thanks a lot. That worked great in Mint 13 KDE RC. :D To avoid this problem in Mint 12, I just installed Chromium. But I prefer Firefox, so I decided to search the forums for a solution after installing Maya KDE.

rustleg wrote:Same here - the about:config setting does not stick. This is definitely a bug.


It could be a Gnome 3 problem. As I said above, it worked in KDE. I know I've had issues getting settings to work like they should in Gnome 3, which is one reason I don't use it anymore.
User avatar
SciFiDude79
Level 1
Level 1
 
Posts: 29
Joined: Fri Feb 11, 2011 1:39 pm
Location: Ohio

Re: Firefox not saving a setting

Postby ingeva on Wed Jul 18, 2012 4:12 am

takis123 wrote: I clicked on "Quit" and "Do not show again" on the dialog window appeared when I've tried to close a firefox window with many tabs opened, it showed that dialog again.

Fixed with FF14, that arrived today.
Mint rules!
User avatar
ingeva
Level 2
Level 2
 
Posts: 81
Joined: Wed Jun 20, 2012 3:39 am
Location: Sandvika, Norway

Re: Firefox not saving a setting

Postby rijnsma on Fri Jul 20, 2012 4:54 pm

I had the problem in Xubuntu 12.04LTS Xfce ff13 and ff14.
I found this on the web:

Mozilla:
Configuring session restore
By default, when Firefox starts, a single window is opened, displaying your specified home page. If you wish, you can configure Firefox to open all windows and tabs from your previous session:

At the top of the Firefox window, click on the Edit menu and select Preferences
Select the General panel.
From the When Firefox starts drop-down, select Show my windows and tabs from last time.
Note: Unchecking Don't load tabs until selected can make Firefox take longer to start.
Click Close to close the Preferences window
Privacy issues
Session Restore may keep you logged in to sites that you were logged into before you closed Firefox. If someone else used your computer after you, they could access your account on these sites. If this is a concern then you should not configure Firefox to open all windows and tabs from your previous session.

You may also wish to disable the Session Restore crash recovery feature which is enabled by default. This will prevent restoring a previous session when Firefox is opened after an unexpected close or software crash:

In the Location bar, type about:config and press Enter.
The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page.
In the Search box at the top, type browser.sessionstore.resume_from_crash.
In the resulting grid, double-click on browser.sessionstore.resume_from_crash to set it to false.
Troubleshooting
Previous session not correctly closed
To get your tabs and windows back from a previous session, you should close Firefox from the menu: At the top of the Firefox window, click on the File menu and select Quit. If you close each window or tab, only the tabs in the final window that you close are available when you restart Firefox.

Settings may be incorrect
For other session restore problems, you may need to make corrections to your Firefox settings:

At the top of the Firefox window, click on the Edit menu and select Preferences
Select the Privacy panel and make sure Firefox will: is set to either Remember history or Use custom settings for history.
If Firefox will: is set to Use custom settings for history then make sure that Permanent Private Browsing mode is not selected.
If Firefox will: is set to Use custom settings for history and Clear history when Firefox closes is selected, then click the Settings button and make sure that Browsing History is not selected.
Click Close to close the Preferences window



Based on information from Session Restore (mozillaZine KB)

Share this article: You can use the link http://mzl.la/MIUY4q to easily share this article with others. It will display instructions automatically customized for their operating system and language.
Contributors to this page: AliceWyman, Bo102010, Verdi, scoobidiver, Swarnava


And I had no problem any more. :wink:
Qiana.... mind your backup..
User avatar
rijnsma
Level 4
Level 4
 
Posts: 298
Joined: Wed May 06, 2009 7:28 am
Location: NL

Re: Firefox not saving a setting

Postby joachim on Wed Nov 28, 2012 3:56 am

ingeva wrote:
takis123 wrote: I clicked on "Quit" and "Do not show again" on the dialog window appeared when I've tried to close a firefox window with many tabs opened, it showed that dialog again.

Fixed with FF14, that arrived today.


No it isn't. I still have the problem even on Mint 14.

The solution with about:config works while firefox is still open but once you close firefox and restart it freshly the value is set to true again and the dialog appears again.
joachim
Level 1
Level 1
 
Posts: 10
Joined: Sun Sep 30, 2012 4:06 am

Re: Firefox not saving a setting

Postby mrfixit2 on Sun Dec 02, 2012 6:12 pm

Edit: /usr/lib/firefox/defaults/preferences/vendor-firefox.js

Code: Select all
sudo nano /usr/lib/firefox/defaults/preferences/vendor-firefox.js


find
// Save tabs before exiting
Comment out next line
// user_pref("browser.showQuitWarning", true);

When mint-artwork updates you might have to edit again.

Just search for vendor-firefox.js

Last update they moved it
Code: Select all
sudo nano /usr/lib/firefox/browser/defaults/preferences/vendor-firefox.js
mrfixit2
Level 1
Level 1
 
Posts: 1
Joined: Sun Dec 02, 2012 5:18 pm

Re: Firefox not saving a setting

Postby Krotow on Mon Apr 14, 2014 7:34 am

mank_in wrote:This is the problem start from LM12

the correct solution is :
browser.warnOnQuit set to false in about:config


I agree. Setting browser.warnOnQuit to "false" in about:config removed warning dialog on FF close in Mint MATE 15/16 for me.
Krotow
Level 1
Level 1
 
Posts: 2
Joined: Mon Apr 14, 2014 7:29 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: all41, Bing [Bot], Flemur, wuftanoz and 26 guests