<SOLVED> Failed to Start the X server

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

<SOLVED> Failed to Start the X server

Postby voodoojoey on Thu Jun 14, 2012 6:34 pm

I installed Linux Mint 13 Cinnamon 64-bit edition today, with no problems. It told me to restart (fairly typical of an OS installation), so I did. However, every time I've tried to boot it up it's given me the error "Failed to start the x server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the X server output to disclose the problem?

and I get this error code with it:
Code: Select all
ieee 80211 phy0:start:tid 1 is not agg'able


This is the X server output:

Code: Select all
X.Org X Server 1.11.3
Release Date: 2011-12-16
Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
Current Operating System: linux joe-Inspiron-M5010 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
Kernel Command line: Boot_Image=/boot/vmlinuz/3.2.0-23generic root=UUID=38b161a2-33ff-4162-a9da-b07cb9949ae0ro quiet splash
Build Date: 05 April 2012 04:32:37 AM
Xorg-server 2:1.11.4-0ubuntu10. (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.24.4 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==logfile: "/var/log/Xorg.O.log" Time: Thu Jun 14 17:20:12 2012
(==) Using Config file: "/etc/xii/Xorg.conf"
(==) Using system config directory "/usr/share/xii/Xorg.conf.d"
Vesa: Ignoring device with a bound kernel drive
(EE) Screen(s) found, but none have a usable configuration.
Fatal Server Error:
No Screens found.
Please consult the X.org foundation's support at http://wiki.x.org for help. Please also check the log file at "/var/log/Xorg.0.log" for additional information.
xxd Sig Give Up: Closing log
Server terminated with error (1). Closing log file.


I have a Dell Inspiron m5010 laptop, an AMD Phenom(tm) II N930 Quad-Core Processor 2.00 GHz, 4.00 GB of RAM, 64 Bit Operating system, and an ATI Mobility Radeon HD 4250 graphics card. I hope I gave enough information for this problem to be solved, and as I am rather new to linux, all your help is appreciated. Thank you.
Last edited by voodoojoey on Wed Aug 15, 2012 1:15 pm, edited 1 time in total.
voodoojoey
Level 1
Level 1
 
Posts: 4
Joined: Thu Jun 14, 2012 5:18 pm

Linux Mint is funded by ads and donations.
 

Re: Failed to Start the X server (your graphical interface)

Postby steveking on Fri Jun 15, 2012 6:54 am

I shall direct you to this site:

http://markmail.org/message/4guasa4hacbmabny

seems like a kernel bug from my research. hope this helps?
2nd gen core i5 : 8Gb RAM : AMD Radeon HD 6770 1Gb GDDR5 : 1Tb 7500 SATA

cpanel Login - The Easy Way To Log Into Your cPanel Hosting
User avatar
steveking
Level 3
Level 3
 
Posts: 146
Joined: Thu Jun 07, 2012 8:53 am
Location: Shropshire, UK

Re: Failed to Start the X server (your graphical interface)

Postby oobetimer on Fri Jun 15, 2012 6:59 am

I got the same error and I resolved it this way:

1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx
Last edited by oobetimer on Mon Jul 02, 2012 6:31 am, edited 1 time in total.
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Failed to Start the X server (your graphical interface)

Postby WSiaB on Fri Jun 15, 2012 8:27 pm

oobetimer wrote:I got the same error and I resolved it this way:

1. When the message about viewing the X server output came, I pressed Ctrl F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf
4. At last I started X using command startx


oobetimer - you are awesome ( :D ), this also fixed my LinuxMint problem. It would seem to be a problem with X Server, not a kernel problem (I tried Ubuntu but had the same problem on this desktop (but no problems with same spec laptop)).
User avatar
WSiaB
Level 1
Level 1
 
Posts: 2
Joined: Thu Dec 30, 2010 4:57 am
Location: Concord, CA USA

Re: Failed to Start the X server (your graphical interface)

Postby tetraodon on Thu Jun 21, 2012 2:47 am

I just wanted to say thanks!
Your solution worked on HP-Envy 14
tetraodon
Level 1
Level 1
 
Posts: 1
Joined: Thu Jun 21, 2012 2:45 am

Re: Failed to Start the X server (your graphical interface)

Postby nevdelap on Tue Jun 26, 2012 1:36 pm

Thank you. Worked for me too. Asus 1000H.
nevdelap
Level 1
Level 1
 
Posts: 2
Joined: Thu Feb 02, 2012 8:37 pm

Re: Failed to Start the X server (your graphical interface)

Postby realflow100 on Sun Jul 01, 2012 9:56 pm

Please help I tried doing what you said but i couldn't get past the ctrl+F2 thing! (didnt do anything when i pressed it)
realflow100
Level 2
Level 2
 
Posts: 55
Joined: Wed Mar 14, 2012 7:07 pm

Re: Failed to Start the X server (your graphical interface)

Postby oobetimer on Mon Jul 02, 2012 6:32 am

realflow100 wrote:Please help I tried doing what you said but i couldn't get past the ctrl+F2 thing! (didnt do anything when i pressed it)


Sorry.. my typo. It is Ctrl Alt F2
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Failed to Start the X server (your graphical interface)

Postby realflow100 on Mon Jul 02, 2012 4:05 pm

ok now it says command xorg -configure not found?
help me! my computer hates me!!
realflow100
Level 2
Level 2
 
Posts: 55
Joined: Wed Mar 14, 2012 7:07 pm

Re: Failed to Start the X server (your graphical interface)

Postby oobetimer on Mon Jul 02, 2012 4:13 pm

realflow100 wrote:ok now it says command xorg -configure not found?
help me! my computer hates me!!


Xorg -configure

It is a big X.. :wink:
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Failed to Start the X server (your graphical interface)

Postby realflow100 on Mon Jul 02, 2012 4:47 pm

ok i got everything working but now i know for sure the file is in /etc/X11/xorg.conf because i start my PC in recovery mode then start up graphical mode (not using any graphics drivers though because im stuck at low resolution) I go to the folder to look to see if the file is there and it IS there but my computers screen is stuck in 1000x700 (or something around that) screen resolution when my monitor supports 1280x800 but when i go to restart my computer and start up in graphical mode normally i STILL get the same error!
probably exactly the same thing as in the first post of this thread
it says theres a configuration file missing or something (im going to copy and paste a log file or two if thats okay?)
realflow100
Level 2
Level 2
 
Posts: 55
Joined: Wed Mar 14, 2012 7:07 pm

Re: Failed to Start the X server (your graphical interface)

Postby AndroidJunkie on Mon Jul 30, 2012 9:22 pm

oobetimer wrote:I got the same error and I resolved it this way:

1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf


After getting Ctrl Alt F2 to work, I entered sudo Xorg -configure and got

Code: Select all
(EE) open /dev/fb0: No such file or directory
Number of created screens does not match number of detected devices
I only have one screen connected
Code: Select all
Configuration failed
ddxSigGiveUp: Closing log
Server terminated with error (2). Closing log file.


Then I entered
Code: Select all
sudo cp /home/family/xorg.conf.new /etc/X11/xorg.conf

and got
Code: Select all
cp: cannot create regular file '/etc/X11/xorg.conf' : No such file or directory


Any ideas as to what I can to to fix my black screen problem?
AndroidJunkie
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 30, 2012 9:08 pm

Re: Failed to Start the X server (your graphical interface)

Postby oobetimer on Mon Jul 30, 2012 9:32 pm

AndroidJunkie wrote:Any ideas as to what I can to to fix my black screen problem?

You have to login on the new shell after pressing Ctrl Alt F2 and then run sudo Xorg -configure
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Failed to Start the X server (your graphical interface)

Postby AndroidJunkie on Mon Jul 30, 2012 10:34 pm

Yup. I was logged in as well.
AndroidJunkie
Level 1
Level 1
 
Posts: 3
Joined: Mon Jul 30, 2012 9:08 pm

Re: Failed to Start the X server (your graphical interface)

Postby oobetimer on Tue Jul 31, 2012 7:45 am

AndroidJunkie wrote:(EE) open /dev/fb0: No such file or directory
Number of created screens does not match number of detected devices[/code] I only have one screen

It is a bug .. :? https://bugs.launchpad.net/linuxmint/+bug/900246

An alternate way may works? http://www.youtube.com/watch?v=trW4BTFYsIM&feature=plcp
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Failed to Start the X server (your graphical interface)

Postby bluejakky on Wed Sep 26, 2012 7:59 pm

hey, there. Im pretty much a Linux Rookie. And I had the same problem as you did.
Then try to figure out why there's no such file , i typed in : ls
and to my surprise the xorg.conf.new is right there.
so I changed the 2nd code line to : sudo cp xorg.conf.new /etc/X11/xorg.conf
It then worked as a charm !!!
I dont know if you are still using Linux , anyways, best luck.
Hope this would help any1 who suffers from the same problem.



AndroidJunkie wrote:
oobetimer wrote:I got the same error and I resolved it this way:

1. When the message about viewing the X server output came, I pressed Ctrl Alt F2
2. Now on the new shell I ran command sudo Xorg -configure
3. Then I copied /home/oobe/xorg.conf.new to /etc/X11/xorg.conf
sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg.conf


After getting Ctrl Alt F2 to work, I entered sudo Xorg -configure and got

Code: Select all
(EE) open /dev/fb0: No such file or directory
Number of created screens does not match number of detected devices
I only have one screen connected
Code: Select all
Configuration failed
ddxSigGiveUp: Closing log
Server terminated with error (2). Closing log file.


Then I entered
Code: Select all
sudo cp /home/family/xorg.conf.new /etc/X11/xorg.conf

and got
Code: Select all
cp: cannot create regular file '/etc/X11/xorg.conf' : No such file or directory


Any ideas as to what I can to to fix my black screen problem?
bluejakky
Level 1
Level 1
 
Posts: 1
Joined: Wed Sep 26, 2012 7:52 pm

Re: <SOLVED> Failed to Start the X server

Postby josephpmh on Sat Sep 29, 2012 9:31 am

Copy Xorg.conf into /etc/X11 didn't work for me, either. I suspect that that's because I have an NVIDIA driver.

What DID work is this:

Code: Select all
sudo mdm stop

Code: Select all
cd [the directory where I extracted the NVIDIA driver installer]

In my case, I found it in my Downloads directory.
Finally:
Code: Select all
./NVIDIA*.run


Hope this works for you.
josephpmh
Level 1
Level 1
 
Posts: 8
Joined: Wed Dec 07, 2011 10:50 pm
Location: Kensington, MD

Re: <SOLVED> Failed to Start the X server

Postby dvdrev on Mon Nov 26, 2012 1:47 pm

I have the same problem but I'm using Linux 8 on a Dell Precisioin M4300.
Its a work laptop so I am not sure if anyone tampered with it but it was working fine and then one day it gave me the same xserver error as described in the first post.
I have tried the steps described above but when I type in the command: sudo Xorg -configure, I get a "Missing output divers. Configuration failed." message.
I tried continuing on with the next steps (sudo cp /home/oobe/xorg.conf.new /etc/X11/xorg/conf) and just got a message saying that no such directories existed
Any help as to what I am doing wrong or what might be the problem would be much appreciated. Thanks!
dvdrev
Level 1
Level 1
 
Posts: 1
Joined: Mon Nov 26, 2012 1:38 pm

Re: <SOLVED> Failed to Start the X server

Postby remoulder on Mon Nov 26, 2012 1:55 pm

dvdrev wrote:using Linux 8

If you are referring to linuxMint 8 then this version is long since obsolete and no longer supported.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: <SOLVED> Failed to Start the X server

Postby Zayofethos on Mon Nov 26, 2012 3:47 pm

Hey guys,

I have the same message popping up as well.

Failed to start X server (your graphical interface). It is likely that it is not set up correctly. Would you like to view the x server output to diagnose the problem? Yes - No


After I click "Yes" the next window reads as follows:

x.org x server 1.13.0
release date 2012-09-05
x protocol version 11, revision 0
build operating system: linux 3.2.0-26-generic i686 ubuntu
current operating system: linux 1225c 3.5.0-17-generic #28-ubuntu SMP
tue oct 9 19:32:08 UTC 2012 i686
kernel command line: BOOT_IMAGE=/vmlinuz-3.5.0-17-generic
root=UUID=894b4915-4f89-48b5-bb14-69329e1aac15 ro quiet splash
vt.handoff=7
build date: 08 october 2012 03:34:08pm
xorg-server 2:1.13.0-0ubuntu6 (for technical support please see http://www.ubuntu.com/support)
current version of pixman: 0.26.0
before reporting problems, check http://wiki.x.org to make sure you have the latest version.

<Ok>


However, this is where the machine just freezes and won't budge anywhere. A restart has to be done via the main power button.

Upon restarting and having chosen Linux Mint 14 from the boot menu (vs. Win7) the next window reads this:

gnu grub version 2.00-7ubuntu11

linux mint 14 mate 32 bit 3.5.7-17-generic (/dev/sda3)
linux mint 14 mate 32 bit 3.5.7-17-generic (/dev/sda3) -- recovery mode
memory test(memtest86+)
memory test(memtest86+, serial console 115200)
windows 7 (loader) (on /dev(sda1)


Use the "up arrow" and "down arrow" keys to select which entry is highlighted
press enter to boot the selected OS, "e" to edit the commands before booting or "c" for a command line.


If I choose the first option, we end up as before with the Xorg error and a frozen screen. The second option, recovery mode, brings to the recovery menu, from where I choose resume boot. This displayes the following:

You are now going to exit the recovery mode and continue the boot sequence. Please note that some graphic drivers require a full graphical boot and so will fail when resuming from recovery. If that's the case,simply reboot from the login screen and the perform a sandard boot.

This is my first step into Linux and I have no idea if the fact that I installed both Win7 and Mint 14 in the same machine makes any difference. Win7 boots just fine, no errors anywhere. Any ideas?

EDIT: Forgot to say that I actually manage to always boot into Mint through the recovery mode and so far the OS has been working OK, but it's a real hassle to always boot in the midst of a jungle of error messages..
Zayofethos
Level 1
Level 1
 
Posts: 21
Joined: Sun Nov 18, 2012 6:44 am

Linux Mint is funded by ads and donations.
 
Next

Return to Installation & Boot

Who is online

Users browsing this forum: all41, inate71 and 17 guests