[Semi-Solved] Cannot Enable Mint 13 Startup Splash

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read this

[Semi-Solved] Cannot Enable Mint 13 Startup Splash

Postby RobertLM78 on Thu Jun 28, 2012 2:31 pm

I was trying to get the mint-logo on startup using the guide on the Mint 13 Release Notes page:

Black splash screen

In Linux Mint the boot splash screen is completely black. This is by design. Once the system is installed the boot sequence is relatively fast. The black loading sequence doesn't look out of place and it looks consistent across all computers, whatever driver you're using. If you'd rather get a splash screen you can select one by typing the following command and selecting mint-logo:

Code: Select all
 sudo update-alternatives --config default.plymouth


But I still get a black screen on booting :( :roll: . It's not a top priority, but it would be nice to see some activity on startup rather than a black screen :) .
Last edited by RobertLM78 on Mon Jul 16, 2012 1:55 pm, edited 2 times in total.
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 159
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Linux Mint is funded by ads and donations.
 

Re: Cannot Enable Mint 13 Startup Splash

Postby jazz.h on Thu Jun 28, 2012 2:50 pm

Try with Grub Customizer. Search the forum with these terms. Upon installing, try to set the option "splash" to get the splash screen while booting...
jazz.h
Level 4
Level 4
 
Posts: 235
Joined: Sat Jun 18, 2011 7:13 am

Re: Cannot Enable Mint 13 Startup Splash

Postby RobertLM78 on Thu Jun 28, 2012 2:55 pm

jazz.h wrote:Try with Grub Customizer. Search the forum with these terms. Upon installing, try to set the option "splash" to get the splash screen while booting...

I might very well be mistaken, but I don't think Grub and a system startup splash are related.
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 159
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Re: Cannot Enable Mint 13 Startup Splash

Postby jazz.h on Thu Jun 28, 2012 2:59 pm

They are related, as long as you're satisfied with static images (without any kind of animations)...
jazz.h
Level 4
Level 4
 
Posts: 235
Joined: Sat Jun 18, 2011 7:13 am

Re: Cannot Enable Mint 13 Startup Splash

Postby RobertLM78 on Thu Jun 28, 2012 3:16 pm

jazz.h wrote:They are related, as long as you're satisfied with static images (without any kind of animations)...

Hmmm. Interesting, the live boot from CD has a splash very similar to Ubuntu's, with the 5-6 "dots" that do their back and forth thing. I will look into the grub customizer, though, but my intial cursory search in synaptic didn't return a package with that name.
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 159
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Re: Cannot Enable Mint 13 Startup Splash

Postby RobertLM78 on Fri Jun 29, 2012 2:20 am

Do you mean the Startup-Manager? I have already check-marked the splash option. I'm looking for the system splash, so if startupmanager supposed to control that, it isn't working :x .

I know it isn't a huge deal, but it is a touch that I'd really like to add to my systems :D . So, if there are any other ideas, please let me know as I'm pretty well stumped at this point (even the code provided by the Mint team seems to have no affect, so I wonder if this is some sort of bug.

UPDATE: Apparently I had not installed startupmanager on the 32-bit machine - which incidentally is a one operating system machine - and after check-marking the splash option and entering the command in the terminal, I get a splash :D :D :D ! It might just be a "flash-of-a-splash" (about 2-3 seconds), but it's there :D.

However, the new 64-bit system is a dual boot (sadly), and on that machine, the splash is still not working :( .
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 159
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Re: Cannot Enable Mint 13 Startup Splash

Postby RobertLM78 on Tue Jul 03, 2012 12:31 am

Final update: after restarting from a kernel update to 3.2.0-26 on the dual boot machine, I finally get a splash, I don't know if it was coincidence, or if the update somehow resolved the issue (I had of course tried reboot several times, I even went as far as to shut the computer down completely to get the splash to work before). Anyway, it's working now :D !

Thanks for the help Jazz :).

-------------------

So in summary, go get the nicely done splash on Mint enabled startup, I followed these steps:

1. In Startup-Manager, under Misc., check the box next to "Show boot splash", and close the manager.

2. Then open a terminal and enter
Code: Select all
sudo update-alternatives --config default.plymouth
, and select option #1, push enter and reboot.
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 159
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Re: [Solved] Cannot Enable Mint 13 Startup Splash

Postby janfai on Fri Jul 13, 2012 12:55 pm

After choosing Plymouth, you need to generate init ram disk by second command.

sudo update-alternatives --config default.plymouth
sudo update-initramfs -u
janfai
Level 1
Level 1
 
Posts: 1
Joined: Fri Jul 13, 2012 12:39 pm

Re: [Solved] Cannot Enable Mint 13 Startup Splash

Postby RobertLM78 on Mon Jul 16, 2012 2:02 pm

janfai wrote:After choosing Plymouth, you need to generate init ram disk by second command.

sudo update-alternatives --config default.plymouth
sudo update-initramfs -u

Thank you janfai for the good eye! This topic really isn't solved, because even though I am getting the splash, it is sporatic and inconsistent.

One machine it does appear every time, but only for about 0.8 second. The other computer is a complete gamble as to what it will do, about 50% of the time it shows, and 50% it doesn't show - this computer is also dual boot, which means it would be even nicer to have it working here, since rebooting is almost a daily occurance.

Anyway, I tried the additional command and it doesn't seem to have made a difference :( . I tried it on the dual boot machine and restarted twice with no splash....
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 159
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Re: [Semi-Solved] Cannot Enable Mint 13 Startup Splash

Postby NotSure23 on Thu Oct 25, 2012 5:49 pm

Using startup manager and checkmarking splash screen. Then imputing the command in terminal worked for me also to get the splash screen. The splash screen only displays for 1 or 2 seconds though.

Did you change the resolution or color depth? By default mine is set to 640x480 and 8 bit. My laptops resolution is 1280x768
NotSure23
Level 1
Level 1
 
Posts: 6
Joined: Mon Oct 22, 2012 2:06 pm

Re: [Semi-Solved] Cannot Enable Mint 13 Startup Splash

Postby RobertLM78 on Thu Nov 01, 2012 3:05 pm

NotSure23 wrote:Using startup manager and checkmarking splash screen. Then imputing the command in terminal worked for me also to get the splash screen. The splash screen only displays for 1 or 2 seconds though.

Did you change the resolution or color depth? By default mine is set to 640x480 and 8 bit. My laptops resolution is 1280x768

I didn't make any changes to the color depth. It seems that the splash does come on most of the time on here, but typically very briefly. I guess it's working well enough for me, as it seems to conistantly come up on the other two machines.
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 159
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Linux Mint is funded by ads and donations.
 

Return to Other topics

Who is online

Users browsing this forum: No registered users and 3 guests