unable to instal liquorix

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

unable to instal liquorix

Postby ganeshanair on Mon Jul 02, 2012 7:14 am

the dkms showing error no built name further more i had hard time installing the apt it kept showing


W: GPG error: http://liquorix.net sid InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3EFF4F272FB2CD80

i tryed a lot of things but no use it stil kept showing that heres my source list to show it there

# deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

deb http://ppa.launchpad.net/bean123ch/burg/ubuntu lucid main
deb-src http://ppa.launchpad.net/bean123ch/burg/ubuntu lucid main
deb http://packages.linuxmint.com/ debian main upstream import
deb-src http://packages.linuxmint.com/ debian main upstream import
# deb http://ftp.us.debian.org/debian testing main contrib non-free
# deb-src http://ftp.us.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free
deb http://ftp.de.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.de.debian.org/debian/ sid main contrib non-free
deb http://suwako.nomanga.net/debian sid main contrib
deb-src http://suwako.nomanga.net/debian sid main contrib
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb-src http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://frickelplatz.de/debian/ sid main
deb-src http://frickelplatz.de/debian/ sid main

deb http://liquorix.net/debian sid main
deb-src http://liquorix.net/debian sid main

plz help
ganeshanair
Level 1
Level 1
 
Posts: 28
Joined: Sun Jun 03, 2012 11:01 am

Linux Mint is funded by ads and donations.
 

Re: unable to instal liquorix

Postby Brian49 on Mon Jul 02, 2012 12:09 pm

You don't say whether you've installed the Liquorix keyring, but it looks as though you haven't:

Code: Select all
sudo apt-get install '^liquorix-([^-]+-)?keyring.?'
Brian49
Level 5
Level 5
 
Posts: 612
Joined: Thu Oct 29, 2009 2:27 pm

Re: unable to instal liquorix

Postby ganeshanair on Mon Jul 02, 2012 12:17 pm

i did install the keyring before and did the installlation but when i looked at how the installation went in synaptic manager i saw that the dkms was showing error still
ganeshanair
Level 1
Level 1
 
Posts: 28
Joined: Sun Jun 03, 2012 11:01 am

Re: unable to instal liquorix

Postby titetanium on Mon Jul 02, 2012 2:38 pm

That's not an error messsage. It's a warning letting u know that u are installing from a source that hasn't been verified by apt/dpkg. The key ring needs to be installed. Alternatively have u tried
Code: Select all
sudo apt-key add 3EFF4F272FB2CD80
to install the keyring? Follow that with apt-get update and the liquorix kernel shouldn't produce a warning. As for dkms, what module are u trying to compile for the new kernel? Have u also installed the headers for the liquorix kernel to compile external modules via dkms?
titetanium
Level 2
Level 2
 
Posts: 71
Joined: Mon Jun 18, 2012 4:26 pm

Re: unable to instal liquorix

Postby craigevil on Mon Jul 02, 2012 6:05 pm

Doesn't help that your sources.list is a mess.

Mixing Ubuntu, LMDE, Debian testing, Debian sid, plus other 3rd party repos is just asking for a screwed up system.

1) Pick which release you are going to run. Are you tracking LMDE latest, Debian Testing, or Debian sid?
2) Never ever use Ubuntu PPAs with LMDE/Debian
3) Learn the difference between a warning and a error message.
4) Learn how to use apt-get or aptitude
5) if you must have a package that is only in a Ubuntu PPA add the deb-src line and build a proper Debian .deb package

Read the Linux Mint Forums • View topic - LMDE FAQ : http://forums.linuxmint.com/viewtopic.php?f=197&t=91405
then take the time to read:
# Basics of the Debian package management system - http://www.debian.org/doc/FAQ/ch-pkg_basics.html
# Debian package management : http://www.debian.org/doc/manuals/debia ... 02.en.html
# Debian package management tools http://www.debian.org/doc/manuals/debia ... ls.en.html
# Aptitude user's manual - http://algebraicthunk.net/~dburrows/pro ... de/doc/en/
# Apt - Debian Wiki - http://wiki.debian.org/Apt
# The APT, Dpkg Quick Reference http://www.cyberciti.biz/ref/apt-dpkg-ref.html
# Secure APT - http://wiki.debian.org/SecureApt
# Aptitude - Debian Wiki - http://wiki.debian.org/Aptitude
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
craigevil
Level 5
Level 5
 
Posts: 559
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole

Re: unable to instal liquorix

Postby rhodry on Wed Jul 04, 2012 1:46 am

craigevil wrote:Doesn't help that your sources.list is a mess.
....................followed by lots of good stuff..................


Craig,

I have come across this sort of "repo mess" before, in this & other forums both you & I frequent. Usually from ex-Windows converts who think application installation is like Windows where you can pick up bits of Shareware & Freeware from all over the place & "make" it work.

If you don't mind, I have copied your reply to use in future as the basis for a stock reply - much easier & more straightforward than trying to address each aspect of someone's problem who has got themselves in such a tangle.

Just letting you know in case you see a reply somewhere that gives you a daunting sense of deja vu!! :)

cheers,
rhodry.
Life isn't about waiting for the storm to pass...
it's about learning to dance in the rain.
rhodry
Level 4
Level 4
 
Posts: 347
Joined: Mon Jun 04, 2007 7:32 am

Re: unable to instal liquorix

Postby cmost on Thu Jul 05, 2012 11:02 am

@ craigevil

2) Never ever use Ubuntu PPAs with LMDE/Debian


While this is obviously an excellent general rule, there are exceptions. For example, an entire PPA has been setup for Cinnamon themes and extensions and this very PPA is recommended for both Mint 13 and LMDE right here on these very boards.

Obviously one needs to be smart if planning to use an Ubuntu PPA in a Debian system. For individual superficial software packages such as screenlets or the aforementioned Cinnamon themes and extensions, using an Ubuntu PPA is relatively harmless. Other PPAs like xorg-edgers repository of latest Xorg and xserver drivers or an Ubuntu PPA containing updated KDE, Gnome or critical system packages could royally screw up an LMDE system. Moreover, not everyone, especially newbies or Windows refugees will have the wherewithal to use source packages to build a proper DEB. My advice is to be smart when adding repositories and do some Googling in advance to ensure others haven't had problems or to determine if the desired action is feasible. Also, users need to learn patience! In this modern age of instant gratification, many users insist on getting the latest version of a software package instantly. These users need to reflect on whether they want stability or cutting edge. If one is willing to go outside official repositories for a must-have package, then one must also be willing to accept the risks inherent in doing so.
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8 GB DDR2 RAM
nVidia GeForce GTX 660
Sabayon Linux - KDE 4.x
Linux Kernel 3.14
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky

Re: unable to instal liquorix

Postby ringo32 on Sat Dec 01, 2012 5:09 pm

i had a clean system. with nouveau driver i just deleted DKMS then install the liquorix kernel. later i install Nvidia drivers and its installs the DKMS to, iand DKMS made the DKMS.CONF for liquorix.
I only have some problem with coldstarts, i had already deleted plymouth and rechange the resolution, but further it works here....
ringo32
Level 1
Level 1
 
Posts: 42
Joined: Mon Jul 16, 2012 9:02 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 7 guests