Can't set Adobe Reader as default application

Questions about applications and software
Forum rules
Before you post please read this

Can't set Adobe Reader as default application

Postby mfreeman on Wed May 30, 2012 5:16 pm

As much as Adobe Reader stinks, I really need to use it more than the open source alternatives, mostly because it's the only one that can organize separate documents into tabs under one window, which none of the others I've tried can do. I have to work with multiple pdf documents constantly, and tabs are really the only sane way to do it.

Anyway, I've recently installed Mint 13, and when installing acroread, it didn't ask if I wanted to set it as the default application like it did in older Mint versions. It is not showing up in file.pdf [right click] -> Properties -> Open with tab. It's not listed in Recommended Applications, and it's not showing up in the list when I click "Show other applications". This new nautilus doesn't seem to allow me to enter a custom command like it used to in older Mint versions (Shameful regression there, Gnome!).

I tried just opening it through Adobe Reader, after which it is in the file.pdf [right click] -> Open with list. However, it is still not in the file.pdf [right click] -> Properties -> Open with tab, so I cannot set it as the default application to open the files when I double-click them.

Any simple way around this nasty flub in Mint 13?
mfreeman
Level 3
Level 3
 
Posts: 129
Joined: Thu Jan 21, 2010 3:11 am

Linux Mint is funded by ads and donations.
 

Re: Can't set Adobe Reader as default application

Postby pedrogplm on Mon Jun 04, 2012 2:58 pm

Happens exactly the same to me... don't have a clue why this can be happening =/
pedrogplm
Level 1
Level 1
 
Posts: 1
Joined: Mon Mar 08, 2010 10:32 am

Re: Can't set Adobe Reader as default application

Postby Nick Payne on Mon Jul 09, 2012 11:41 pm

Same here - I've installed Acroread through Synaptic, but can't make it the default application for opening PDFs. As I deal with a lot of PDF portfolios, Acroread is the only option for opening them, so it's a PITA to have Evince as the default app.

In Nautilus, when I look at the "Open With" tab of the properties dialog for any PDF, Acroread is not listed as one of the possible applications to use for opening PDF files.
Nick Payne
Level 3
Level 3
 
Posts: 104
Joined: Sun Feb 21, 2010 8:49 pm

Re: Can't set Adobe Reader as default application

Postby Nick Payne on Tue Jul 10, 2012 11:12 pm

Ok, the fix for being able to make Adobe Reader the default app for opening PDFs is:

1. Open the desktop file for acroread in an editor:
Code: Select all
gksudo gedit /usr/share/applications/acroread.desktop


2. Find the line that says "Exec=acroread" and change it to "Exec=acroread %f"

3. Save the changed file.

4. Open Nautilus, right-click on a PDF file and select "Properties", go to the "Open With" tab, select Adobe Reader 9 and click the "Set as default" button.

You should now be able to open a PDF in Adobe Reader by double-clicking on the file in Nautilus.
Nick Payne
Level 3
Level 3
 
Posts: 104
Joined: Sun Feb 21, 2010 8:49 pm

Re: Can't set Adobe Reader as default application

Postby altos on Sat Sep 01, 2012 10:19 am

I had the same issue, but my fix was simple enough - I uninstalled the default document viewer for MATE (atril, which I have no use for), and Adobe Reader automatically became the default viewer when I double-clicked a PDF file.

Peace.
altos
Level 1
Level 1
 
Posts: 1
Joined: Thu Aug 30, 2012 10:52 pm

Re: Can't set Adobe Reader as default application

Postby martywd on Sat Sep 01, 2012 12:20 pm

I know this is somewhat OT but just a reminder that there are security issues with acroread, especially on the *nix side.

==> https://lwn.net/Articles/511797/rss

FWIW. Lately I've found 'evince' (http://projects.gnome.org/evince/) to be much improved for opening and viewing .pdf 's on LinuxMint 13 Maya / MATE (32-bit).
.
martywd
Level 3
Level 3
 
Posts: 119
Joined: Sun May 08, 2011 10:35 am
Location: Texas

Re: Can't set Adobe Reader as default application

Postby Jon N on Wed Sep 26, 2012 12:30 am

Goto System Settings>File Associations>Applications. Then scroll down to PDF, and click on it. It will give a preference order on the right. Move the Adobe reader to the top, then press the "apply" button on the lower right. When you start a PDF again, it shoutld default to Adobe Reader! I hope this helped! :)
Jon N
Level 1
Level 1
 
Posts: 1
Joined: Wed Sep 26, 2012 12:22 am

Re: Can't set Adobe Reader as default application

Postby Mik3e on Wed Sep 26, 2012 10:41 pm

Jon N wrote:Goto System Settings>File Associations>Applications.


Where is 'System Settings'?
Mik3e
Level 2
Level 2
 
Posts: 64
Joined: Sat Jan 01, 2011 2:54 pm

Re: Can't set Adobe Reader as default application

Postby carlnielsen on Sat Nov 17, 2012 6:13 am

@Mik3e - Menu.. Preferences... System Settings (but you probably got that by now).


Everyone - I am stumped on this one. I need to set acroread as the default for handling pdf files. As others have noted, although "Open with Adobe Reader 9" is available as an option when right-clicking a file, it is not in the list of options for adding as the default. I don't seem to have an acroread.desktop file anywhere.

running LMDE 64-bit, if that makes a difference.
carlnielsen
Level 1
Level 1
 
Posts: 8
Joined: Sun Jun 12, 2011 4:57 pm

Re: Can't set Adobe Reader as default application

Postby xenopeek on Sun Nov 18, 2012 11:33 am

carlnielsen, suggest you open a new topic in the LMDE section of the forums. This section is for Linux Mint Main Edition.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14561
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Can't set Adobe Reader as default application

Postby cluelesscoder on Sun Nov 18, 2012 6:25 pm

Note that when Jon N talks about System Settings->File Associations, he's probably talking about KDE which has this menu. KDE seems to make it easier to configure default file associations. I commented on this over at viewtopic.php?f=47&t=100362&p=649250#p649250 ("[SOLVED] How to set default programs/applications?").

UPDATE: As I mentioned in the thread cited in the paragraph, Nautilus (I guess) sometimes HIDES FILE EXTENSIONS. So you might not see the .desktop at the end, but it is there, and so to open these .desktop files in /usr/share/applications you need to add the .desktop to the end - ie, gedit acroread.desktop rather than gedit acroread.
cluelesscoder
Level 1
Level 1
 
Posts: 12
Joined: Wed Sep 26, 2012 8:59 pm

Re: Can't set Adobe Reader as default application

Postby carlnielsen on Mon Nov 19, 2012 3:41 am

Solved... new eyes this morning and I discovered that on my system the file I wanted was AdobeReader.desktop in /usr/share/applications.

Not sure why mine is AdobeReader.desktop whereas others mention acroread.desktop. But anyway, adding the %f sorted it out.
carlnielsen
Level 1
Level 1
 
Posts: 8
Joined: Sun Jun 12, 2011 4:57 pm

Re: Can't set Adobe Reader as default application

Postby josephpmh on Thu Dec 27, 2012 3:49 pm

Thanks, Nick Payne. That fix worked.
josephpmh
Level 1
Level 1
 
Posts: 8
Joined: Wed Dec 07, 2011 10:50 pm
Location: Kensington, MD

Re: Can't set Adobe Reader as default application

Postby Spinnekop on Mon Feb 04, 2013 5:30 pm

Didn't quite work for me.... However, when I renamed AdobeReader.desktop to acroread.desktop it worked like a charm!
User avatar
Spinnekop
Level 2
Level 2
 
Posts: 61
Joined: Thu Jan 10, 2013 12:22 pm
Location: East Molesey, Surrey, UK

Re: Can't set Adobe Reader as default application

Postby Reteip on Sat Jun 08, 2013 11:05 am

I found that by installing Adobe reader using apt-get, I was given the option to make it the default reader.
Select yes and your done!
Reteip
Level 1
Level 1
 
Posts: 2
Joined: Fri Apr 12, 2013 7:50 pm

Re: Can't set Adobe Reader as default application

Postby laforey on Sat Aug 24, 2013 1:04 am

I solved by: Install acroread.
Open "/usr/share/applications" in Nemo File Browser(open as root).
Right click Adobe Reader, select "Properties".
In "Command:" change to "acroread %f"
Close
Right-click your PDF file, select Properties.
select "Open With",If "Adobe Reader" does not appear, select "Show other applications".
select "Adobe Reader" from the list , select "Set as Default". then "Close".
The next time you open a PDF file, Adobe Reader should open it.
laforey
Level 1
Level 1
 
Posts: 2
Joined: Sat Jun 16, 2012 6:33 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: pcpunk and 16 guests