j'ai un clavier qwerty sur l'ecran de login

French Forum

j'ai un clavier qwerty sur l'ecran de login

Postby olitask on Sat Jul 07, 2012 6:36 am

Bonjour à tous

après un moment sur ubuntu, je migre avec mon nouveau pc sur LMDE. ( j'ai eu qqs problèmes de freeze non résolus sur ubuntu.) et ceci est mon premier message sur ce forum.

Au moment de me loguer, mon clavier est paramétré en qwerty , et ca me pose qqs problèmes car j'ai plusieurs lettres "a" dans mon mot de passe. Une fois loggé ( apres 3 tentatives...), pas de problèmes, mon clavier est bien en azerty. Comment régler ce problème ?

merci à vous Olivier
olitask
Level 1
Level 1
 
Posts: 4
Joined: Sat Jul 07, 2012 6:22 am

Linux Mint is funded by ads and donations.
 

Re: j'ai un clavier qwerty sur l'ecran de login

Postby corn on Mon Jul 09, 2012 4:46 pm

À tout hasard, essaie le raccourci clavier pour changer de clavier au moment du login. (Pour moi, avec MATE, c'est shift+capslock)
corn
Level 1
Level 1
 
Posts: 24
Joined: Sun Dec 25, 2011 7:59 pm

Re: j'ai un clavier qwerty sur l'ecran de login

Postby olitask on Wed Jul 11, 2012 5:46 am

Bonjour

Eh non, ça ne passe pas. Le raccourci ne fait que me mettre le clavier en majuscule. J'avais déjà rencontré ce problème en essayant fedora il y a deux semaines avant de passer à LMDE.
olitask
Level 1
Level 1
 
Posts: 4
Joined: Sat Jul 07, 2012 6:22 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby eanfrid on Wed Jul 11, 2012 6:04 am

Bonjour,

A tout hasard, parce que la config du clavier console conditionne tout y compris sous X:
Code: Select all
(sudo) dpkg-reconfigure keyboard-configuration


Si le souci était identique sous Fedora, le problème ne vient pas de LMDE mais plus problablement de la détection du clavier au démarrage. Essaie aussi si possible avec un autre clavier (matériel).
No, Linux is not a Windows clone for free - Before asking any question here...
"Never attribute to malice that which is adequately explained by stupidity." (Hanlon's razor)

Debian GNU/Linux Wheezy 64bit w/custom 3.12 kernel - MATE 1.8
User avatar
eanfrid
Level 6
Level 6
 
Posts: 1199
Joined: Mon Apr 30, 2012 2:49 am
Location: France

Re: j'ai un clavier qwerty sur l'ecran de login

Postby makidoko on Sat Jul 14, 2012 7:16 am

Le problème ne vient pas du clavier, mais de mdm, le gestionnaire de connexion.
J'ai le même bug. Le clavier est correctement reconnu partout (console, gnome, cinamon, mate, gdm, ldm...) mais pas sous mdm.
makidoko
Level 1
Level 1
 
Posts: 2
Joined: Sat Jul 14, 2012 7:11 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby magnusanderssen on Mon Jul 16, 2012 3:29 pm

Même problème ici et j'avais le même soucis avec une debian unstable avant. Partout c'est bon sauf dans MDM et GDM respectivement.

Je me demande si ce n'est pas lié à certains claviers; je n'ai jamais eu de soucis avant d'acheter un logitech k750 (avec unifying).
magnusanderssen
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 18, 2012 5:14 pm

Re: j'ai un clavier qwerty sur l'ecran de login

Postby magnusanderssen on Sat Jul 21, 2012 7:51 am

bon ben on dirait que tout le monde s'en fiche...
magnus
linux mint cinnamon 13
- i7 avec clavier k750 et problème MDM
- eeepc 1215p
magnusanderssen
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 18, 2012 5:14 pm

Re: j'ai un clavier qwerty sur l'ecran de login

Postby Asimov on Wed Aug 01, 2012 7:29 pm

magnusanderssen wrote:bon ben on dirait que tout le monde s'en fiche...


C'est pas vraiment un problème critique. Avoue qu'un virus sous Window serait plus emmerdant. Les programmeurs sont sans doute en train de chercher la cause du problème. Donc tu peux attendre le correctif et continuer à démarrer en mode sécuritaire, te loggé et faire startx. Soit expérimenté avec xdm.

P.S. pense à indiquer ta version de Mint. Quelque fois c'est une information critique.
Asimov
Level 2
Level 2
 
Posts: 95
Joined: Wed Aug 01, 2012 4:04 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby eanfrid on Thu Aug 02, 2012 1:42 am

Il n'y a aucun bug déclaré à ce sujet sur https://github.com/linuxmint/mdm/issues mais peut-être est-ce lié à ce bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=647230 puisque mdm est à la base un renommage et un relooking de gdm 2.20.11.
No, Linux is not a Windows clone for free - Before asking any question here...
"Never attribute to malice that which is adequately explained by stupidity." (Hanlon's razor)

Debian GNU/Linux Wheezy 64bit w/custom 3.12 kernel - MATE 1.8
User avatar
eanfrid
Level 6
Level 6
 
Posts: 1199
Joined: Mon Apr 30, 2012 2:49 am
Location: France

Re: j'ai un clavier qwerty sur l'ecran de login

Postby Asimov on Thu Aug 02, 2012 8:35 pm

Eanfrid

Ton bug semble être une bonne piste. Un projet saboter par un serveur qui convertie les noms de fichier pour des majuscules, c'est quelque chose qui est arrivé plus d'une fois.
Asimov
Level 2
Level 2
 
Posts: 95
Joined: Wed Aug 01, 2012 4:04 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby magnusanderssen on Fri Aug 03, 2012 2:03 am

Asimov wrote:Eanfrid

Ton bug semble être une bonne piste. Un projet saboter par un serveur qui convertie les noms de fichier pour des majuscules, c'est quelque chose qui est arrivé plus d'une fois.


Je dois admettre que je suis un peu perplexe: plus de gens seraient impactés par le problème, non ?

Finalement, après y avoir pensé un peu, les gens ont probablement soit des mots de passe simple (alphanumérique) soit ils utilisent l'autologin.

Sur mon netbook, qui a été installé avec la même image, je n'ai pas le problème.

Quoi qu'il en soit, j'ai ouvert un "issue" sur le github de MDM : https://github.com/linuxmint/mdm/issues/5.

On verra si j'ai une réponse.
magnus
linux mint cinnamon 13
- i7 avec clavier k750 et problème MDM
- eeepc 1215p
magnusanderssen
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 18, 2012 5:14 pm

Re: j'ai un clavier qwerty sur l'ecran de login

Postby olitask on Sun Aug 05, 2012 1:07 pm

Bonjour

De retour de vacances, frais et dispo ( enfin facon de parler ) , je me rend compte que comme l'un d'entre vous mon clavier est aussi un logitech k520.
si ca peut faire avancer ...
olitask
Level 1
Level 1
 
Posts: 4
Joined: Sat Jul 07, 2012 6:22 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby Asimov on Mon Aug 06, 2012 12:06 pm

Ça serait vraiment utile que tu nous dises si ton clavier est en mode qwerty quand tu démarre en mode texte. Ça permettrais d'établir si c'est la détection qui est en faute.
Asimov
Level 2
Level 2
 
Posts: 95
Joined: Wed Aug 01, 2012 4:04 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby magnusanderssen on Mon Aug 06, 2012 3:24 pm

Asimov wrote:Ça serait vraiment utile que tu nous dises si ton clavier est en mode qwerty quand tu démarre en mode texte. Ça permettrais d'établir si c'est la détection qui est en faute.


Ne sachant pas si c'est à moi que la question s'adresse, je réponds.

Mon clavier est un modèle suisse et tout fonctionne correctement sauf xDM (x pour G ou M).

voilà
magnus
linux mint cinnamon 13
- i7 avec clavier k750 et problème MDM
- eeepc 1215p
magnusanderssen
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 18, 2012 5:14 pm

Re: j'ai un clavier qwerty sur l'ecran de login

Postby Asimov on Tue Aug 07, 2012 8:12 am

En fait, au deux. Je viens de faire une recherche sur Google au sujet des deux programmes. Ils sont de sérieux bugs. Je crois que dans vos cas, il serait préférable que vous fassiez une conversion pour XDM. L'abandon de Gnome sera difficile, je crois ...

D'un autre coté, se logger en mode texte n'est pas très long.
Asimov
Level 2
Level 2
 
Posts: 95
Joined: Wed Aug 01, 2012 4:04 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby Asimov on Thu Aug 09, 2012 5:47 am

Le dossier xorg a encore priorité


à modifier dans le dossier : /etc/X11/xorg.conf

Cette partie

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection



En la remplacant par


Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
EndSection

Asimov
Level 2
Level 2
 
Posts: 95
Joined: Wed Aug 01, 2012 4:04 am

Re: j'ai un clavier qwerty sur l'ecran de login

Postby magnusanderssen on Mon Aug 13, 2012 4:27 pm

Hello,

J'ai essayé cette solution mais ça ne change pas, le layout dans MDM est toujours un clavier américain.

On dirait de MDM se fiche de la configuration. Je me demande s'il n'y a pas une erreur qqp et qu'il fallback sur le clavier par défaut.

Dans /var/log/Xorg.0.log je vois:

Code: Select all
[    26.509] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    26.509] (WW) Disabling Keyboard0
[    26.509] (WW) Disabling Mouse0


Donc effectivement il "jette" ma configuration

plus tard j'ai

Code: Select all
[    31.823] (II) Using input driver 'evdev' for 'Power Button'
[    31.823] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    31.823] (**) Power Button: always reports core events
[    31.823] (**) Power Button: Device: "/dev/input/event1"
[    31.823] (--) Power Button: Found keys
[    31.823] (II) Power Button: Configuring as keyboard
[    31.823] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[    31.823] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    31.823] (**) Option "xkb_rules" "evdev"
[    31.823] (**) Option "xkb_model" "pc105"
[    31.823] (**) Option "xkb_layout" "ch"
[    31.823] (**) Option "xkb_variant" "fr"
[    31.824] (II) XKB: reuse xkmfile /var/lib/xkb/server-53A4CFD27CBE694B87E57086754C176B71A8EEB5.xkm
[    31.837] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    31.837] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    31.837] (II) Using input driver 'evdev' for 'Power Button'
[    31.837] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    31.837] (**) Power Button: always reports core events
[    31.837] (**) Power Button: Device: "/dev/input/event0"
[    31.838] (--) Power Button: Found keys
[    31.838] (II) Power Button: Configuring as keyboard
[    31.838] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[    31.838] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    31.838] (**) Option "xkb_rules" "evdev"
[    31.838] (**) Option "xkb_model" "pc105"
[    31.838] (**) Option "xkb_layout" "ch"
[    31.838] (**) Option "xkb_variant" "fr"

???

et encore un peu après:

Code: Select all
[    31.841] (II) config/udev: Adding input device Logitech Unifying Device. Wireless PID:4002 (/dev/input/event3)
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: Applying InputClass "evdev keyboard catchall"
[    31.841] (II) Using input driver 'evdev' for 'Logitech Unifying Device. Wireless PID:4002'
[    31.841] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: always reports core events
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: Device: "/dev/input/event3"
[    31.841] (--) Logitech Unifying Device. Wireless PID:4002: Found 1 mouse buttons
[    31.841] (--) Logitech Unifying Device. Wireless PID:4002: Found scroll wheel(s)
[    31.841] (--) Logitech Unifying Device. Wireless PID:4002: Found relative axes
[    31.841] (--) Logitech Unifying Device. Wireless PID:4002: Found absolute axes
[    31.841] (II) evdev-grail: failed to open grail, no gesture support
[    31.841] (--) Logitech Unifying Device. Wireless PID:4002: Found keys
[    31.841] (II) Logitech Unifying Device. Wireless PID:4002: Configuring as mouse
[    31.841] (II) Logitech Unifying Device. Wireless PID:4002: Configuring as keyboard
[    31.841] (II) Logitech Unifying Device. Wireless PID:4002: Adding scrollwheel support
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: YAxisMapping: buttons 4 and 5
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    31.841] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.2/0003:046D:C52B.0003/input/input3/event3"
[    31.841] (II) XINPUT: Adding extended input device "Logitech Unifying Device. Wireless PID:4002" (type: KEYBOARD)
[    31.841] (**) Option "xkb_rules" "evdev"
[    31.841] (**) Option "xkb_model" "pc105"
[    31.841] (**) Option "xkb_layout" "ch"
[    31.841] (**) Option "xkb_variant" "fr"
[    31.841] (EE) Logitech Unifying Device. Wireless PID:4002: failed to initialize for relative axes.
[    31.841] (II) Logitech Unifying Device. Wireless PID:4002: initialized for absolute axes.
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: (accel) keeping acceleration scheme 1
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: (accel) acceleration profile 0
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: (accel) acceleration factor: 2.000
[    31.841] (**) Logitech Unifying Device. Wireless PID:4002: (accel) acceleration threshold: 4
[    31.842] (II) config/udev: Adding input device Logitech Unifying Device. Wireless PID:1028 (/dev/input/event4)
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: Applying InputClass "evdev pointer catchall"
[    31.842] (II) Using input driver 'evdev' for 'Logitech Unifying Device. Wireless PID:1028'
[    31.842] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: always reports core events
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: Device: "/dev/input/event4"
[    31.842] (--) Logitech Unifying Device. Wireless PID:1028: Found 20 mouse buttons
[    31.842] (--) Logitech Unifying Device. Wireless PID:1028: Found scroll wheel(s)
[    31.842] (--) Logitech Unifying Device. Wireless PID:1028: Found relative axes
[    31.842] (--) Logitech Unifying Device. Wireless PID:1028: Found x and y relative axes
[    31.842] (II) Logitech Unifying Device. Wireless PID:1028: Configuring as mouse
[    31.842] (II) Logitech Unifying Device. Wireless PID:1028: Adding scrollwheel support
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: YAxisMapping: buttons 4 and 5
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    31.842] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.2/0003:046D:C52B.0003/input/input4/event4"
[    31.842] (II) XINPUT: Adding extended input device "Logitech Unifying Device. Wireless PID:1028" (type: MOUSE)
[    31.842] (II) Logitech Unifying Device. Wireless PID:1028: initialized for relative axes.
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: (accel) keeping acceleration scheme 1
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: (accel) acceleration profile 0
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: (accel) acceleration factor: 2.000
[    31.842] (**) Logitech Unifying Device. Wireless PID:1028: (accel) acceleration threshold: 4
[    31.842] (II) config/udev: Adding input device Logitech Unifying Device. Wireless PID:1028 (/dev/input/mouse0)
[    31.842] (II) No input driver/identifier specified (ignoring)
[    31.843] (II) config/udev: Adding input device Eee PC WMI hotkeys (/dev/input/event2)
[    31.843] (**) Eee PC WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[    31.843] (II) Using input driver 'evdev' for 'Eee PC WMI hotkeys'
[    31.843] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    31.843] (**) Eee PC WMI hotkeys: always reports core events
[    31.843] (**) Eee PC WMI hotkeys: Device: "/dev/input/event2"
[    31.843] (--) Eee PC WMI hotkeys: Found keys
[    31.843] (II) Eee PC WMI hotkeys: Configuring as keyboard
[    31.843] (**) Option "config_info" "udev:/sys/devices/platform/eeepc-wmi/input/input2/event2"
[    31.843] (II) XINPUT: Adding extended input device "Eee PC WMI hotkeys" (type: KEYBOARD)
[    31.843] (**) Option "xkb_rules" "evdev"
[    31.843] (**) Option "xkb_model" "pc105"
[    31.843] (**) Option "xkb_layout" "ch"
[    31.843] (**) Option "xkb_variant" "fr"
[    43.133] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
[    47.271] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
[    47.288] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
[    48.185] (II) XKB: reuse xkmfile /var/lib/xkb/server-8A67ACE56E71AC3F1F392DB8437BBC00A7803286.xkm
[    49.935] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
[    49.937] (II) XKB: reuse xkmfile /var/lib/xkb/server-E011D4BA1FB70FFBF98D428A4489C11CF3CDA812.xkm
[    63.774] (II) XKB: reuse xkmfile /var/lib/xkb/server-E011D4BA1FB70FFBF98D428A4489C11CF3CDA812.xkm


Code: Select all
magnus@i5 ~ $ ls -la /var/lib/xkb/
total 64
drwxr-xr-x  2 root root  4096 Jul 28 19:51 .
drwxr-xr-x 63 root root  4096 Jun 18 22:34 ..
-rw-r--r--  1 root root 12264 Jul 28 19:49 server-53A4CFD27CBE694B87E57086754C176B71A8EEB5.xkm
-rw-r--r--  1 root root 12312 Jul 28 19:51 server-8A67ACE56E71AC3F1F392DB8437BBC00A7803286.xkm
-rw-r--r--  1 root root 11252 Jul 28 19:49 server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
-rw-r--r--  1 root root 12304 Jul 28 19:51 server-E011D4BA1FB70FFBF98D428A4489C11CF3CDA812.xkm
magnus@i5 ~ $
magnus
linux mint cinnamon 13
- i7 avec clavier k750 et problème MDM
- eeepc 1215p
magnusanderssen
Level 1
Level 1
 
Posts: 9
Joined: Mon Jun 18, 2012 5:14 pm

Re: j'ai un clavier qwerty sur l'ecran de login

Postby Asimov on Mon Aug 13, 2012 8:14 pm

j'avoue que je m'y perd avec cette distro. J'ai fait des recherches pour changer votre gestionnaire de bureau ( Display manager). Et certain fichier n'existe plus sous Mint. J'ai fait un demande d'information sur le forum anglophone pour savoir comment si prendre pour installer LightDM, le display manager de la version 12.
Asimov
Level 2
Level 2
 
Posts: 95
Joined: Wed Aug 01, 2012 4:04 am

Linux Mint is funded by ads and donations.
 

Return to French

Who is online

Users browsing this forum: No registered users and 4 guests