SOLVED ... "Battery broken" warning on MATE

SOLVED ... "Battery broken" warning on MATE

Postby iain_j on Sun Jul 15, 2012 7:25 am

I've just installed LM13 MATE on my laptop (HP G70) and every time I start up I get a warning "Battery may be broken - battery has a very low capacity (38.9%) which means that it may be old or broken". The laptop's plugged in, and when I close the warning, the indicator shows "fully charged". Unplugged, the power statistics "time to empty" is around 50 minutes.

I've got LM13 Cinnamon on another partition and haven't had any such warnings there, and none in the old days of Windows. I rarely use the laptop unplugged anyway. Is there any way to stop this warning (other than buying a new battery)?
Last edited by iain_j on Thu Aug 16, 2012 5:18 am, edited 1 time in total.
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Linux Mint is funded by ads and donations.
 

Re: "Battery broken" warning on MATE

Postby Oscar799 on Sun Jul 15, 2012 12:54 pm

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8699
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: "Battery broken" warning on MATE

Postby tinbox on Sun Aug 05, 2012 3:24 pm

So I ran into this same issue. Searching you will find lots of advice to edit the gconf file for power-management. This is correct "HOWEVER" as a Mint user you most likely are using MATE or Cinnamon. I happen to be using MATE, so you will not find the desired gconf files they refer you too. The files do exist but exist under MATE rather then gconf.

Code: Select all
su (superuser elevation)
cd /usr/share/mateconf/schemas/
nano mate-power-manager.schemas
ctrl ^W "broken battery"  (Search for broken battery)
 

You should find the following, change true value to false and save ctrl ^X
Code: Select all
 <schema>
      <key>/schemas/apps/mate-power-manager/notify/low_capacity</key>
      <applyto>/apps/mate-power-manager/notify/low_capacity</applyto>
      <owner>mate-power-manager</owner>
      <type>bool</type>
      <default>false</default>
      <gettext_domain>mate-power-manager</gettext_domain>
      <locale name="C">
        <short>If we should show the low capacity warning for a broken battery<$
        <long>If we should show the low capacity warning for a broken battery.<$
      </locale>
    </schema>


Enjoy!
tinbox
Level 1
Level 1
 
Posts: 1
Joined: Sun Aug 05, 2012 3:09 pm

Re: "Battery broken" warning on MATE

Postby iain_j on Thu Aug 16, 2012 5:17 am

Hi tinbox

Thanks for your help, I actually came across a solution while looking for something else (run mateconf-editor, go to apps > mateconf-power-manager > notify, un-check "low_capacity"). I figure that your solution is changing the same setting?

Thanks
Iain
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Re: SOLVED ... "Battery broken" warning on MATE

Postby Knowcontrol on Sat Feb 23, 2013 2:21 am

The previous solutions didn't work... Iain's solution did and only required a few clicks and zero typing. Thank you so much!
Knowcontrol
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 02, 2013 6:49 pm


Return to MATE

Who is online

Users browsing this forum: No registered users and 3 guests