Disable Anitaliasing fonts

Disable Anitaliasing fonts

Postby kcpoole on Wed May 16, 2012 9:21 pm

Can some one provide info on how to disable Anitaliasing fonts on Mint ( or any other Gnome UI ).

Forget the invitable comments that liased font look better and provide a better user experience. For me and many others, they just look Fuzzy and give me a headace after about 30 minutes of use

I support windows 7 for my work, and to turn off all antialiasing, it is one check box. If I do not do this at the first boot on Win7 / 2008 install, by the time the install has completed I have a headache for the rest of the day.

Same applies to recent Mint / Ubuntu

Last used ubuntu and there was a font tuning application that I used, but it only worked on the operating system fonts, this on Firefox and Thunderbird were not changed. I had to modify these font settings manually.
About 1 year ago I installed Minto over the top of this and the UI settings were retained so I have been OK with it up till now. I have to reinstall this machine du to playing with Disk Formats :lol:
I ran up a new laptop with Mint on it ( LMDE) and using Cinnamon or Mate, the fonts are antialiased. I cannot look at it for more that 30 minutes before having to turn it off and do something else!

Not happy
Ken
kcpoole
Level 1
Level 1
 
Posts: 20
Joined: Fri Apr 13, 2012 2:47 am

Linux Mint is funded by ads and donations.
 

Re: Disable Anitaliasing fonts

Postby kcpoole on Wed May 16, 2012 11:48 pm

A reply to another post elswhere, mentions to use "Gnome Tweak Tool" http://live.gnome.org/GnomeTweakTool

Anyone tried it?
is it in any repos?

tia
Ken
kcpoole
Level 1
Level 1
 
Posts: 20
Joined: Fri Apr 13, 2012 2:47 am

Re: Disable Anitaliasing fonts

Postby eanfrid on Thu May 17, 2012 2:22 am

The default "slight" antialiasing is quite bad and blurry indeed. You should then choose either at least "medium" or "none" (if you prefer a 1990's style) in antialiasing options. The gnome-tweak-tool thing is in Mint/Ubuntu repos and is now a standard tool in Gnome 3. But regarding Cinnamon, you must look for display settings in "Cinnamon Settings".
Main desktop: Debian GNU/Linux Wheezy 64bit - MATE 1.8.1
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox
User avatar
eanfrid
Level 7
Level 7
 
Posts: 1871
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Disable Anitaliasing fonts

Postby Oscar799 on Thu May 17, 2012 7:52 am

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8888
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Disable Anitaliasing fonts

Postby kcpoole on Thu May 17, 2012 8:57 am

Dunnu why moved to LMDE forum as it relates to Gnome UI and not specific to LMDE but that OK so long as users see it and can help out.

Ken
kcpoole
Level 1
Level 1
 
Posts: 20
Joined: Fri Apr 13, 2012 2:47 am

Re: Disable Anitaliasing fonts

Postby proxima_centauri on Thu May 17, 2012 9:00 am

gnome-tweak-tool is installed by default and is available under the name "Advanced Settings" in the menu.
User avatar
proxima_centauri
Level 11
Level 11
 
Posts: 3976
Joined: Tue Dec 25, 2007 3:24 pm
Location: NB, Canada

Re: Disable Anitaliasing fonts

Postby kcpoole on Fri May 18, 2012 9:42 am

Ok found gnome-tweak-tool ( not installed by default on my install).
Set the Default and document fonts to DejaVu Sans, with Antialiasing to None, and Hinting to Full gives a nice sharp single line font on Most apps Excep Firefox and Thunderbird.
They seem to ignore the OS Font settings on Mint, but when disable Antialiasing on Win7 they Both use the system settings.

Any idea on how to get FF and Thunderbird to also have no Anitaliasing too?

Ken
kcpoole
Level 1
Level 1
 
Posts: 20
Joined: Fri Apr 13, 2012 2:47 am

Re: Disable Anitaliasing fonts

Postby titetanium on Sun Jul 15, 2012 11:41 pm

Hi,

Try this addon for both firefox and thunderbird. Works for me.
titetanium
Level 2
Level 2
 
Posts: 71
Joined: Mon Jun 18, 2012 4:26 pm

Re: Disable Anitaliasing fonts

Postby egrath on Mon Jul 16, 2012 12:09 am

Hi,
if you want to totally disable antialiasing in your fonts, the best way is to do the following:

  • Install fonts which have excellent Hinting information in them (like the Microsoft Core Fonts for web; apt-get install ttf-mscorefonts-installer)
  • Tweak your /etc/fonts/local.conf to disable antialiasing entirely and enable full hinting.
  • Set your Display fonts to Arial and Courier New in the Settings

This gives you essentially the look and feel of Windows 2000/XP with crispy and sharp fonts. I have attached my /etc/fonts/local.conf for your reference.

Code: Select all
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!--
 
(Mostly aliased) Font configuration
 
This configuration assumes that you like crispy and sharp looking fonts, like
the ones shown in the default configuration of Windows versions before Vista.
 
It also assumes that you have installed at least the following fonts:
 
* Arial
* Times New Roman
* Courier
 
These fonts are freely available on the Web from various places like your
distribution provided repository or over at http://corefonts.sourceforge.net
 
-->
<fontconfig>
    <dir>/usr/share/fonts/ttf</dir>
     
    <!-- Font replacements for standard names -->
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>sans</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Arial</string>
        </edit>
    </match>
     
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>sans-serif</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Arial</string>
        </edit>
    </match>
     
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>serif</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Times New Roman</string>
        </edit>
    </match>
     
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>monospace</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Courier New</string>
        </edit>
    </match>
     
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>monospaced</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Courier New</string>
        </edit>
    </match>
     
    <match target="pattern" name="family">
        <test name="family" qual="any">
            <string>mono</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Courier New</string>
        </edit>
    </match>
     
    <!-- Font replacements for other often used font names
         that we probably don't have installed -->     
    <match target="pattern">
        <test name="family" qual="any" mode="contains">
            <string>Helvetica</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Arial</string>
        </edit>
    </match>
 
    <match target="pattern">
        <test name="family" qual="any" mode="contains">
            <string>Times Roman</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Times New Roman</string>
        </edit>
    </match>
     
    <match target="pattern">
        <test name="family" qual="any" mode="contains">
            <string>Times</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Times New Roman</string>
        </edit>
    </match>
     
    <match target="pattern">
        <test name="family" qual="any" mode="contains">
            <string>Courier</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Courier New</string>
        </edit>
    </match>
     
    <match target="pattern">
        <test name="family" qual="any" mode="contains">
            <string>Consolas</string>
        </test>
        <edit name="family" mode="assign" binding="strong">
            <string>Courier New</string>
        </edit>
    </match>
     
    <!-- Default settings -->
    <match target="font">
        <edit name="antialias" mode="assign"><bool>false</bool></edit>
        <edit name="hinting" mode="assign"><bool>true</bool></edit>
        <edit name="autohint" mode="assign"><bool>false</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintfull</const></edit>   
        <edit name="rgba" mode="assign"><const>none</const></edit>
    </match>
     
    <!-- Make fonts larger than 15 Pt. Antialiased with RGB Subpixel rendering -->
    <match target="font">
        <test name="size" qual="any" compare="more_eq">
            <double>15</double>
        </test>
        <edit name="antialias" mode="assign"><bool>true</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintmedium</const></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <edit name="lcdfilter" mode="assign"><const>lcdlight</const></edit>
    </match>
 
    <!-- Make fonts smaller than 8 pt. Antialiased with RGB Subpixel rendering -->
    <!-- and fully hinted -->
    <match target="font">
        <test name="size" qual="any" compare="less">
            <double>9</double>
        </test>
        <edit name="antialias" mode="assign"><bool>true</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintfull</const></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <edit name="lcdfilter" mode="assign"><const>lcddefault</const></edit>
    </match>
     
    <!-- Make bold fonts Antialiased with RGB Subpixel rendering -->
    <match target="font">
        <test name="weight" qual="any" compare="more_eq">
            <const>demibold</const>
        </test>     
        <edit name="antialias" mode="assign"><bool>true</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintmedium</const></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <edit name="lcdfilter" mode="assign"><const>lcdlight</const></edit>   
    </match>
 
    <!-- Special handling for Lucida Grande Font family -->
    <match target="font">
        <test name="family" qual="any">
            <string>Lucida Grande</string>
        </test>
        <edit name="lcdfilter" mode="assign"><const>lcddefault</const></edit>
    </match>
 
    <!-- Special handling for DejaVu Font family -->
    <match target="font">
        <test name="family" qual="any">
            <string>DejaVu Sans</string>
            <string>DejaVu Sans Mono</string>
            <string>DejaVu Serif</string>
        </test>
         
        <edit name="antialias" mode="assign"><bool>true</bool></edit>
        <edit name="hintstyle" mode="assign"><const>hintmedium</const></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <edit name="lcdfilter" mode="assign"><const>lcdlight</const></edit>
    </match>
     
    <!-- Special handling for Liberation Font family -->
    <match target="font">
        <test name="family" qual="any">
            <string>Liberation Sans</string>
            <string>Liberation Serif</string>
            <string>Liberation Mono</string>
        </test>
         
        <edit name="hintstyle"><const>hintslight</const></edit>
    </match>
 
    <!-- Special handling for Droid Font family -->
    <match target="font">
        <test name="family" qual="any">
            <string>Droid Sans</string>
            <string>Droid Sans Mono</string>
            <string>Droid Serif</string>
        </test>
 
        <edit name="antialias" mode="assign"><bool>true</bool></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <edit name="lcdfilter" moder="assign"><const>lcdlight</const></edit>
    </match>
     
    <!-- Special handling for Ubuntu Font family -->
    <match target="font">
        <test name="family" qual="any" compare="contains">
            <string>Ubuntu</string>
        </test>
 
        <edit name="antialias" mode="assign"><bool>true</bool></edit>
        <edit name="rgba" mode="assign"><const>rgb</const></edit>
        <edit name="lcdfilter" moder="assign"><const>lcdlegacy</const></edit>
    </match>   
</fontconfig>


Screenshot of what it looks like:

egrath_desktop.png
egrath_desktop.png (431.65 KiB) Viewed 5999 times


egrath
User avatar
egrath
Level 1
Level 1
 
Posts: 33
Joined: Thu Jun 14, 2012 5:44 am
Location: Austria

Re: Disable Anitaliasing fonts

Postby j.rueger on Wed Oct 02, 2013 7:11 am

After I upgraded to LMDE UP7 (and Firefox 24), Firefox ignored MATE's font settings, at least the hinting.
After some fiddling around, I found a fix.

This helped me get on the right track: http://livelinux.altervista.org/Guida_LMDE/EN_tips.html
Point 20, Adjust Fonts.

The tip is a bit outdated, on UP7 you just need to remove 10-hinting-slight.conf and link in i.e. 10-hinting-full.conf to make Firefox behave. :)

Hope this helps someone finding this thread.
j.rueger
Level 1
Level 1
 
Posts: 6
Joined: Thu May 24, 2012 7:26 am
Location: Göttingen, Germany

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest