Firefox Issues

Questions about applications and software
Forum rules
Before you post please read this

Firefox Issues

Postby LivingColour on Wed Jun 27, 2012 4:42 pm

I have 2 Firefox issues that are driving me nuts. The first issue is with the search bar. I have it set to Google. No problem there. But it won't show search suggestions even though the box is checked in the options. My second, and biggest issue is that I don't get spell check on anything. Not in this text box I am typing in, not in Facebook, nothing. I get no red lines under misspelled words. I don't know how this got turned off, but it just stopped doing it the other day, and I don't how to turn it back on. Thanks for any help.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Linux Mint is funded by ads and donations.
 

Re: Firefox Issues

Postby HughT on Wed Jun 27, 2012 5:16 pm

hi LivingColour, regarding the second problem: in Firefox, go to Edit Preferences Advanced General 'Check my spelling as I type'. I'm not sure how it figures out the language to check, possibly in Edit Preferences Content.
regards
Please Edit your post title and add [SOLVED] once your question is resolved.
HughT
Level 5
Level 5
 
Posts: 628
Joined: Thu Oct 20, 2011 1:54 pm
Location: England

Re: Firefox Issues

Postby LivingColour on Wed Jun 27, 2012 6:30 pm

I have that box checked. That is the first thing I looked at when I noticed the problem.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 3:25 pm

Bump... Anyone? This is why Linux will never make it on the desktop. Nothing ever works right out of the box, and there is no help.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby esteban1uy on Tue Jul 17, 2012 4:55 pm

LivingColour wrote:Bump... Anyone? This is why Linux will never make it on the desktop. Nothing ever works right out of the box, and there is no help.


... and surely you won't get a lot of help with that attitude.
If you want to have a nice spell-checker in your FF you can always install "After the Deadline" extension: http://atdfirefox.wordpress.com/

Cheers!
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Firefox Issues

Postby oboedad55 on Tue Jul 17, 2012 5:17 pm

LivingColour wrote:Bump... Anyone? This is why Linux will never make it on the desktop. Nothing ever works right out of the box, and there is no help.


Have you installed the dictionary for your language? For example, in my addons I have the US English spellchecker installed.
Also, have a look here; http://support.mozilla.org/en-US/kb/how ... ll-checker
Homemade Intel Dual-core 3.4 gHz, 4 gigs ram, EVGA GeForce GT 430
=================================
Mint 14, Arch Linux, Fedora 17
User avatar
oboedad55
Level 2
Level 2
 
Posts: 99
Joined: Thu Aug 06, 2009 3:02 am

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 9:09 pm

esteban1uy wrote:
LivingColour wrote:Bump... Anyone? This is why Linux will never make it on the desktop. Nothing ever works right out of the box, and there is no help.


... and surely you won't get a lot of help with that attitude.
If you want to have a nice spell-checker in your FF you can always install "After the Deadline" extension: http://atdfirefox.wordpress.com/

Cheers!


No attitude here, just an observation. Why would I want to install a third party add-on to fix something that shouldn't need fixing? All this worked in Firefox, and is built in to Firefox, from the get go, For some reason it just stopped working. I didn't do anything but add the updates that came from the built in Mint software updater. Also, you can't uninstall Firefox and reinstall it. I tried that, and it didn't do anything. It said it was removed, but when I reinstalled it, all my settings were the same, it didn't default anything.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 9:12 pm

oboedad55 wrote:
LivingColour wrote:Bump... Anyone? This is why Linux will never make it on the desktop. Nothing ever works right out of the box, and there is no help.


Have you installed the dictionary for your language? For example, in my addons I have the US English spellchecker installed.
Also, have a look here; http://support.mozilla.org/en-US/kb/how ... ll-checker


I would assume the English dictionary is installed since all this worked before. I didn't do anything but apply the updates from the built in Mint updater.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby esteban1uy on Tue Jul 17, 2012 9:18 pm

LivingColour wrote:Why would I want to install a third party add-on to fix something that shouldn't need fixing?


If you don't want to use an add-on, then read this: https://bugs.launchpad.net/ubuntu/+sour ... bug/989978

Which language is selected in your Firefox when you right-click on some text input box?
Image
Sorry, I only speak Spanish
User avatar
esteban1uy
Level 5
Level 5
 
Posts: 734
Joined: Sat Nov 12, 2011 6:20 am

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 9:40 pm

esteban1uy wrote:
LivingColour wrote:Why would I want to install a third party add-on to fix something that shouldn't need fixing?


If you don't want to use an add-on, then read this: https://bugs.launchpad.net/ubuntu/+sour ... bug/989978

Which language is selected in your Firefox when you right-click on some text input box?
Image


Ok. that seems to work. But why would that get disabled by something? Now if I could get my Google search box fixed, I would be in business.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby Iurydice on Tue Jul 17, 2012 9:55 pm

About your search box problem...have you tried this?

Type about:config in your browser's address bar.
Type browser.search.suggest.enabled in the filter bar on the page that loads.
If the value of browser.search.suggest.enabled is false, double click on it to make it true.
If you think you're the only one, think again.
User avatar
Iurydice
Level 2
Level 2
 
Posts: 68
Joined: Mon Apr 07, 2008 4:18 pm

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 10:13 pm

Iurydice wrote:About your search box problem...have you tried this?

Type about:config in your browser's address bar.
Type browser.search.suggest.enabled in the filter bar on the page that loads.
If the value of browser.search.suggest.enabled is false, double click on it to make it true.


It was already true.

Here is what the line says:

browser.search.suggest.enabled;true
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby Iurydice on Tue Jul 17, 2012 10:25 pm

I see. :?

I suppose that "Show search suggestions" is also enabled in your "Manage Search Engines" box?

The problem might be in the search plugin itself. If you haven't tried this yet, try installing it again as described here: http://www.makeuseof.com/tag/10-firefox ... ggestions/

Basically, you'd remove the existing Google in Manage Search Engines and add the first one from this list: http://mycroft.mozdev.org/google-search-plugins.html

You can also add some of the other engines just to test if their autosuggest works (I'm only writing this because you haven't specified whether this happens only with Google, sorry if I'm being useless and suggesting things you already tried).

Good luck, I hope this works 'cause I'm running out of ideas here :lol:
If you think you're the only one, think again.
User avatar
Iurydice
Level 2
Level 2
 
Posts: 68
Joined: Mon Apr 07, 2008 4:18 pm

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 10:38 pm

Iurydice wrote:I see. :?

I suppose that "Show search suggestions" is also enabled in your "Manage Search Engines" box?

The problem might be in the search plugin itself. If you haven't tried this yet, try installing it again as described here: http://www.makeuseof.com/tag/10-firefox ... ggestions/

Basically, you'd remove the existing Google in Manage Search Engines and add the first one from this list: http://mycroft.mozdev.org/google-search-plugins.html

You can also add some of the other engines just to test if their autosuggest works (I'm only writing this because you haven't specified whether this happens only with Google, sorry if I'm being useless and suggesting things you already tried).

Good luck, I hope this works 'cause I'm running out of ideas here :lol:


No dice man.... Now I can't even get Google back as a search box option. It might be because of the new Firefox version that came out today. But my issues with the search suggestions not working were before that.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 10:43 pm

On a side note, I do get search suggestion for Yahoo. I don't know if I had the before or not because i used Google after i added it.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby Iurydice on Tue Jul 17, 2012 11:00 pm

LivingColour wrote:Now I can't even get Google back as a search box option.


Why not? What happens when you try to add the one from the list I linked in the previous post?
(To install it, you just click on the first one, but you have to enable JavaScript, so if you're using NoScript, review the permissions first. If it doesn't show up in the search box as an option after you've added it, just try restarting FF.)

Anyway, if Yahoo works, then there's definitely something wrong with the Google engine you have. It's not because of the update - I have the newest version of FF and it works for me, it worked before the update as well.
If you think you're the only one, think again.
User avatar
Iurydice
Level 2
Level 2
 
Posts: 68
Joined: Mon Apr 07, 2008 4:18 pm

Re: Firefox Issues

Postby LivingColour on Tue Jul 17, 2012 11:14 pm

When I click on the arrow to manage search engines, then click get more search engines to add Google I get sent to this site:

https://addons.mozilla.org/en-US/firefox/search-tools/

And almost nothing is there. Not an official Google option for sure.

Edit: I also hit restore defaults to see if that would help anything. That is why I lost Google in the first place.
User avatar
LivingColour
Level 1
Level 1
 
Posts: 25
Joined: Fri Jun 15, 2012 6:38 pm

Re: Firefox Issues

Postby Iurydice on Tue Jul 17, 2012 11:21 pm

That's because you're trying to add it through the Manage Search Engines box. But that is not what I told you to do. What I meant is - go here: http://mycroft.mozdev.org/google-search-plugins.html, click on the first Google entry under Main Engines. When you do, it should look like this. I'm sure you know how to proceed from there :wink:
If you think you're the only one, think again.
User avatar
Iurydice
Level 2
Level 2
 
Posts: 68
Joined: Mon Apr 07, 2008 4:18 pm

Re: Firefox Issues

Postby BillG541 on Wed Jul 18, 2012 12:36 am

Since I upgraded to ff14 earlier today. when I right click the context menu doesn't appear and ff freezes up. Is anyone else seeing this problem, or is there a fix? Thank you for your help.
BillG541
Level 1
Level 1
 
Posts: 2
Joined: Thu May 24, 2012 6:20 pm

Re: Firefox Issues

Postby ingeva on Wed Jul 18, 2012 4:09 am

LivingColour wrote:Bump... Anyone? This is why Linux will never make it on the desktop. Nothing ever works right out of the box, and there is no help.

There's a hundred times more help than there ever was with windows, even if windows has ten times more users.
The problem is, of course, that the majority of windows users Know Nothing, because M$ doesn't want them to. :evil:
Mint rules!
User avatar
ingeva
Level 2
Level 2
 
Posts: 76
Joined: Wed Jun 20, 2012 3:39 am
Location: Sandvika, Norway

Linux Mint is funded by ads and donations.
 
Next

Return to Software & Applications

Who is online

Users browsing this forum: Google Feedfetcher and 17 guests