DVD drive causing failed boot (updated)

Questions about hardware and drivers
Forum rules
Before you post please read this

DVD drive causing failed boot (updated)

Postby ayocam on Wed Jul 18, 2012 12:19 pm

(I am editing to add this information. I have found the cause of the problem. If I move the DVD drive from a ASmedia SATAIII port to a Intel SATAIII port everything runs A OK. Problem appears to be that neither distro supports the ASmedia SATA ports of my Maximus V Gene MB)

I recently installed LMDE 201204 (I started with lm13 cin but after having the same problems thought I would try another distro) The machine hangs on boot and I managed to narrow it down to the DVD, unplugged it and install went like a charm. (after reading my post I thought I should add I unplugged the DVD and did a USB install, was originally attempting to install from DVD) Setup existing RAID and everything else without a hitch. Thought if I plugged drive in after install maybe the problem would be fixed; however, it still persists. I took a couple of pictures of the screen, one from a regular boot and the other a compatibility boot; however, it won't let me post the pictures here so I'll type it all out.

My system is an ASUS ROG Maximus V Gene, i5-3570K, XFX Radeon 6850HD, 250G SSD as OS drive with 2 HDD setup as RAID. My DVD multidrive is a lite-on. I thought I still had the box with an old reader in it but I do not, windows 7 recognizes it at
"ATAPI iHAS324 B ATA Device"

On a regular boot the first error line is:

xhci_hcd 0000:00:14.0: Failed to enable MSI-X
ata7.00: exception Emask 0x52 SAct 0x0 SErr 0xffffffff action 0xe frozen
ata7:SError : { RecovData RecovVomm UnrecovData Persist Proto HostInt PHYRdyChg PHYInt CommWake 10B8B Dispar BadCRC Handshk LinkSeq TrStaTrns UnrecFIS DevExch }
ata7.00: failed command: IDENTIFY PACKET DEVICE
ata7.00: cmd a1/00:01:00:00:00/)):00:00:00:00/00 tag 0 pio 512 in
res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x56 (ATA bus error)
ata7.00: status: {DRDY}

On a compatibility boot the errors on the screen are:
(my blackwidow ultimate is loaded b4 the DVD in this mode)
ata5: SATA link down (SStatys 0 SControl 300)
scsi 6:0:0:0: CD-ROM ATAPI iHAS324 B ALI9 PQ : 0 ANSI: 5
ata8: SATA link down (SStatus 0 SControl 300)
sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
cdrom: Uniform CD-ROM driver Revision: 3.20

After the last line I typed the error continues identical to what I typed previous for the regular boot error starting on the second line. Only very first line is omitted, the 'Failed to enable MSI-X' line

My first time touching Linux in quite a few years and I am very impressed so far! Has come a long way, the install was easy for the most part. I was somehow expecting problems because oh how new my MB is...
I am contemplating making this my main OS (if only I could play bf3 and skyrim)

Any assistance would be greatly appreciated! Thank you all very much for taking the time to read
ayocam
Level 1
Level 1
 
Posts: 1
Joined: Wed Jul 18, 2012 11:22 am

Linux Mint is funded by ads and donations.
 

Re: DVD drive causing failed boot (updated)

Postby naviathan on Wed Nov 14, 2012 5:02 pm

Have you found any reasonable reason for this yet? I have all six of my Intel ports taken up so I have to put my CD drive on the ASMedia controller.
naviathan
Level 1
Level 1
 
Posts: 44
Joined: Tue Nov 16, 2010 6:58 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 2 guests